Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 414273 - media-gfx/picasa USE=nsplugin - alternatively depend on www-client/firefox / www-client/firefox-bin
Summary: media-gfx/picasa USE=nsplugin - alternatively depend on www-client/firefox / ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-01 16:21 UTC by Jan Buecken
Modified: 2013-03-27 13:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,4.41 KB, text/plain)
2012-05-01 16:22 UTC, Jan Buecken
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Buecken 2012-05-01 16:21:09 UTC
Install picasa with nsplugin and use firefox-bin usually. Then you must have firefox installed additionally. Isn't it possible to change the picasa ebuild to something like

-nspulgin? ( >=www-client/firefox-3.0.0 )
+nspulgin? ( >=www-client/firefox-3.0.0 || >=www-client/firefox-bin-3.0.0)

?

Reproducible: Always

Steps to Reproduce:
1. Use firefox-bin
2. Install picasa with nsplugin use flag
3. firefox AND firefox-bin will be installed at the same time due to dependencies
Comment 1 Jan Buecken 2012-05-01 16:22:32 UTC
Created attachment 310585 [details]
emerge --info

Only because it should be added every time for a bug report.
Comment 2 Jan Buecken 2012-05-01 16:40:25 UTC
Ok it is more like:
+nsplugin? ( || ( 
+                 >=www-client/firefox-3.0.0
+                 >=www-client/firefox-bin-3.0.0
+               )
+          )
Comment 3 Jeroen Roovers gentoo-dev 2012-05-03 01:01:48 UTC
nsplugin - Build plugin for browsers supporting the Netscape plugin architecture (that is almost any modern browser)

I don't see at all why the RDEPEND is needed. It should work equally fine in Opera or Chromium. Just remove it entirely?
Comment 4 Dion Moult (RETIRED) gentoo-dev 2013-03-27 13:20:36 UTC
Package removed, see bug #434390.