Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 413613 - media-video/h264enc-10.3.6 version bump
Summary: media-video/h264enc-10.3.6 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 543370 (view as bug list)
Depends on:
Blocks: 561160
  Show dependency tree
 
Reported: 2012-04-26 10:21 UTC by Peter Gantner (a.k.a. nephros)
Modified: 2019-04-10 18:25 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-video/h264enc-9.6.0.ebuild (h264enc-9.6.0.ebuild,1023 bytes, text/plain)
2013-09-05 08:48 UTC, Peter Gantner (a.k.a. nephros)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Gantner (a.k.a. nephros) 2012-04-26 10:21:56 UTC
+++ This bug was initially created as a clone of Bug #307935 +++

media-video/h264enc-9.4.6 is available.

Please investigate the dep on media-sound/aacplusenc which blocks media-libs/libaacplus which in turn is needed by recent ffmpeg.

I *think* h264enc only needs a binary called aacplusenc, and that is provided by libaacplus as well.

I have not investigated this though and don't know if they are commandline-compatible.
Comment 1 Denis M. (Phr33d0m) 2013-02-23 04:17:26 UTC
9.4.8 has been released.
Comment 2 Peter Gantner (a.k.a. nephros) 2013-09-05 08:48:22 UTC
Created attachment 357900 [details]
media-video/h264enc-9.6.0.ebuild

ebuild for the current version of the script.

Worksforme^TM
Comment 3 Steve Dibb (RETIRED) gentoo-dev 2014-08-22 18:11:09 UTC
10.2.2 is latest.

I've got a working ebuild, adds support for dcaenc (new ebuild in tree) and for opus audio codec.

Sent out an email to gentoo-dev with feedback for moving opus use flag from local to global.  Once that goes through, I'll bump the ebuild.
Comment 4 Michael Palimaka (kensington) gentoo-dev 2015-03-16 14:17:14 UTC
*** Bug 543370 has been marked as a duplicate of this bug. ***
Comment 5 G.Wolfe Woodbury 2015-06-01 18:56:29 UTC
Is there a technical reason that h264enc requires the installation of media-video/mplayer?

mplayer brings in all sorts of extraneous packages, that, as far as I can tell, are not *required* for h264enc to work.

If it isn't really needed can it be removed from the ebuild's RDEPEND list?
Comment 6 Bob Wya 2015-06-01 19:17:48 UTC
(In reply to G.Wolfe Woodbury from comment #5)
> Is there a technical reason that h264enc requires the installation of
> media-video/mplayer?
> 
> mplayer brings in all sorts of extraneous packages, that, as far as I can
> tell, are not *required* for h264enc to work.
> 
> If it isn't really needed can it be removed from the ebuild's RDEPEND list?

I use h264enc off & on - so I'm familiar with the basic functionality. The check for mplayer should actually be for mencoder (under Gentoo anyway)...
http://en.wikipedia.org/wiki/MEncoder

So it's an Upstream (h264enc) assumption that mencoder will be bundled with mplayer... Easy to fix with some sed magic or a patch... :-)
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-04-10 18:25:13 UTC
10.4.7 is the current version, so I guess this has been handled sometime in the past.