Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 413489 - >=gnustep-base/gnustep-gui-0.22.0 links against its own installed libraries (including on ICU upgrades with "ld: warning: libicuuc.so.48, needed by /usr/lib64/libgnustep-gui.so, not found")
Summary: >=gnustep-base/gnustep-gui-0.22.0 links against its own installed libraries (...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gnustep herd
URL:
Whiteboard:
Keywords:
: 491396 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-25 11:28 UTC by José Romildo Malaquias
Modified: 2014-01-29 15:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnustep-base:gnustep-gui-0.22.0:20120425-112349.log (gnustep-base:gnustep-gui-0.22.0:20120425-112349.log,186.42 KB, text/plain)
2012-04-25 11:28 UTC, José Romildo Malaquias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description José Romildo Malaquias 2012-04-25 11:28:46 UTC
Created attachment 310037 [details]
gnustep-base:gnustep-gui-0.22.0:20120425-112349.log

gnustep-base/gnustep-gui-0.22.0 does not build on my ~amd64 system:

[...]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.2/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicuuc.so.48, needed by /usr/lib64/libgnustep-gui.so, not found (try using -rpath or -rpath-link)
/usr/lib64/libgnustep-gui.so: undefined reference to `u_getPropertyValueName_48'
/usr/lib64/libgnustep-gui.so: undefined reference to `u_charName_48'
/usr/lib64/libgnustep-gui.so: undefined reference to `u_strFromUTF32_48'
/usr/lib64/libgnustep-gui.so: undefined reference to `u_enumCharNames_48'
/usr/lib64/libgnustep-gui.so: undefined reference to `u_getIntPropertyValue_48'
[...]

This is happening with an up to date system, after running revdep-rebuild.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-04-25 16:00:36 UTC
It's linking against its own installed libraries, which fails because those need to be rebuilt because dev-libs/icu was upgraded.
Comment 2 Alex Buell 2012-05-05 21:04:42 UTC
Confirmed, unmerging gnustep-gui and re-emerging resolves the problem. Might I suggest setting up an emerge block so it uninstalls in order to install gnustep-gui?
Comment 3 Bernard Cafarelli gentoo-dev 2013-03-08 16:11:53 UTC
Also got this while bumping the gnustep packages. It does not look like easy to fix, and adding a "!!" blocker will not be allowed if applications depending on gnustep are installed... Hmm tricky
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-19 02:52:54 UTC
*** Bug 491396 has been marked as a duplicate of this bug. ***
Comment 5 Bernard Cafarelli gentoo-dev 2014-01-29 15:17:46 UTC
From upstream discussions, should be fixed with gnustep-gui-0.24.0