Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 413131 - www-client/firefox - sdk binaries are not executable
Summary: www-client/firefox - sdk binaries are not executable
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-22 18:00 UTC by Alon Bar-Lev
Modified: 2017-08-26 18:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alon Bar-Lev 2012-04-22 18:00:40 UTC
Hello,

When compiling firefox with -minimal, sdk is installed, but sdk binaries are not executable.
---
# ls -la /usr/lib/firefox/sdk/bin/
total 172
drwxr-xr-x 3 root root  4096 Apr 22 20:55 .
drwxr-xr-x 4 root root  4096 Apr 22 09:31 ..
-rw-r--r-- 1 root root 17197 Mar 10 00:20 header.py
drwxr-xr-x 2 root root  4096 Apr 22 09:31 ply
-rw-r--r-- 1 root root 12924 Mar 10 00:20 typelib.py
-rw-r--r-- 1 root root  1645 Apr 22 02:43 xpidllex.py
-rw-r--r-- 1 root root 49761 Mar 10 00:20 xpidl.py
-rw-r--r-- 1 root root 13337 Apr 22 02:43 xpidlyacc.py
-rw-r--r-- 1 root root 50711 Mar 10 00:20 xpt.py
---

Also, the python header is not fixed to meet python2, I think that the python eclass is capable of doing that.

Workaround: execute using python2.

Thanks!
Comment 1 Jory A. Pratt gentoo-dev 2012-05-08 15:48:07 UTC
The scripts are designed to be called from a Makefile, they are not intended to executed standalone. While I can address the python2 issue, I will not make the scripts executable.
Comment 2 Alon Bar-Lev 2012-05-08 15:54:49 UTC
(In reply to comment #1)
> The scripts are designed to be called from a Makefile, they are not intended
> to executed standalone. While I can address the python2 issue, I will not
> make the scripts executable.

Thank you for your answer.
First time I hear a script that should be run from makefile is different in any nature?
Why is it different? Why should it be none executable? Why does makefile care if this is a script in python, bash or an executable?

And if not meant to be executable, why do they have #!/usr/bin/env python in their first line?

Please educate me some more.
Comment 3 Jory A. Pratt gentoo-dev 2017-08-26 17:56:05 UTC
If you feel I have closed your bug and it is still a current issue, please reopen and update it completely. We will not work bugs that have no ebuild in tree any longer or can not be reproduced with a current system.

Thank You for your support and understanding
The Mozilla Team
Comment 4 Alon Bar-Lev gentoo-dev 2017-08-26 18:05:13 UTC
Kinda simple, sdk is no longer installed in Gentoo.