Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412461 - media-gfx/inkscape with dev-libs/glib-2.32.1 - /usr/include/glib-2.0/glib/gtypes.h:28:2: error: #error "Only <glib.h> can be included directly."
Summary: media-gfx/inkscape with dev-libs/glib-2.32.1 - /usr/include/glib-2.0/glib/gty...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL: https://bugs.launchpad.net/inkscape/+...
Whiteboard:
Keywords:
: 421771 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-04-18 05:00 UTC by salamanderrake
Modified: 2012-06-19 09:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build.log (build.log,42.07 KB, text/plain)
2012-04-18 05:00 UTC, salamanderrake
Details
output of emerge --info =media-gfx/inkscape-0.48.2 (inkscape-info.log,4.79 KB, text/plain)
2012-04-18 05:02 UTC, salamanderrake
Details
inkscape enviroment file (enviroment-inkscape.log,119.36 KB, text/plain)
2012-04-18 05:04 UTC, salamanderrake
Details

Note You need to log in before you can comment on or make changes to this bug.
Description salamanderrake 2012-04-18 05:00:41 UTC
Created attachment 309375 [details]
full build.log

compiling inkscape with glib 2.32.1 with multiple 
"/usr/include/glib-2.0/glib/gtypes.h:28:2: error: #error "Only <glib.h> can be included directly.""
errors.

** NOTE: I do have glib-2.32.1 keyworded ~amd64 **
Comment 1 salamanderrake 2012-04-18 05:02:31 UTC
Created attachment 309377 [details]
output of emerge --info =media-gfx/inkscape-0.48.2
Comment 2 salamanderrake 2012-04-18 05:04:41 UTC
Created attachment 309379 [details]
inkscape enviroment file
Comment 3 Anton Kochkov 2012-04-20 17:15:48 UTC
(In reply to comment #2)
> Created attachment 309379 [details]
> inkscape enviroment file

Looks like fixed in inkscape-0.48.3.1, try it.
Comment 4 Pacho Ramos gentoo-dev 2012-04-20 20:05:20 UTC
0.48.3 should fix it
Comment 5 salamanderrake 2012-04-21 15:06:30 UTC
Inkscape version 0.48.3.1 in amd64. Thank you.
Comment 6 salamanderrake 2012-04-21 15:08:11 UTC
I ment inkscape version 0.48.3.1 *compiles fine in amd64.
Comment 7 Maxim Kachur 2012-04-26 12:47:21 UTC
=media-gfx/inkscape-0.48.3.1 built ok on amd64.
Comment 8 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-05-04 02:49:10 UTC
(In reply to comment #4)
(In reply to comment #5)
(In reply to comment #6)
(In reply to comment #7)

Marking this as fixed then.
Comment 9 Samuli Suominen gentoo-dev 2012-06-19 09:33:30 UTC
*** Bug 421771 has been marked as a duplicate of this bug. ***