Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412365 - x11-misc/parcellite with >=dev-libs/glib-2.31 - /usr/include/glib-2.0/glib/gtypes.h:28:2: error: #error "Only <glib.h> can be included directly."
Summary: x11-misc/parcellite with >=dev-libs/glib-2.31 - /usr/include/glib-2.0/glib/gt...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords: PATCH
: 413459 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-04-17 16:11 UTC by Elis Axelsson
Modified: 2012-05-04 15:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log of the failed build (build.log,8.61 KB, text/plain)
2012-04-17 16:13 UTC, Elis Axelsson
Details
Patch that fixes the compilation issue with parcellite and >=glib-2.32.0 (parcellite-glib-2.32.0.patch,297 bytes, patch)
2012-04-17 16:22 UTC, Daniel Kuehn (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Elis Axelsson 2012-04-17 16:11:51 UTC
Any version of x11-misc/parcellite in the tree fails to build with >=dev-libs/glib-2.32.0.

Reproducible: Always

Steps to Reproduce:
1. Get >=dev-libs/glib-2.32.0
2. emerge x11-misc/parcellite
Actual Results:  
Build failure

Expected Results:  
Successful build
Comment 1 Elis Axelsson 2012-04-17 16:13:30 UTC
Created attachment 309281 [details]
build.log of the failed build
Comment 2 Daniel Kuehn (RETIRED) gentoo-dev 2012-04-17 16:16:07 UTC
I can reproduce the error building with glib-2.32.1

A simple fix in keybinder.h from <glib/gtypes.h> to <glib.h> was needed to make parcellite compile and install successfully.
Comment 3 Daniel Kuehn (RETIRED) gentoo-dev 2012-04-17 16:22:30 UTC
Created attachment 309283 [details, diff]
Patch that fixes the compilation issue with parcellite and >=glib-2.32.0
Comment 4 Samuli Suominen gentoo-dev 2012-04-25 11:26:07 UTC
*** Bug 413459 has been marked as a duplicate of this bug. ***
Comment 5 Jean-Claude Gervais 2012-04-29 23:53:41 UTC
Same problem trying to build epdfview-0.1.8 on x86

i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../..    -DDATADIR='"/usr/share/epdfview"' -I../../src -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/libdrm   -Os -march=core2 -pipe -Wall -Wno-long-long -DNDEBUG -DG_DISABLE_ASSERT -c -o libshell_gtk_a-PrintView.o `test -f 'PrintView.cxx' || echo './'`PrintView.cxx
In file included from StockIcons.h:21:0,
                 from StockIcons.cxx:23:
/usr/include/glib-2.0/glib/gmacros.h:32:2: error: #error "Only <glib.h> can be included directly."
Comment 6 Samuli Suominen gentoo-dev 2012-04-30 12:12:17 UTC
(In reply to comment #5)
> Same problem trying to build epdfview-0.1.8 on x86
> 
> i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../..   
> -DDATADIR='"/usr/share/epdfview"' -I../../src -pthread
> -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
> -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0
> -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1
> -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/libdrm   -Os
> -march=core2 -pipe -Wall -Wno-long-long -DNDEBUG -DG_DISABLE_ASSERT -c -o
> libshell_gtk_a-PrintView.o `test -f 'PrintView.cxx' || echo
> './'`PrintView.cxx
> In file included from StockIcons.h:21:0,
>                  from StockIcons.cxx:23:
> /usr/include/glib-2.0/glib/gmacros.h:32:2: error: #error "Only <glib.h> can
> be included directly."

And why do you think this has anything do with parcellite? epdfview is a different application. file a new bug.
Comment 7 Elis Axelsson 2012-05-04 07:09:51 UTC
Patch is accepted upstream.

http://sourceforge.net/tracker/?func=detail&atid=1097277&aid=3518845&group_id=235597
Comment 8 Samuli Suominen gentoo-dev 2012-05-04 07:30:54 UTC
patch added to portage for version 1.0.2_rc5, thanks guys

(one bug, one package)