Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412339 - media-sound/rhythmbox-0.{12.8-r1,13.3}: Remove unused net-libs/xulrunner depend because internal headers are used instead
Summary: media-sound/rhythmbox-0.{12.8-r1,13.3}: Remove unused net-libs/xulrunner depe...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xulrunner
  Show dependency tree
 
Reported: 2012-04-17 13:34 UTC by Samuli Suominen (RETIRED)
Modified: 2012-04-24 10:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen (RETIRED) gentoo-dev 2012-04-17 13:34:09 UTC
net-libs/xulrunner is going away. bug 403415.

do you still want to try to port these old versions to npapi-sdk or are you fine with dropping the support of nsplugin from them?

rhythmbox-0.12.8-r1.ebuild:	nsplugin? ( net-libs/xulrunner )
rhythmbox-0.13.3.ebuild:	nsplugin? ( net-libs/xulrunner )
Comment 1 Pacho Ramos gentoo-dev 2012-04-17 18:51:57 UTC
I wouldn't put much effort on old 0.xx rhythmbox releases... but the rest of the team knows more about rhythmbox-2.96 status and stability :-/
Comment 2 Gilles Dartiguelongue gentoo-dev 2012-04-17 23:11:07 UTC
Erm, rhythmbox does not require xulrunner to build its nsplugin afaik or do I misunderstand the problem ?
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2012-04-18 07:54:47 UTC
(In reply to comment #2)
> Erm, rhythmbox does not require xulrunner to build its nsplugin afaik or do
> I misunderstand the problem ?

The problem is that the 2 older ebuilds directly depend on net-libs/xulrunner. 
If they are really redudant dependencies, please just drop the deps and the bug is done.
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2012-04-21 12:03:32 UTC
The podcast/ directory has bundled np*.h headers for building the plug-in. It looks like xulrunner was never used and was simply a redudant dependency. I've tested this with 0.12.8-r1. 

So,

+  21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+  rhythmbox-0.12.8-r1.ebuild, rhythmbox-0.13.3.ebuild:
+  Remove unused net-libs/xulrunner from dependencies because
+  librhythmbox-itms-detection-plugin.so is using internal np*.h headers within
+  rhythmbox tarball wrt #412339

http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.13.3.ebuild?r1=1.7&r2=1.8

http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild?r1=1.19&r2=1.20
Comment 5 Gilles Dartiguelongue gentoo-dev 2012-04-24 10:28:35 UTC
Fine with me. thanks.