Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412217 - dev-libs/redland-1.0.15 has malformed Makefile, won't emerge: "missing separator"
Summary: dev-libs/redland-1.0.15 has malformed Makefile, won't emerge: "missing separa...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-16 14:17 UTC by N. Andrew Walsh
Modified: 2014-10-21 04:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log from redland compile failure (redland-failure.log,20.60 KB, text/plain)
2012-04-16 14:18 UTC, N. Andrew Walsh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description N. Andrew Walsh 2012-04-16 14:17:17 UTC
Trying to emerge dev-libs/redland-1.0.15 results in the following failure:

Redland build summary:

  Using modular storage backends in /usr/local/lib/redland:/usr/lib64/redland

  Oracle Berkeley DB (BDB) : Version 4.8 (library db-4.8 in /usr/lib)
  Triple stores available  : memory file hashes(memory) trees hashes(bdb 4.8)
  Triple stores enabled    : memory file hashes trees
  RDF parsers              : raptor(system 2.0.7)
  RDF query                : rasqal(system 0.9.28)
  Content digests          : md5 sha1

>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-libs/redland-1.0.15/work/redland-1.0.15 ...
make -j5 
Makefile:262: *** missing separator.  Stop.
 * ERROR: dev-libs/redland-1.0.15 failed (compile phase):


Reproducible: Always

Steps to Reproduce:
1. emerge dev-libs/redland-1.0.15
2. it fails
3. emo tears
Actual Results:  
I got that error above.

Expected Results:  
the makefile should use the correct tab whitespace, and thus make corectly.

# emerge --info
Portage 2.1.10.56 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.3.1-gentoo x86_64)
=================================================================
System uname: Linux-3.3.1-gentoo-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.1
Timestamp of tree: Sun, 15 Apr 2012 12:15:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3, 3.1.4-r4, 3.2.2-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo pd-overlay x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Mendeley-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.lagis.at/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.web4u.cz/ ftp://gentoo.mirror.web4u.cz/ ftp://ftp.klid.dk/gentoo/ http://mirror.uni-c.dk/pub/gentoo/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://mirror.netcologne.de/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://de-mirror.org/distro/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://mirror.netcologne.de/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.ipv6.uni-muenster.de/pub/linux/distributions/gentoo ftp://gentoo.inf.elte.hu/ http://gentoo.inf.elte.hu/ http://ftp.heanet.ie/pub/gentoo/ ftp://ftp.heanet.ie/pub/gentoo/ ftp://ftp.df.lth.se/pub/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ http://gentoo.kiev.ua/ftp/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US.utf8 de de_DE.utf8"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/pd-overlay /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi aim alsa amd64 apm audiofile bash-completion berkdb bzip2 cairo cddb cdinstall cdparanoia cdr clamav cli consolekit cracklib crypt css cups curl curlwrappers cxx dbus directfb dri dvd dvdr dvdread encode ffmpeg fftw firefox flac fortran ftp gdbm geoip gif gimp glut gpm graphite gstreamer gtk hddtemp iconv icq ieee1394 imagemagick imap imlib ipv6 jack java java6 javascript jikes joystick jpeg kde kde4 lame latex ldap libsamplerate libwww lm_sensors mad matroska mmx modules motif mp3 mpeg mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin offensive ogg openal opengl openmp openssl oscar pam pcre pdf perl png policykit posix pppd python qt3support qt4 quicktime raw readline rss scanner session sndfile sockets speex spell sse sse2 ssl suid svg symlink sysfs syslog tcl tcpd tetex theora threads tidy tiff tk translucency truetype udev unicode usb videos vorbis wmf wxwindows x264 xcomposite xetex xine xml xorg xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US.utf8 de de_DE.utf8" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 N. Andrew Walsh 2012-04-16 14:18:55 UTC
Created attachment 309145 [details]
build.log from redland compile failure
Comment 2 N. Andrew Walsh 2012-04-16 14:20:37 UTC
#emerge --info =dev-libs/redland-1.0.15
dev-libs/redland-1.0.15 was built with the following:
USE="berkdb (multilib) ssl xml -iodbc -mysql -odbc -postgres -sqlite -static-libs"
Comment 3 N. Andrew Walsh 2012-04-16 14:21:53 UTC
# emerge -pqv =dev-libs/redland-1.0.15
[ebuild   R   ] dev-libs/redland-1.0.15  USE="berkdb ssl xml -iodbc -mysql -odbc -postgres -sqlite -static-libs"
Comment 4 Samuli Suominen gentoo-dev 2012-04-16 17:35:29 UTC
>>> Compiling source in /var/tmp/portage/dev-libs/redland-1.0.15/work/redland-1.0.15 ...
make -j5 
Makefile:262: *** missing separator.  Stop.

That 262 there is a line number. Please post the relavent information (like Makefile in attachment, or if you know what to look, just the offending line(s))

Please reopen the bug once done, thanks
Comment 5 N. Andrew Walsh 2012-04-16 17:42:56 UTC
Lines 260-263 read:

ODBC_CFLAGS = iODBC Demonstration program
This program shows an interactive SQL processor
ODBC_LIBS = iODBC Demonstration program


Looks like someone forgot to comment the line out, maybe?
Comment 6 N. Andrew Walsh 2012-04-16 17:47:14 UTC
oh, and, uh … that's /var/tmp/portage/dev-libs/redland-1.0.15/work/redland-1.0.15/Makefile I just excerpted. Sorry for the lack of info.
Comment 7 Samuli Suominen gentoo-dev 2014-10-21 04:57:07 UTC
looks like this isn't a problem with 1.0.17 anymore, grepped the source tree