Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412157 - dev-db/mysql-workbench-5.2.38 fails to compile with glib-2.32.0 <glib/gthreads.h>
Summary: dev-db/mysql-workbench-5.2.38 fails to compile with glib-2.32.0 <glib/gthread...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Hans de Graaff
URL: http://bugs.mysql.com/bug.php?id=63705
Whiteboard:
Keywords:
: 412265 429600 429638 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-04-16 00:40 UTC by goeland86
Modified: 2012-08-03 13:46 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
revised ebuild including applying the patch (mysql-workbench-5.2.38-r1.ebuild,2.35 KB, text/plain)
2012-04-16 00:40 UTC, goeland86
Details
patch to fix all calls to includes which need to be replaced by glib.h (mysql-workbench-5.2.38-glib_2_32_0.patch,2.74 KB, patch)
2012-04-16 00:41 UTC, goeland86
Details | Diff
mysql-workbench-5.2.39-r1.ebuild (mysql-workbench-5.2.39-r1.ebuild,2.35 KB, text/plain)
2012-04-17 12:57 UTC, goeland86
Details

Note You need to log in before you can comment on or make changes to this bug.
Description goeland86 2012-04-16 00:40:02 UTC
Glib changed the interface and returns an error if an application tries to directly include glib/gthreads.h I have seen the behavior with other applications, but this is the one I patched.



Reproducible: Always

Steps to Reproduce:
1. emerge =dev-libs/glib-2.32.0
2. emerge mysql-workbench (if on ~amd64 this will be =dev-db/mysql-workbench-5.2.38

Actual Results:  
observe error about including <glib/gthreads.h> in library/canvas/src/mdc_canvas_view.h 

Expected Results:  
Expected compilation without error

This occurs with other applications, any code that has a #include <glib/gthreads.h> will fail. I've noticed the same behavior in gtk-engines-nodoka, though that package is what I consider optional, therefore I ignored it. 
However mysql-workbench is a critical admin tool for mysql databases, and I prefer it to alternatives to work with. As such I looked closer to the problem and created a patch for the code and a local ebuild.
Comment 1 goeland86 2012-04-16 00:40:51 UTC
Created attachment 309103 [details]
revised ebuild including applying the patch
Comment 2 goeland86 2012-04-16 00:41:23 UTC
Created attachment 309105 [details, diff]
patch to fix all calls to includes which need to be replaced by glib.h
Comment 3 goeland86 2012-04-16 00:42:39 UTC
As extra info, the patch fixes the code until it compiles - however it is not just gthreads.h that is affected - see the patch for all includes used by this app.
Comment 4 Hans de Graaff gentoo-dev 2012-04-16 18:51:03 UTC
According to upstream this is fixed in 5.2.39 which is now in the tree.
Comment 5 Hans de Graaff gentoo-dev 2012-04-17 05:36:58 UTC
*** Bug 412265 has been marked as a duplicate of this bug. ***
Comment 6 Juergen Rose 2012-04-17 07:10:36 UTC
Bug 412265 shows that it is not fixed with 5.2.39.
Comment 7 goeland86 2012-04-17 12:57:38 UTC
Created attachment 309249 [details]
mysql-workbench-5.2.39-r1.ebuild

Patch created for 5.2.38 works on 5.2.39 as well.

Probably just a temporary fix, but ebuild for patching the code for 5.2.39 is in the ebuild mysql-workbench-5.2.39-r1.ebuild
Comment 8 Hans de Graaff gentoo-dev 2012-04-17 18:21:37 UTC
(In reply to comment #7)

> Patch created for 5.2.38 works on 5.2.39 as well.

Thanks, I have now applied this to CVS (no revision bump).
Comment 9 Hans de Graaff gentoo-dev 2012-08-03 10:42:00 UTC
*** Bug 429600 has been marked as a duplicate of this bug. ***
Comment 10 Hans de Graaff gentoo-dev 2012-08-03 13:46:06 UTC
*** Bug 429638 has been marked as a duplicate of this bug. ***