Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 411747 - x11-drivers/xf86-video-ati 6.14.3-6.14.4: Vertical pixel-line display artifacts from fvwm desktop menu
Summary: x11-drivers/xf86-video-ati 6.14.3-6.14.4: Vertical pixel-line display artifa...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 15:23 UTC by Phil Stracchino (Unix Ronin)
Modified: 2015-02-22 21:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Screen grab of the menu showing the artifact (glitch.png,87.68 KB, image/png)
2012-04-12 15:24 UTC, Phil Stracchino (Unix Ronin)
Details
The xpm texture in use (stone.xpm,172.37 KB, image/xpm)
2012-04-12 15:26 UTC, Phil Stracchino (Unix Ronin)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Stracchino (Unix Ronin) 2012-04-12 15:23:17 UTC
I have a RadeonHD 5500 series card, all appropriate drivers etc fully up to date, kernel 3.3.0 at present, drm enabled etc, x11-wm/fvwm-2.6.3, x11-libs/libXpm-3.5.10, and a tiled xpm background for my fvwm menus.  Roughly one time in five, pulling down the fvwm desktop menu will result in a single-pixel-wide broken vertical line, usually mostly black/white/grey, down the length of the menu, aligned with the mouse pointer.  This line often, but not always, extends beyond the menu and onto the desktop.  If it extends onto the desktop, it will be left behind after the menu disappears until that spot is redrawn as a result of any other event.  Opinion in #gentoo seems to be that it's a radeon driver bug, possibly tied to this specific card series.  I also asked in #radeon, where the problem was unknown, and in #fvwm, where the fvwm maintainer believes it to be possibly an xpm issue; however, upgrading libxpm and using a different xpm file had no effect, I have not seen the issue manifest anywhere else the same xpm texture is used, and removing the xpm background from the menu reduces the frequency of the problem by about half but does not eliminate it altogether.  Thomas Adam (fvwm maintainer) suggested it was related to tiling the xpm, but the xpm texture is wider than the menu and does not need to be horizontally tiled to render the menu.  It also does not appear on any other objects or menus rendered by fvwm using the same xpm texture (window list, window ops menu etc).  ONLY the primary desktop menu appears to be affected.

Reproducible: Sometimes

Steps to Reproduce:
1. You may need a RadeonHD 55xx card to reproduce.
2. Update all packages, set up MenuStyle * MenuFace TiledPixmap some.xpm
3. Left-click on the desktop to bring up the main desktop menu.  You may have to do this several times.
Actual Results:  
See attached (or will be attached shortly) screen grab of the menu showing the problem.


Portage 2.1.10.49 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.3.0-gentoo-babylon5 x86_64)
=================================================================
System uname: Linux-3.3.0-gentoo-babylon5-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.0.3
Timestamp of tree: Thu, 12 Apr 2012 06:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo perl-experimental overlay-dev-robbat2 mysql x-alaric
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=amdfam10 -mfpmath=sse -pipe -mcx16 -mpopcnt"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=amdfam10 -mfpmath=sse -pipe -mcx16 -mpopcnt"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo                 ftp://mirror.iawnet.sandia.gov/pub/gentoo                 http://gentoo.cites.uiuc.edu/pub/gentoo                 http://gentoo.chem.wisc.edu/gentoo                 http://gentoo.osuosl.org                 http://www.gtlib.gatech.edu/pub/gentoo                 ftp://mirrors.rit.edu/gentoo                 http://mirrors.cs.wmich.edu/gentoo                 "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/perl-experimental /var/lib/layman/robbat2 /var/lib/layman/mysql /var/lib/alaric"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif ffmpeg firefox flac fltk fortran gdbm gdu gif gpm gtk iconv id3tag imagemagick ipv6 java jpeg jpeg2k kde lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session speex spell sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff tk tools truetype udev unicode usb utils vorbis x264 xcb xml xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="emu10k1 hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

[I] x11-drivers/radeon-ucode
     Available versions:  20110302 20110531 (~)20120320
     Installed versions:  20120320(08:26:20 AM 04/12/2012)
     Homepage:            http://people.freedesktop.org/~agd5f/radeon_ucode/
     Description:         IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs

[I] x11-drivers/xf86-input-evdev
     Available versions:  2.6.0 (~)2.7.0
     Installed versions:  2.7.0(08:27:13 AM 04/12/2012)
     Homepage:            http://xorg.freedesktop.org/
     Description:         Generic Linux input driver

[I] x11-drivers/xf86-input-keyboard
     Available versions:  1.6.0 (~)1.6.1
     Installed versions:  1.6.1(08:26:51 AM 04/12/2012)
     Homepage:            http://xorg.freedesktop.org/
     Description:         Keyboard input driver

[I] x11-drivers/xf86-input-mouse
     Available versions:  1.7.0 1.7.1 (~)1.7.2
     Installed versions:  1.7.2(08:27:34 AM 04/12/2012)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org driver for mouse input devices

[I] x11-libs/libXpm
     Available versions:  3.5.9 (~)3.5.10 {static-libs}
     Installed versions:  3.5.10(10:11:54 AM 04/12/2012)(-static-libs)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org Xpm library

[I] x11-wm/fvwm
     Available versions:  2.6.2 2.6.3 {bidi debug doc gtk2-perl lock netpbm nls perl png readline rplay stroke svg tk truetype vanilla xinerama}
     Installed versions:  2.6.3(09:05:11 AM 04/12/2012)(bidi gtk2-perl lock netpbm nls perl png readline svg tk truetype -debug -doc -rplay -stroke -vanilla -xinerama)
     Homepage:            http://www.fvwm.org/
     Description:         An extremely powerful ICCCM-compliant multiple virtual desktop window manager


[I] x11-drivers/xf86-video-ati
     Available versions:  6.13.2 6.14.0 6.14.1 6.14.2 6.14.3 (~)6.14.3-r1 (~)6.14.4
     Installed versions:  6.14.4(08:28:36 AM 04/12/2012)
     Homepage:            http://xorg.freedesktop.org/
     Description:         ATI video driver

04:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Redwood PRO [Radeon HD 5500 Series] (prog-if 00 [VGA controller])
        Subsystem: XFX Pine Group Inc. Device 3050
        Flags: bus master, fast devsel, latency 0, IRQ 40
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at fbec0000 (64-bit, non-prefetchable) [size=128K]
        I/O ports at d800 [size=256]
        Expansion ROM at fbea0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: radeon
Comment 1 Phil Stracchino (Unix Ronin) 2012-04-12 15:24:50 UTC
Created attachment 308659 [details]
Screen grab of the menu showing the artifact
Comment 2 Phil Stracchino (Unix Ronin) 2012-04-12 15:26:51 UTC
Created attachment 308661 [details]
The xpm texture in use
Comment 3 Phil Stracchino (Unix Ronin) 2012-04-12 15:31:18 UTC
Update:  I have also just discovered that this artifact is also still occasionally occurring (with lesser frequency) with windows created by xmessage.  Xmessage windows are set in my fvwm configuration to have no titlebar, buttons or handles, but still have a Motif-style frame rendered by fvwm.
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-04-12 15:32:31 UTC
If you suspect a radeon driver bug, make sure that upstream https://bugs.freedesktop.org/ is also aware of the issue and add the upstream bug URL to this report.

To isolate the issue more, you could try the following:
1. See whether changing exa options in xorg.conf makes a difference ("man exa" will show them)
2. On xrandr rotated display, does the screen corruption also appear rotated?
3. Was the problem always present, or did it start happening after an upgrade?
Comment 5 Phil Stracchino (Unix Ronin) 2012-04-12 21:32:07 UTC
(In reply to comment #4)
> If you suspect a radeon driver bug, make sure that upstream
> https://bugs.freedesktop.org/ is also aware of the issue and add the
> upstream bug URL to this report.
> 
> To isolate the issue more, you could try the following:
> 1. See whether changing exa options in xorg.conf makes a difference ("man
> exa" will show them)
> 2. On xrandr rotated display, does the screen corruption also appear rotated?
> 3. Was the problem always present, or did it start happening after an
> upgrade?

1 - Do you have a particular suggestion as to what exa settings might be applicable?

2 - I've just tested and verified that rotating the screen with xrandr also rotates the corruption.  (Man, having my screen logical axes at 90 degrees to my mouse and keyboard is confusing!)

3 - The problem first appeared ...  maybe a month ago, and I've been trying various things since then to diagnose or troubleshoot it on my own, and also somewhat hoping upgrades would fix it.  I honestly don't remember whether it began following an update or not.
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-04-12 21:37:52 UTC
There are only four options, try them all individually.
Comment 7 Phil Stracchino (Unix Ronin) 2012-04-12 21:41:05 UTC
(In reply to comment #6)
> There are only four options, try them all individually.

Just to make sure I understand this right, testing all of these options requires restarting X11, right?  I want to make sure I'm not missing something obvious here.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-04-12 21:54:05 UTC
Yes, after every modification of xorg.conf you need to restart X for the change to take effect.
Comment 9 Phil Stracchino (Unix Ronin) 2012-04-13 11:57:33 UTC
(In reply to comment #8)

Results, after testing this morning:

Setting EXANoComposite has no visible effect.

Setting MigrationHeuristic has no visible effect.

Setting either EXANoUploadToScreen or EXANoDownloadFromScreen shoots X in the head.  (EXANoDownloadFromScreen prevents X from starting; EXANoUploadToScreen leaves X half-started and the display unresponsive, and I had to ssh in from another machine to regain control.)
Comment 10 Matt Turner gentoo-dev 2015-02-22 21:56:15 UTC
Hopefully fixed long ago. If not, open a bug upstream https://bugs.freedesktop.org/enter_bug.cgi?product=xorg&component=Driver/Radeon