module-rebuild [options] action [category/package]
Where options are:
-X - Emerge based on package names,
not exact versions.
-C - Disable all coloured output.
Where action is one of:
add - Add package to moduledb.
del - Delete a package from moduledb.
toggle - Toggle auto-rebuild of Package.
list - List packages to auto-rebuild.
rebuild - Rebuild packages.
populate - Populate the database with any
packages which currently install
drivers into the running kernel.
These options are inconsistent with the ones used by all other gentoo/genkernel/portage stuff.
A while ago, portage changed from
# emerge unmerge <ebuild>
# emerge --unmerge <ebuild>
My request is to have the same consistency for module-rebuild... for one simple reason: I always write
# module-rebuild --rebuild
followed by me shouting "S*1T!" (which is bad if my kids are around!), followed by
# module-rebuild rebuild
(which always makes me whish for one consistent way for these options/actions/... whatever you call it).
It really should be "module-rebuild --action".
As I'm not really qualified to change this myself, so I RQ this here. Thanks.