Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410721 - sys-apps/portage-2.2.0_alpha99 - Parameter substitution in portage environment files doesn't work anymore
Summary: sys-apps/portage-2.2.0_alpha99 - Parameter substitution in portage environmen...
Status: CONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Configuration (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-03 22:20 UTC by Elias Probst
Modified: 2012-04-04 23:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2012-04-03 22:20:44 UTC
Running sys-apps/portage-2.2.0_alpha99 here.

Running 'emerge -avuDN @world' throws multiple times
"/etc/portage/env/nodebug", line 3: unexpected EOF while looking for matching `}'
at the terminal.

Content of /etc/portage/env/nodebug is:
CFLAGS="${CFLAGS/-ggdb/}"
CXXFLAGS="${CXXFLAGS/-ggdb/}"

The change causing this must have been somewhere between alpha96 and alpha99, as this doesn't happen with alpha96, but with alpha99. Other releases inbetween them aren't available in the tree.


moria ~ # emerge --info
Portage 2.2.0_alpha99 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.3.0-gentoo x86_64)
=================================================================
System uname: Linux-3.3.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-2620M_CPU_@_2.70GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 03 Apr 2012 21:00:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise apokolips eliasp kde x11 aidecoe eliasp-public gamerlay-stable perl-experimental multimedia
Installed sets: @fusioninventory, @kde-4.8, @kde-telepathy, @otrs
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula PUEL AdobeFlash-10.3 Oracle-BCLA-JavaSE IBM-J1.6"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=2 --keep-going --load-average=2.5"
FEATURES="assume-digests binpkg-logs ccache collision-protect distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://mirror.netcologne.de/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="de_DE.utf8"
LC_ALL="C"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/apokolips /var/lib/layman/eliasp /var/lib/layman/kde /var/lib/layman/x11 /var/lib/layman/aidecoe /var/lib/layman/eliasp-public /var/lib/layman/gamerlay /var/lib/layman/perl-experimental /var/lib/layman/multimedia"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 audiofile avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdparanoia cli consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr emboss encode exif fastcgi ffmpeg fftw firefox flac gdbm gdu gif git gnutls gs gstreamer gtk handbook hdri iconv icu imagemagick inotify ipv6 jabber java java6 jpeg jpeg2k kde kerberos kipi kms lame lcms ldap libnotify libsamplerate lzma mac mad matroska mmap mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz mysql ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl pam pango pcre pdf perl plasma png policykit postgres ppds pppd private-headers pulseaudio python qt qt3support qt4 rdesktop readline rss ruby samba sdl semantic-desktop session spell spice sqlite sse sse2 ssl startup-notification subversion svg sysfs taglib tcpd theora tiff truetype udev unicode upnp usb v4l2 vaapi vcd vim-syntax vnc vorbis wmf x264 xcb xcomposite xinerama xml xorg xulrunner xv xvid xvmc zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth caps" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel i965 vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Zac Medico gentoo-dev 2012-04-04 06:51:17 UTC
It never worked. The warning is new though, so now it's obvious that it doesn't work.
Comment 2 Elias Probst 2012-04-04 20:35:55 UTC
(In reply to comment #1)
> It never worked. The warning is new though, so now it's obvious that it
> doesn't work.

I'm pretty sure it worked, as I used this to suppress debug builds with -ggdb in CFLAGS for chromium and other packages.

If it wouldn't have worked, I'd still have seen the warning when building chromium about -ggdb being enabled and the size of resulting build wouldn't have decreased that dramatically after enabling it :)
Comment 3 Zac Medico gentoo-dev 2012-04-04 21:51:03 UTC
It only worked in the sense that it set CFLAGS and CXXFLAGS to empty strings. As you can see in the following commit, the only change was that the warnings were added:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=7342ef701af9eae725d89b784410884560793519
Comment 4 Elias Probst 2012-04-04 23:02:20 UTC
(In reply to comment #3)
> It only worked in the sense that it set CFLAGS and CXXFLAGS to empty
> strings. As you can see in the following commit, the only change was that
> the warnings were added:
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;
> h=7342ef701af9eae725d89b784410884560793519

Great! Thanks a lot for this information.
I probably would have never noticed my CFLAGS being empty in these cases.