Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410333 - media-sound/milkytracker-0.90.85 - In member function ‘virtual bool DecompressorGZIP::decompress(const PPString&, DecompressorBase::Hints)’: DecompressorGZIP.cpp:64:68: erreur: invalid conversion from ‘void**’ to ‘gzFile_s**’ [-fpermissive]
Summary: media-sound/milkytracker-0.90.85 - In member function ‘virtual bool Decompres...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-03-31 14:06 UTC by Sylvain GRIALOU
Modified: 2014-08-29 13:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,58.82 KB, text/plain)
2012-03-31 14:06 UTC, Sylvain GRIALOU
Details
patch1 for milkytracker-0.90.85 (milkytracker-0.90.85-gzfile.patch,843 bytes, patch)
2012-03-31 14:51 UTC, Joonas Niilola
Details | Diff
patch2 for milkytracker-0.90.85 (milkytracker-0.90.85-sdlmain.patch,2.20 KB, patch)
2012-03-31 14:52 UTC, Joonas Niilola
Details | Diff
Fix incorrect type/typecasts in src/compression/DecompressorGZIP.cpp (milkytracker-0.90.85-zlib-casts.patch,673 bytes, patch)
2012-08-28 16:22 UTC, Maks Verver
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain GRIALOU 2012-03-31 14:06:53 UTC
Created attachment 307283 [details]
build.log

milkytracker doesnt builds

http://pastebin.com/nHVz6VTP
Comment 1 Sylvain GRIALOU 2012-03-31 14:10:32 UTC
localhost ~ # emerge --info milkytracker
Portage 2.3.3-r2 (default/linux/amd64/2008.0, gcc-4.6.2, glibc-2.13-r4, 3.3.0-syl x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.0-syl-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.1.8
Timestamp of tree: Sat, 31 Mar 2012 06:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3_pre20120325, 3.2.3_pre20120325
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1.8-r3
sys-apps/openrc:          0.8.3-r5
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.3
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo localhost
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X aac aalib acl alac alsa amd64 berkdb bzip2 cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dvd dvdr dvdread encode flac fortran gdbm gif gpm iconv icu ipv6 jpeg jpeg2k kde lame lua mad matroska minizip mmx mmxext mng modules mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre perl png policykit pppd python qt3support qt4 readline session shout sql sse sse2 ssl svg sysfs tcpd theora tiff truetype unicode vaapi vorbis wavpack webkit x264 xml xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK


localhost ~ # emerge -uDNp milkytracker

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-sound/milkytracker-0.90.85  USE="alsa -jack"
Comment 2 Joonas Niilola gentoo-dev 2012-03-31 14:51:40 UTC
Created attachment 307293 [details, diff]
patch1 for milkytracker-0.90.85
Comment 3 Joonas Niilola gentoo-dev 2012-03-31 14:52:06 UTC
Created attachment 307295 [details, diff]
patch2 for milkytracker-0.90.85
Comment 4 Joonas Niilola gentoo-dev 2012-03-31 14:53:02 UTC
Had this same problem on ~amd64 platform. I found a solution from Arch Linux repositories, 
http://projects.archlinux.org/svntogit/community.git/tree/trunk/arch.patch?h=packages/milkytracker

I only took the necessary parts for milkytracker to compile. I had it install just fine, and the program launches.
Comment 5 Sylvain GRIALOU 2012-03-31 15:27:37 UTC
thanks Joonas :)

written the first one into user patches :

/etc/portage/patches/media-sound/milkytracker-0.90.85/milkytracker-0.90.85-gzfile.patch

and :

FEATURES="localpatch" emerge milkytracker

worked perfectly :)
Comment 6 Maks Verver 2012-08-28 16:20:46 UTC
The zlib-patch is broken.  Yes, it gets the application to compile, but now it will segfault when opening gzipped files, because type casts are wrong.  Clearly the author never bothered to test his changes.  I'll attach a proper patch.
Comment 7 Maks Verver 2012-08-28 16:22:30 UTC
Created attachment 322456 [details, diff]
Fix incorrect type/typecasts in src/compression/DecompressorGZIP.cpp
Comment 8 James L. Hammons 2013-01-30 18:31:25 UTC
(In reply to comment #6)
> The zlib-patch is broken.  Yes, it gets the application to compile, but now
> it will segfault when opening gzipped files, because type casts are wrong. 
> Clearly the author never bothered to test his changes.  I'll attach a proper
> patch.

Confirm that this patch works as advertised. This is on ~amd64. Maybe some kind soul can put this patch in the tree? :-)
Comment 9 Ari Malinen 2014-07-03 11:29:47 UTC
(In reply to Maks Verver from comment #7)
> Created attachment 322456 [details, diff] [details, diff]
> Fix incorrect type/typecasts in src/compression/DecompressorGZIP.cpp

Thanks for the patch. Works great. I added working ebuild to my overlay. I wish someone would merge this to portage tree.
Comment 10 Alexander Berntsen (RETIRED) gentoo-dev 2014-07-03 14:53:04 UTC
Patch worked for me (almost) two years ago. Dunno why it's not committed to Portage. Sound herd care to comment?
Comment 11 Samuli Suominen gentoo-dev 2014-08-29 13:37:46 UTC
media-sound/milkytracker-0.90.86 is in Portage and seems to build fine and looking at the patch attached here, it's fixed similarly too