Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410235 - net-misc/mediatomb-0.12.1-r1 with media-libs/libmp4v2-1.9.1_p479 - ../src/metadata/libmp4v2_handler.cc:77:48: error: ‘MP4GetMetadataName’ was not declared in this scope
Summary: net-misc/mediatomb-0.12.1-r1 with media-libs/libmp4v2-1.9.1_p479 - ../src/met...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Jeremy Olexa (darkside) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-30 12:52 UTC by optiluca@gmail.com
Modified: 2012-04-11 04:49 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,70.16 KB, text/plain)
2012-03-30 12:53 UTC, optiluca@gmail.com
Details
Patch for the libmp4v2-handling (mediatomb-0.12.1-libmp4v2_191_p479.patch,5.75 KB, patch)
2012-04-05 00:12 UTC, Peter Asplund
Details | Diff
Ebuild that uses the new patch (mediatomb-0.12.1-r2.ebuild,3.77 KB, text/plain)
2012-04-05 00:12 UTC, Peter Asplund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description optiluca@gmail.com 2012-03-30 12:52:06 UTC
Title says it all really.  emerge output attached, emerge --info below:

emerge --info mediatomb
Portage 2.2.0_alpha96 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r2, 3.3.0-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.0-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_Q_820_@_1.73GHz-with-gentoo-2.1
Timestamp of tree: Fri, 30 Mar 2012 08:30:01 +0000
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo maggu2810-overlay sunrise powerman benf ikelos v-fox vmware bitcoin gamerlay-stable LOCAL
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/etc/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=y --jobs=8 --load-average=10"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ ftp://mirror.qubenet.net/mirror/gentoo/ http://mirror.bytemark.co.uk/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1"
LINGUAS="en_GB en_US it"
MAKEOPTS="-j8"
PKGDIR="/etc/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/maggu2810-overlay /var/lib/layman/sunrise /var/lib/layman/powerman /var/lib/layman/benf /var/lib/layman/ikelos /var/lib/layman/v-fox /var/lib/layman/vmware /var/lib/layman/bitcoin /var/lib/layman/gamerlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr apm avi bash-completion berkdb bluetooth branding bzip2 cairo caps cdaudio cdda cddb cdr chm cleartype cli consolekit cracklib crypt css cuda cups cxx dbus declarative dhcp dri dts dv dvb dvd dvdr dvdread editor emboss emovix encode exif faac faad fam fame fbcondecor fbsplash ffmpeg firefox flac foomaticdb fortran gcj gd gdbm gdu gif git glitz glx gphoto2 gpm gps gstreamer hdaps iconv id3tag ieee1394 imagemagick inotify ipod ipv6 it jack java java6 joystick jpeg kde kickoff kipi ladspa lastfm lcms ldap libnotify libsamplerate libv4l2 lm_sensors mad matroska mbrola mikmod mmx mng modules mp2 mp3 mp4 mpeg mplayer msn mudflap multilib musicbrainz ncurses networkmanager nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pango pcre pdf phonon plasma pmu png policykit ppds pppd qt qt3support qt4 quicktime readline rtc samba scanner sdl semantic-desktop session skype slp smp snmp spell sse sse2 sse3 ssl ssse3 startup-notification subtitles subversion svg sysfs tcpd theora threads tiff truetype twolame udev unicode usb v4l v4l2 vdpau vorbis wifi wma-fixed x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en_US it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-misc/mediatomb-0.12.1-r1 was built with the following:
USE="(consolekit) exif ffmpeg inotify javascript lastfm libextractor mp4 (multilib) (policykit) taglib thumbnail -debug -mysql"
CFLAGS="-march=native -O2 -pipe -ggdb"
CXXFLAGS="-march=native -O2 -pipe -ggdb"


Reproducible: Always
Comment 1 optiluca@gmail.com 2012-03-30 12:53:37 UTC
Created attachment 307181 [details]
build.log
Comment 2 Jess Haas 2012-03-31 02:26:57 UTC
Just ran into the same problem when I tried to update world. 

From the changelog:
21 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
libmp4v2-1.9.1_p479.ebuild:
Keyword 1.9.1_p479 for ~arch because media-libs/faac is now working.

*libmp4v2-1.9.1_p479 (19 Nov 2011)

19 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
+libmp4v2-1.9.1_p479.ebuild:
Version bump to featured upstream snapshot (unkeyworded for now because of
API and ABI break)

So looks like it was keyworded because of the break in the API but there is now something else that needs it so it was unkeyworded? Do we update the mediatomb dependency or slot it?

Looks like the current stable version of this lib has some serious problems of its own: http://groups.google.com/group/mp4v2/browse_thread/thread/c19e8203ac2a27f0/1192d9fac9ffcd87?lnk=gst&q=noring#1192d9fac9ffcd87 So unkeywording this version should be a good thing.
Comment 3 Jess Haas 2012-03-31 02:33:51 UTC
From the bug reports it looks like there are atleast 3 other programs with the same problem.
Comment 4 Robert 2012-04-04 04:30:00 UTC
I can confirm that I got this same error on x86_64 with 3.3.0-gentoo kernel. It seems that faac had this issue as well because a patch is now included with faac for this new version of libmp4v2. Looks like we need another patch for mediatomb, anyone up for writing it?
Comment 5 Peter Asplund 2012-04-04 22:34:18 UTC
I've now written a patch for the libmp4v2 issue. I haven't tested it with different mp4s, but it compiles and mediatomb starts with it =)

Please review it and comment! Hopefully you think it's good enough to accept.

I've added it to my overlay called AzP: http://gpo.zugaina.org/Overlays/AzP
It doesn't seem to have synced yet, but I guess it'll show up sooner or later.
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-04-04 22:41:53 UTC
Attach it here, please
Comment 7 Peter Asplund 2012-04-04 22:55:21 UTC
Ok, I've already seen some issues with the patch, at least my mediatomb is crasching after a little while now. I'm looking into it.
Comment 8 Peter Asplund 2012-04-05 00:12:02 UTC
Created attachment 307845 [details, diff]
Patch for the libmp4v2-handling

Ok, here we go! I found the (some) issues and resolved the crashes. It now successfully scans my entire library of a couple of thousands of files.
Comment 9 Peter Asplund 2012-04-05 00:12:39 UTC
Created attachment 307847 [details]
Ebuild that uses the new patch

Here's the ebuild for it.
Comment 10 SpanKY gentoo-dev 2012-04-08 18:19:12 UTC
(In reply to comment #8)

fix building for me
Comment 11 Ryan Hill (RETIRED) gentoo-dev 2012-04-11 01:31:50 UTC
works for me too.  darkside i have the fix for bug #407753 queued up.  let me know if you want me to include this as well.
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-04-11 03:19:08 UTC
(In reply to comment #11)
> works for me too.  darkside i have the fix for bug #407753 queued up.  let
> me know if you want me to include this as well.

go ahead. my test env is very fragile and I'm not going to install ~arch to test mediatomb. Thanks!
Comment 13 Ryan Hill (RETIRED) gentoo-dev 2012-04-11 04:49:11 UTC
Fixed in 0.12.1-r2.