Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410065 - net-mail/dovecot-2.1.3 fails at parallel make: fatal error: ../../../src/plugins/quota/rquota.h: No such file or directory
Summary: net-mail/dovecot-2.1.3 fails at parallel make: fatal error: ../../../src/plug...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Eray Aslan
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: parallel-make
  Show dependency tree
 
Reported: 2012-03-28 20:47 UTC by Wonko
Modified: 2021-11-20 11:45 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (net-mail:dovecot-2.1.3:20120328-195150.log,876.42 KB, text/plain)
2012-03-30 09:59 UTC, Wonko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wonko 2012-03-28 20:47:53 UTC
The package compiles fine with MAKEOPTS=-j1.


wonko@weird ~ $ emerge --info net-mail/dovecot
Portage 2.2.0_alpha96 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r2, 3.3.0-gentoo x86_64)                                                                                                                                                                  
=================================================================                                                                                                                                                                                                              
                        System Settings                                                                                                                                                                                                                                        
=================================================================                                                                                                                                                                                                              
System uname: Linux-3.3.0-gentoo-x86_64-AMD_FX-tm-4100_Quad-Core_Processor-with-gentoo-2.1                                                                                                                                                                                     
Timestamp of tree: Wed, 28 Mar 2012 05:15:01 +0000                                                                                                                                                                                                                             
distcc 3.1 x86_64-pc-linux-gnu [disabled]                                                                                                                                                                                                                                      
ccache version 3.1.7 [disabled]                                                                                                                                                                                                                                                
app-shells/bash:          4.2_p24                                                                                                                                                                                                                                              
dev-java/java-config:     2.1.11-r3                                                                                                                                                                                                                                            
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.2.2-r1                                                                                                                                                                                                                         
dev-util/ccache:          3.1.7                                                                                                                                                                                                                                                
dev-util/cmake:           2.8.7-r5                                                                                                                                                                                                                                             
dev-util/pkgconfig:       0.26                                                                                                                                                                                                                                                 
sys-apps/baselayout:      2.1                                                                                                                                                                                                                                                  
sys-apps/openrc:          0.9.9.3                                                                                                                                                                                                                                              
sys-apps/sandbox:         2.5                                                                                                                                                                                                                                                  
sys-devel/autoconf:       2.13, 2.68                                                                                                                                                                                                                                           
sys-devel/automake:       1.9.6-r3, 1.11.1-r1                                                                                                                                                                                                                                  
sys-devel/binutils:       2.22-r1                                                                                                                                                                                                                                              
sys-devel/gcc:            4.4.7, 4.5.3-r2                                                                                                                                                                                                                                      
sys-devel/gcc-config:     1.6                                                                                                                                                                                                                                                  
sys-devel/libtool:        2.4.2                                                                                                                                                                                                                                                
sys-devel/make:           3.82-r3                                                                                                                                                                                                                                              
sys-kernel/linux-headers: 3.3 (virtual/os-headers)                                                                                                                                                                                                                             
sys-libs/glibc:           2.14.1-r2                                                                                                                                                                                                                                            
Repositories: gentoo kde-sunset zugaina sunrise vmware x11 nx kde enlightenment emacs dfreise proaudio science gamerlay-stable local                                                                                                                                           
Installed sets:                                                                                                                                                                                                                                                                
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                                                                                                                                                                 
ACCEPT_LICENSE="* -@EULA"                                                                                                                                                                                                                                                      
CBUILD="x86_64-pc-linux-gnu"                                                                                                                                                                                                                                                   
CFLAGS="-pipe -march=amdfam10 -O2          -floop-interchange -floop-strip-mine -floop-block          -msse -msse2 -msse3 -msse4a -msse4.1 -msse4.2 -m3dnow          -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx          --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /usr/share/X11/xkb /usr/share/openvpn/easy-rsa"
CXXFLAGS="-pipe -march=amdfam10 -O2          -floop-interchange -floop-strip-mine -floop-block          -msse -msse2 -msse3 -msse4a -msse4.1 -msse4.2 -m3dnow          -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx          --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps y --load-average=6.0"
FEATURES="assume-digests binpkg-logs buildpkg buildsyspkg collision-protect distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS=""
GENTOO_MIRRORS="rsync://mirror.netcologne.de/gentoo/ http://gentoo.mneisen.org/"
LANG="de_DE.utf8"
LC_ALL="C"

LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="--jobs --load 5"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/portage/tmpfs"
PORTDIR="/var/portage/tree"
PORTDIR_OVERLAY="/var/portage/layman/kde-sunset /var/portage/layman/zugaina /var/portage/layman/sunrise /var/portage/layman/vmware /var/portage/layman/x11 /var/portage/layman/nx /var/portage/layman/kde /var/portage/layman/enlightenment /var/portage/layman/emacs /var/portage/layman/dfreise /var/portage/layman/pro-audio /var/portage/layman/science /var/portage/layman/gamerlay /var/portage/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi aim alsa amd64 apache2 apm audiofile bash-completion bcmath berkdb bluetooth branding bzip2 cairo calendar cdda cdparanoia cdr cli consolekit cracklib crypt ctype cups cvs cxx dbus declarative dga directfb dri dts dvb dvd dvdr emacs emboss encode exif fam fbcon ffmpeg firefox flac foomaticdb fortran ftp gd gdbm gdu ggi gif gimp ginac git gnutls gphoto2 gpm gtk handbook hddtemp iconv ieee1394 imagemagick imlib ipv6 jabber jack java javascript jbig jpeg jpeg2k kde kipi latex lcms ldap libnotify lm_sensors lzma mad maildir matroska matrox mikmod mime mmx mng modplug modules motif mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz nas ncurses nls nptl nptlonly nsplugin ogg openal opengl openmp oss pam pango pch pcre pdf phonon php plasma plotutils png policykit ppds pppd qt3support qt4 quicktime radius rdesktop readline recode ruby samba scanner sdl semantic-desktop session slang slp smp sndfile sockets sox speex spell sse sse2 sse3 ssl startup-notification subversion svg sysfs tcpd theora threads tiff truetype udev unicode usb videos vim-syntax visualization vnc vorbis wma wmf wxwindows x264 xattr xcb xcomposite xine xinerama xml xorg xosd xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="cgi alias auth_basic authn_file authz_groupfile authz_host authz_owner authz_user dir mime userdir" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FRITZCAPI_CARDS="fcpci" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" LIRC_DEVICES="serial" MISDN_CARDS="avmfritz" PHP_TARGETS="php5-3 php5-4" RUBY_TARGETS="ruby18" SANE_BACKENDS="canon_pp microtek plustek_pp" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-mail/dovecot-2.1.3 was built with the following:
USE="bzip2 (consolekit) ipv6 ldap maildir (multilib) pam (policykit) ssl zlib -caps -cydir -doc -imapc -kerberos -lucene -managesieve -mbox -mdbox -mysql -postgres -sdbox -sieve -sqlite -static-libs -suid -vpopmail"
Comment 1 Eray Aslan gentoo-dev 2012-03-29 09:32:16 UTC
Please attach full build log.  Thank you.
Comment 2 Wonko 2012-03-30 09:59:23 UTC
Created attachment 307175 [details]
Build log

Weird, this is the 2nd time the build log was missing in a report of mine. I'm totally sure I had added it as attachement to the bug.
Comment 3 Wonko 2012-05-09 11:39:18 UTC
Cool, I do not have to report the build failure of net-mail/dovecot-2.1.6 because I already did for 2.1.3. Version 2.1.6 has the same problem, it failed to build two out of three times. Because of my MAKEOPTS="-j -l 5" the actual number of parallel makes depends on the current load, and sometimes it works, sometimes not.

I tried to reproduce this with a fixed number of parallel makes, but I had no success, this loop did not exit:

file=/var/portage/tree/net-mail/dovecot/dovecot-2.1.6.ebuild
for (( i=2; i < 50; i++ ))
do
    ebuild $file clean
    MAKEOPTS=-j$i ebuild $file compile || break
done

And I tried to just emerge it for ten more times with my default options, and again it built every time. Weird. I did not change any settings here. I give up.
Comment 4 Wonko 2012-07-12 15:51:16 UTC
It happens again with 2.1.8, about two out of three times with MAKEOPTS="--jobs --load=5".

I tried for 30 times with MAKEOPTS=--jobs only, end succeeded every time. Then I varied the load. With values from 1 to 6, I get the errors. If I use values greater than or equal to 7, it builds fine.
Comment 5 Stefan Schmiedl 2013-03-07 12:52:56 UTC
After a few failed attempts at emerging dovecot-2.1.15, I found this bug and changed my MAKEOPTS from "-j9 -l4" to "-j9 -l7" and, lo and behold, emerge completed just fine.
Comment 6 Wolfram Schlich (RETIRED) gentoo-dev 2013-12-06 14:37:03 UTC
Same issue here.

With MAKEOPTS="-j8 --load-average=6" compilation aborts with that rquota.h error,
with MAKEOPTS="-j1" it compiles fine.
Comment 7 Daniel Nilsson 2014-06-06 15:29:18 UTC
The same build failure just happened to me with dovecot-2.2.13-r1 on a loaded system (2 cores out of 4 busy with other things).
I'm using MAKEOPTS="-j5 -l4.5".
Retrying the failed build with the same MAKEOPTS but when the system was otherwise idle resulted in a successful build. Previous version have never failed for me but they where all probably built with no other load.
Comment 8 Robin Bankhead 2015-02-23 14:56:26 UTC
Still happening with dovecot-2.2.15.

From the above posts it appears that -l settings are the problem, maybe specifically settings of <7.0 (although it seems unwise to ever set -l that high on a machine that has anything else to be doing!).

Anyone have a theory on this, at least?
Comment 9 Thibaud "thican" CANALE 2015-05-01 12:19:09 UTC
(In reply to Wolfram Schlich from comment #6)
> Same issue here.
> 
> With MAKEOPTS="-j8 --load-average=6" compilation aborts with that rquota.h
> error,
> with MAKEOPTS="-j1" it compiles fine.

Still here with net-mail/dovecot-2.2.16-r1, with the same behaviour.
Comment 10 Thibaud "thican" CANALE 2015-05-01 12:49:03 UTC
(In reply to Thibaud "thican" CANALE from comment #9)
> (In reply to Wolfram Schlich from comment #6)
> > Same issue here.
> > 
> > With MAKEOPTS="-j8 --load-average=6" compilation aborts with that rquota.h
> > error,
> > with MAKEOPTS="-j1" it compiles fine.
> 
> Still here with net-mail/dovecot-2.2.16-r1, with the same behaviour.

Oh! Better than that, I have found something else:
I just add to my /etc/portage/make.conf file the line:

MAKEOPTS="${MAKEOPTS} --load-average"

to disable the limitation on my fully charged system, and it worked, with our without distcc.

I think I found the reason of most of my problems :-)

So, people, try to compile it with
MAKEOPTS="${MAKEOPTS} --load-average"
in your make.conf (better in the bottom of the file), it may do the trick.