Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 409745 - app-misc/ranger-1.5.3: "bzip2: I/O or other error, bailing out" when using man page
Summary: app-misc/ranger-1.5.3: "bzip2: I/O or other error, bailing out" when using ma...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tim Harder
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-26 10:17 UTC by Amadeusz Żołnowski (RETIRED)
Modified: 2018-08-15 22:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-03-26 10:17:03 UTC
I get following error when using ranger's help (man page displayed on '?'):

bzip2: I/O or other error, bailing out.  Possible reason follows.
bzip2: Broken pipe
	Input file = /usr/share/man/man1/ranger.1.bz2, output file = (stdout)

bzip2: I/O or other error, bailing out.  Possible reason follows.
bzip2: Broken pipe
	Input file = /usr/share/man/man1/ranger.1.bz2, output file = (stdout)


Reproducible: Always

Steps to Reproduce:
1. Run ranger
2. Press '?' to open man page
3. Quit man page
4. Quit ranger
Comment 1 pavel sanda 2012-04-11 11:59:59 UTC
Do normal man pages work for you without this error?
I see this bug with normal man usage (just from recently).
Comment 2 Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-04-17 08:55:39 UTC
(In reply to comment #1)
> Do normal man pages work for you without this error?
> I see this bug with normal man usage (just from recently).

Yes. I have no errors when doing "man ranger" from the shell.
Comment 3 pavel sanda 2012-05-02 17:17:41 UTC
And what is your bash version?
I tracked down my problem to update bash from 4.1_p9 to 4.2_p20.
Comment 4 Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-05-04 10:31:27 UTC
(In reply to comment #3)
> And what is your bash version?

4.2_p24-r1


> I tracked down my problem to update bash from 4.1_p9 to 4.2_p20.

But problem still occurs for me.
Comment 5 pavel sanda 2012-05-04 10:33:41 UTC
if you try to downgrade bash for a while does it improve?
if not i will create separate bug, since it would be different issue.
Comment 6 Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-05-04 11:15:43 UTC
(In reply to comment #5)
> if you try to downgrade bash for a while does it improve?

Hm, to bash-4.1_p9 or earlier, or later?  The problem still occurs with 4.1_p9.
Comment 7 pavel sanda 2012-05-04 11:19:39 UTC
aha,that means these two are unrelated, because my issue is fixed when downgrade to 4.1_p9.
Comment 8 Virgil Dupras (RETIRED) gentoo-dev 2014-10-16 22:59:18 UTC
I'm been using ranger-1.6.1 ~amd64 and I can't reproduce the issue. Are we sure it's still current?
Comment 9 Amadeusz Żołnowski (RETIRED) gentoo-dev 2014-10-17 17:47:09 UTC
Me either. :-)
Comment 10 Nik Strauss 2015-06-01 14:05:32 UTC
I get the error on 1.6.1 stable.
Comment 11 Nik Strauss 2015-06-01 14:15:20 UTC
Also on ~amd64 1.7.1
Comment 12 Virgil Dupras (RETIRED) gentoo-dev 2015-06-01 21:11:58 UTC
I don't know if this will help, but this is the relevant code upstream:

https://github.com/hut/ranger/blob/a65efba9c1db5cda2284e95d364e47bf652bf160/ranger/core/actions.py#L780

This part hasn't changed since 2013.

As we can see, it's simply "process = self.run(['man', 'ranger'])" being called. I can't figure out for sure where `self.run()` comes from, but I think it's from https://github.com/hut/ranger/blob/bababd8cd4259e90f20ab7dccde3de27cde8dcf6/ranger/core/runner.py#L88


... Oh, I think I have it. If I re-emerge ranger with python 2.7 use flags (I've always used ranger through python 3), I can reproduce the bug. Can we confirm that reproducing the bug is tied to python 2?
Comment 13 Virgil Dupras (RETIRED) gentoo-dev 2015-06-01 21:17:35 UTC
I've opened a ticket at https://github.com/hut/ranger/issues/325
Comment 14 Virgil Dupras (RETIRED) gentoo-dev 2015-06-07 17:08:47 UTC
It would seem that this bug is not related to ranger:

python2 -c 'from subprocess import *; Popen(["man", "ls"]).wait()'

reproduces the bug for me (but not with python 3).
Comment 15 Virgil Dupras (RETIRED) gentoo-dev 2015-06-07 17:14:41 UTC
Also, this bug seems to be specific to gentoo: I can't reproduce it on an Ubuntu 14.04 environment (2.7.6) I have lying around. Ranger's author says he can't reproduce it on Arch (2.7.10).
Comment 16 Evan Stoll 2018-04-26 19:13:17 UTC
Might this be related?

man prints warnings
https://github.com/kovidgoyal/kitty/issues/277
Comment 17 Amadeusz Żołnowski (RETIRED) gentoo-dev 2018-08-15 22:01:54 UTC
It is very probable. Let's close this bug.