Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 409327 - media-video/vlc-2.0.1 crashes when playing dvd with menu (and dvd-CSS)
Summary: media-video/vlc-2.0.1 crashes when playing dvd with menu (and dvd-CSS)
Status: RESOLVED DUPLICATE of bug 303845
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Tom Wijsman (TomWij) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 15:01 UTC by samurai.no.dojo
Modified: 2013-12-15 23:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output of emerge --info media-video/vlc (emerge-info,14.36 KB, text/plain)
2012-03-22 15:01 UTC, samurai.no.dojo
Details
output of vlc -vvv (vlc-vvv,44.11 KB, text/plain)
2012-03-22 15:02 UTC, samurai.no.dojo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description samurai.no.dojo 2012-03-22 15:01:08 UTC
Created attachment 306319 [details]
output of emerge --info media-video/vlc

VLC crashes when playing dvdcss DVD (.iso file - my dvd-rom is dead)
It plays menu but when I select to play movie it crashes


Steps to reproduce:
1) emerge VLC v. 2.0.1
2) open CSS dvd or .iso file
3) select to play movie ... CRASH

Desired action:
Playing movie not crashing

Output of vlc -vvv :
in attachment vlc-vvv

Output of emerge --info media-video/vlc :
in attachment "emerge-info"
Comment 1 samurai.no.dojo 2012-03-22 15:02:20 UTC
Created attachment 306321 [details]
output of vlc -vvv
Comment 2 Jeroen Roovers gentoo-dev 2012-03-23 15:54:43 UTC
Could you run vlc from a shell and post the output, please?
Comment 3 samurai.no.dojo 2012-03-23 17:09:52 UTC
Its already in attachment 306321 [details]

https://bugs.gentoo.org/attachment.cgi?id=306321
Comment 4 Alexis Ballier gentoo-dev 2012-03-23 18:09:16 UTC
Assertion 'pthread_setspecific(t->key, userdata) == 0' failed at pulsecore/thread-posix.c:247, function pa_tls_set(). Aborting.

seems to come from pulseaudio, you can try to use alsa output meanwhile i'd say

to debug this, please provide a backtrace as described in:
http://www.gentoo.org/proj/en/qa/backtraces.xml

so that we'll know where everything comes from and not only where it fails.
Comment 5 samurai.no.dojo 2012-03-23 18:31:43 UTC
(In reply to comment #4)
For debugging this what packages I need to rebuild - Its slow machine so some advice would be helpful (whole world rebuild would take at least day and half)
Comment 6 Alexis Ballier gentoo-dev 2012-03-23 18:36:34 UTC
(In reply to comment #5)
> (In reply to comment #4)
> For debugging this what packages I need to rebuild - Its slow machine so
> some advice would be helpful (whole world rebuild would take at least day
> and half)

pulseaudio and vlc should be a good start, then if there's something in between we may want to rebuild them too, but at that point i doubt it.

does it fail the same way with other medias ?
can you try with some random file, and with some file with a52 audio ?
Comment 7 samurai.no.dojo 2012-03-23 18:49:08 UTC
I'm no quite sure that the main problem is audio the exact way it happens on that .iso is this:
open vlc 
open file
menu just plays well but when you try to open main movie it fails.

right now Im copying other files to test one with a52 audio and one with PCM U8 and one .flv with MPEG Audio layer 1/2/3 which plays just well.
Comment 8 samurai.no.dojo 2012-03-23 18:52:38 UTC
Sorry for Spamming all three test files are playing without problems. It seems to be somehow connected with dvd structure of media.
Comment 9 Alexis Ballier gentoo-dev 2012-03-23 18:52:50 UTC
and with audio like this one:
[0x9d81250] a52 decoder debug: A/52 channels:6 samplerate:48000 bitrate:448000

i'm focusing on audio because i suppose it doesnt play audio, or that kind of audio, when in the menus and then the crash (assertion failure) appears in pulseaudio when the movie start...
Comment 11 samurai.no.dojo 2012-03-23 19:22:04 UTC
I'm really sorry for taking valuable dev time but when I was going to try if that dvd has different sound codecs for menu and main movie i found that now it plays without problem.

So my problem disappeared and therefore I'm not able to reproduce this bug myself.

Have nice day and as less bugs as possible.
S.
Comment 12 samurai.no.dojo 2012-03-24 10:57:47 UTC
So after restart when i was trying to play that dvd to my daghter we are back where we were...

crash after menu.

BUT...
when I first play those sample sounds from comment 10
I'm able to play that movie without problems!
Comment 13 Alexis Ballier gentoo-dev 2012-03-24 13:12:05 UTC
weird
does the same bahavior occurs with alsa as audio output module ?

and, this time, i'll really need the backtrace
Comment 14 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-12-15 23:10:33 UTC
Please see https://bugs.gentoo.org/show_bug.cgi?id=303845#c10.

*** This bug has been marked as a duplicate of bug 303845 ***