Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 40926 - aalib-1.4_rc4-r2 fails with 'needs autoconf 2.50 or higher'
Summary: aalib-1.4_rc4-r2 fails with 'needs autoconf 2.50 or higher'
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2004-02-08 20:00 UTC by ferret
Modified: 2004-02-19 10:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description ferret 2004-02-08 20:00:47 UTC
cd . && autoconf
FATAL ERROR: Autoconf version 2.50 or higher is required for this script
make: *** [configure] Error 2

There's a message earlier in the emerge which I think is unrelated, when the
"elibtoolize" line in the ebuild is ran:

 * Patching ${S}/
 *   Could not apply portage.patch!
 *   Please verify that it is not needed.
 * Cannot apply any patch, running libtoolize...
You should update your `aclocal.m4' by running aclocal.

The odd thing is, the ebuild actually specifies which autoconf it wants:

pkg_setup() {
    # We need autoconf-2.5
    export WANT_AUTOCONF=2.5

And despite this, the following alteration fixes the ebuild for me.

+   WANT_AUTOCONF=2.5 emake || die
-   emake || die
Comment 1 SpanKY gentoo-dev 2004-02-08 21:07:24 UTC
just needs to be given a little libtool love
Comment 2 Nick Demchenko 2004-02-12 05:22:19 UTC
Got the same issue with aalib and a few other packages. For instance, xine-lib doesn't let me emerge it, although I could do it before (same version). I've been thinking something might be wrong with my system because neither that nor a new =>2.6.2 vanilla kernel works.

SpanKY, what do you mean with it needs some libtool love?
Comment 3 Robert Cole 2004-02-12 20:15:15 UTC
same problem here on a fresh 2004.0 gentoo system.

Had a problem with xine too NeoNik but ended up just commenting out my compiler options in my /etc/make.conf and letting the defaults go and that worked. I tried tweeking -O3 to 2 and a few other things but it didn't work. Didn't work for aalib-1.4_rc4-r2 either but commenting the compiler options options for aalib doesn't work.

I have autoconf 2.59 btw.
Comment 4 Kelly Harnden (uglyman) 2004-02-13 22:38:11 UTC
just wanted to say I have been running 
emerge -e world (don't ask :-) )
and it failed exactly as ferret described.

if you don't hear back from me in the next hour you can safely assume that ferret's suggested change works for me too.

just thought I would give one more "me too"
Comment 5 Francisco José Cañizares Santofimia 2004-02-15 01:34:23 UTC
I agree for bug and solution, and also, it's not the only program with that fail.
Comment 6 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-15 12:09:34 UTC
I think I got this fixed with autoconf fix:

  14 Feb 2004; Martin Schlemmer <> files/
  Fix to also work with AC_PREREQ(2.50) (note the 2.50 and not

Basically it checked for AC_PREREQ(2.5) and not 2.50 to switch to 2.5
autoconf.  Merges fine here.  Try to rsync, and remerge autoconf.
Comment 7 andrew way 2004-02-17 05:45:09 UTC
ive changed followed symlinks
/usr/bin/autoconf -> /usr/lib/autoconf/
/usr/bin/autoconf -> /usr/bin/autoconf-2.59

same with the symlink in /usr/local/bin

then it works...
perhaps not so a good solution, but it works ;)

Comment 8 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-19 10:25:39 UTC
Please try it with autoconf-2.59-r3 - there crept a bug into previous

Anyhow, it should fix it - reopen if you still have issues with -r3.