Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 409081 - net-libs/meanwhile with dev-libs/glib-2.31 - error: #error "Only <glib.h> can be included directly."
Summary: net-libs/meanwhile with dev-libs/glib-2.31 - error: #error "Only <glib.h> can...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PATCH
: 410905 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-03-21 06:30 UTC by Bjoern Thorwirth
Modified: 2012-04-12 07:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Updated ebuild (meanwhile-1.0.2-r1.ebuild,1.07 KB, text/plain)
2012-03-21 06:31 UTC, Bjoern Thorwirth
Details
patch to fix includes (meanwhile-1.0.2-glib-2.31.patch,241.51 KB, patch)
2012-03-21 06:31 UTC, Bjoern Thorwirth
Details | Diff
patch file (meanwhile-1.0.2-glib-2.31.patch,6.31 KB, patch)
2012-03-21 06:38 UTC, Bjoern Thorwirth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bjoern Thorwirth 2012-03-21 06:30:30 UTC
meanwhile fails to build agains glib 2.31

Reproducible: Always
Comment 1 Bjoern Thorwirth 2012-03-21 06:31:14 UTC
Created attachment 306063 [details]
Updated ebuild
Comment 2 Bjoern Thorwirth 2012-03-21 06:31:51 UTC
Created attachment 306065 [details, diff]
patch to fix includes
Comment 3 Bjoern Thorwirth 2012-03-21 06:38:17 UTC
Created attachment 306067 [details, diff]
patch file
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2012-03-21 15:37:47 UTC
Comment on attachment 306063 [details]
Updated ebuild

--- meanwhile-1.0.2.ebuild      2011-02-07 20:36:57.000000000 +0100
+++ -   2012-03-21 16:37:37.361232125 +0100
@@ -24,7 +24,7 @@
        unpack ${A}
        cd "${S}"
        epatch "${FILESDIR}/${P}-presence.patch" #239144
-
+       epatch "${FILESDIR}/${P}-glib-2.31.patch"
        #241298
        sed -i -e "/sampledir/ s:-doc::" samples/Makefile.in
 }
Comment 5 Pacho Ramos gentoo-dev 2012-03-24 11:38:12 UTC
+*meanwhile-1.0.2-r1 (24 Mar 2012)
+
+  24 Mar 2012; Pacho Ramos <pacho@gentoo.org>
+  +files/meanwhile-1.0.2-glib2.31.patch, +meanwhile-1.0.2-r1.ebuild:
+  Fix glib-2.31 building, bug #409081 by Bjoern Thorwirth; also drop static
+  stuff.
+
Comment 6 Johannes Huber gentoo-dev 2012-04-12 07:44:39 UTC
*** Bug 410905 has been marked as a duplicate of this bug. ***