Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 408919 - sys-kernel/gentoo-sources-3.2.11 / 3.3.0 doesn't interact with sys-fs/udev-182 correctly (???)
Summary: sys-kernel/gentoo-sources-3.2.11 / 3.3.0 doesn't interact with sys-fs/udev-18...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-19 21:59 UTC by Marco Napetti
Modified: 2012-04-06 13:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
backported patch for brcmsmac (brcmsmac.patch,1.47 KB, patch)
2012-03-21 00:18 UTC, Mike Pagano
Details | Diff
config-3.2.11-gentoo (.config,82.09 KB, text/plain)
2012-03-21 08:11 UTC, Marco Napetti
Details
config-3.3.0-gentoo (.config,81.66 KB, text/plain)
2012-03-21 08:12 UTC, Marco Napetti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Napetti 2012-03-19 21:59:39 UTC
After the upgrade to sys-fs/udev-181 I have this strange error at boot time:
 * Waiting for uevents to be processed ...
udevd[166]: worker [187] timeout, kill it

udevd[166]: seq 1644 '/devices/pci0000:00/0000:00:1c.1/0000:02:00.0' killed

udevd[166]: worker [187] terminated by signal 9 (Killed)

I can't understand what's happening, this is my lspci output:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
0a:00.0 FireWire (IEEE 1394): O2 Micro, Inc. 1394 OHCI Compliant Host Controller (rev 05)
0a:00.1 SD Host controller: O2 Micro, Inc. Integrated MMC/SD controller (rev 05)
0a:00.2 Mass storage controller: O2 Micro, Inc. O2 Flash Memory Card (rev 05)


Reproducible: Always




Portage 2.1.10.49 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r2, 3.2.11-gentoo x86_64)
=================================================================
System uname: Linux-3.2.11-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Mon, 19 Mar 2012 08:00:01 +0000
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5.1-r1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2-r1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo seden
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula dlj-1.1 PUEL AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -O2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build=y"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/seden"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl addbookmarks alias alsa amd64 amr amuled apache2 audiofile autoreplace avi bash-completion berkdb bluetooth boost branding browserplugin bzip2 cdaudio cdb cdda cddb cdinstall cdio cdparanoia cdr cleartype cli clucene codecs connectionstatus contactnotes cracklib crypt css ctype cups curl custom-optimization cxx dbus decibel dga divx4linux dlloader dri dts dv dvb dvd dvdr dvdread dxr3 edl emul-linux-x86 encode exif extensions faad fam fame ffmpeg filter firefox flac fontconfig fortran ftp gadu gcj gd gdbm ggi gif gimp gimpprint git glib glitz gnutls gpm groupwise gstreamer highlight history hou iconv idn ieee1394 imagemagick imap imlib inquisitio insecure-drivers ipv6 irc ithreads jack java javascript jingle jpeg jpeg2k kde kdeenablefinal lame lcd lcdfilter libcaca libnotify live lm_sensors lzo mad matroska messenger mikmod mime mjpeg mmx mmxext modules monkey moodbar mozbranding mozdevelop mozilla mp3 mp4 mpeg msn msword mudflap multilib musepack musicbrainz mysql mysqli mythtv ncurses nepomuk netmeeting nls nodrm nowin nowlistening nptl nptlonly nsplugin objc objc++ objc-gc offensive ogg oggvorbis opengl openmp pam pcre pdf phonon php plasma png ppds pppd qt qt-copy qt3support qt4 quicktime rar rdesktop readline remote replytolist samba sametime scanner sdl semantic-desktop sensord session slp smp sms sndfile sou sound speex sqlite sse sse2 ssl startup-notification statistics subversion svg sysfs taglib tcpd telepathy texteffect tga theora threads tidy tiff tokenizer translator truetype truetype-fonts udev unicode upnp usb v4l v4l2 vcd video videos visualization vnc vorbis wavpack webdav webpresence wifi winpopup wlm xanim xattr xcb xcomposite xine xinerama xml xmlpatterns xmlreader xmlwriter xorg xscreensaver xv xvid xvmc yahoo zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby19" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="intel vesa fbdev i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 William Hubbs gentoo-dev 2012-03-20 04:47:01 UTC
What happens if you upgrade to udev-182?
Comment 2 Tong Ju 2012-03-20 11:05:24 UTC
I'm not sure, but I sovled a similar problem by recompiling the kernel with my rtl8192se firmware in it. It seems that >=udev-177 has trouble dealing with some firmwares. Compiling them within your kernel / pack them in the initramfs can be a workaround.
Comment 3 Marco Napetti 2012-03-20 12:32:56 UTC
The problem is still here with sys-fs/udev-182 and sys-kernel/gentoo-sources-3.2.11, but is solved with sys-fs/udev-182 and sys-kernel/gentoo-sources-3.3.0
Comment 4 Marco Napetti 2012-03-20 20:33:47 UTC
I have to correct myself: actually using sys-kernel/gentoo-sources-3.3.0 my WiFi card (brcmfmac based) doesn't work, with sys-kernel/gentoo-sources-3.2.11 it works.
Have I to open another bug report because it isn't related to sys-fs/udev?
Comment 5 Samuli Suominen gentoo-dev 2012-03-20 20:48:13 UTC
This bug would need a lot more information than is provided right now. 
There isn't much to go on. In the current state this is on, it will likely just get closed with 'NEEDINFO'. 
No kernel config, emerge -pv udev, dmesg, or anything like that attached...
Comment 6 Mike Pagano gentoo-dev 2012-03-20 23:30:22 UTC
Can we try this:

Run gentoo-sources-3.2.11 and udevd 182 as I think it has a fix for firmware loading bugs.

Compile rtl8192se as a module and do *not* load it. Also install rlt8192se-firmware.

Without the module being loaded, do you get the udevd error messages?
If not, modprobe rtl8192se and tell me what happens.

btw, if you can't get wireless working with 3.3.0, that should be a separate bug.
Comment 7 Mike Pagano gentoo-dev 2012-03-21 00:18:22 UTC
Created attachment 306057 [details, diff]
backported patch for brcmsmac

Can you apply this patch to your gentoo-sources-3.2.11 and let me know if it helps. Use udev 182 and load your driver module as you were when it was failing.

Thanks.
Comment 8 Marco Napetti 2012-03-21 08:11:50 UTC
Created attachment 306079 [details]
config-3.2.11-gentoo
Comment 9 Marco Napetti 2012-03-21 08:12:18 UTC
Created attachment 306081 [details]
config-3.3.0-gentoo
Comment 10 Marco Napetti 2012-03-21 08:16:19 UTC
(In reply to comment #5)
> This bug would need a lot more information than is provided right now. 
> There isn't much to go on. In the current state this is on, it will likely
> just get closed with 'NEEDINFO'. 
> No kernel config, emerge -pv udev, dmesg, or anything like that attached...

You're right, it's my fault.
I've attached the configs files, udes is merged with those use flags:
[ebuild   R    ] sys-fs/udev-182  USE="gudev openrc rule_generator -build -debug -doc -floppy -hwdb -introspection -keymap (-selinux) -static-libs" 0 kB

Now I notice that, in another gentoo box with different hardware, the static-libs flag was needed...
Comment 11 Marco Napetti 2012-03-21 08:22:06 UTC
(In reply to comment #6)
> Can we try this:
> 
> Run gentoo-sources-3.2.11 and udevd 182 as I think it has a fix for firmware
> loading bugs.
> 
> Compile rtl8192se as a module and do *not* load it. Also install
> rlt8192se-firmware.
> 
> Without the module being loaded, do you get the udevd error messages?
> If not, modprobe rtl8192se and tell me what happens.
> 
> btw, if you can't get wireless working with 3.3.0, that should be a separate
> bug.

Actually I don't use rtl8192se module, it was cited by Tong Ju in Comment #2, I use brcmfmac and I already tried to make it builtin into kernel, but the problem persists.

When I try to start /etc/init.d/net.wlan0 I obtain this:
 * Caching service dependencies ...                                                                                                                                                                                                          [ ok ]
 * Bringing up interface wlan0
 *   ERROR: interface wlan0 does not exist
 *   Ensure that you have loaded the correct kernel module for your hardware
 * ERROR: net.wlan0 failed to start
Comment 12 Marco Napetti 2012-03-21 08:26:37 UTC
(In reply to comment #7)
> Created attachment 306057 [details, diff] [details, diff]
> backported patch for brcmsmac
> 
> Can you apply this patch to your gentoo-sources-3.2.11 and let me know if it
> helps. Use udev 182 and load your driver module as you were when it was
> failing.
> 
> Thanks.

Wait a moment, maybe I didn't understand the goal of your patch, but, with gentoo-sources-3.2.11, brcmsmac works fine, but I have a strange error at boot time (and I don't know wich module the error is related to).

Instead, with gentoo-sources-3.3.0, brcmsmac doesn't works (loads, doesn't give any error but the device isn't created).
Comment 13 Mike Pagano gentoo-dev 2012-03-21 11:47:54 UTC
What are the results from the steps of comment #7?
Comment 14 Marco Napetti 2012-03-21 12:37:00 UTC
(In reply to comment #13)
> What are the results from the steps of comment #7?

Applying the patch to gentoo-sources-3.2.11 results on a compilation error:
  CC [M]  drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.o
drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c: In function ‘brcms_driver_init’:
drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c:1276:5: error: implicit declaration of function ‘bcma_driver_register’
drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c:1276:35: error: ‘brcms_bcma_driver’ undeclared (first use in this function)
drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c:1276:35: note: each undeclared identifier is reported only once for each function it appears in
make[5]: *** [drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.o] Errore 1
make[4]: *** [drivers/net/wireless/brcm80211/brcmsmac] Errore 2
make[3]: *** [drivers/net/wireless/brcm80211] Errore 2
make[2]: *** [drivers/net/wireless] Errore 2
make[1]: *** [drivers/net] Errore 2
make: *** [drivers] Errore 2
Comment 15 Mike Pagano gentoo-dev 2012-03-21 15:42:24 UTC
Thanks, let me see what I can come up with.
Comment 16 Mike Pagano gentoo-dev 2012-03-22 13:57:29 UTC
A whole set of patches that might address this issue are now in Linus's upstream development tree. As soon as he tags a version, I will ask you to test.
Comment 17 Marco Napetti 2012-03-22 14:02:51 UTC
(In reply to comment #16)
> A whole set of patches that might address this issue are now in Linus's
> upstream development tree. As soon as he tags a version, I will ask you to
> test.

Ok, no problem, let me know...
Comment 18 Maciej Gierok 2012-03-24 10:57:40 UTC
To enable CONFIG_BRCMSMAC on kernel 3.3.0 you need to enable CONFIG_BCMA first.
BRCMSMAC != BRCMFMAC

Even that, my wifi connection doesn't work on both kernel (3.3.0 and 3.2.11) with >=udev-182. I must downgrade it.
Comment 19 Marco Napetti 2012-03-25 15:41:17 UTC
(In reply to comment #18)
> To enable CONFIG_BRCMSMAC on kernel 3.3.0 you need to enable CONFIG_BCMA
> first.
> BRCMSMAC != BRCMFMAC
> 
> Even that, my wifi connection doesn't work on both kernel (3.3.0 and 3.2.11)
> with >=udev-182. I must downgrade it.

Yes, you're right, enabling BCMA i had BRCMSMAC back and now my WiFi works.
Thank you very much!
Comment 20 Mike Pagano gentoo-dev 2012-04-06 13:11:02 UTC
I think you are ok now? Reopen if not.