Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 408741 - pkg-config doesn't find .pc files
Summary: pkg-config doesn't find .pc files
Status: RESOLVED DUPLICATE of bug 401021
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-18 18:01 UTC by renato gallo
Modified: 2012-03-20 16:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description renato gallo 2012-03-18 18:01:40 UTC
an example is here with navit it doesn't find libgps.pc which is present in the system exporting the pkgconfig variable into .bashrc made the program compile

https://bugs.gentoo.org/show_bug.cgi?id=176552
Comment 1 Samuli Suominen gentoo-dev 2012-03-20 13:36:14 UTC
Try to come up with a simple way to reproduce (other than trying a software which isn't in Portage)
Otherwise I'm inclined to believe this is a problem in the package, not pkg-config
Comment 2 Jeroen Roovers gentoo-dev 2012-03-20 16:19:18 UTC
As far as I can tell, libgps.pc is installed by sci-geosciences/gpsd.

app-portage/pfl's e-file lists /lib64/pkgconfig/libgps.pc as one place where the .pc file might have ended up erroneously (in past times, I expect). Maybe this information helps you.

*** This bug has been marked as a duplicate of bug 176552 ***
Comment 3 Jeroen Roovers gentoo-dev 2012-03-20 16:21:31 UTC
Ah, there we go.

*** This bug has been marked as a duplicate of bug 401021 ***