Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 408193 - sys-power/cpupower: the new sys-power/cpufrequtils
Summary: sys-power/cpupower: the new sys-power/cpufrequtils
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL: http://permalink.gmane.org/gmane.linu...
Whiteboard:
Keywords:
: 410439 424643 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-14 18:46 UTC by Martin Mokrejš
Modified: 2013-01-24 10:37 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-power/cpupowerutils-3.4.18 (cpupowerutils-3.4.18.ebuild,635 bytes, text/plain)
2012-11-17 11:21 UTC, Lars Wendler (Polynomial-C)
Details
cpupower-3.4.18-makefile.patch (cpupower-3.4.18-makefile.patch,1.74 KB, patch)
2012-11-17 11:21 UTC, Lars Wendler (Polynomial-C)
Details | Diff
cpupower-3.4.18-makefile.patch (cpupower-3.4.18-makefile.patch,1.46 KB, patch)
2012-11-17 11:23 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2012-03-14 18:46:44 UTC
I am not sure if this is really a replacement but it looks it is or will be in future.
Comment 1 Doug Goldstein gentoo-dev 2012-06-17 03:28:01 UTC
This is now merged into the tools/ tree of the kernel tree. But it doesn't include the pmtools pieces. Those are at www.lesswatts.org.
Comment 2 Julian Ospald 2012-07-18 15:33:42 UTC
*** Bug 410439 has been marked as a duplicate of this bug. ***
Comment 3 Julian Ospald 2012-07-18 15:33:50 UTC
*** Bug 424643 has been marked as a duplicate of this bug. ***
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2012-11-17 11:21:11 UTC
Created attachment 329698 [details]
sys-power/cpupowerutils-3.4.18

Okay, I've started hacking together an ebuild for this. 
I find it quite annoying that these tools are part of the kernel sources so I put them into a tarball on my dev space. Please find attached the ebuild I'm currently using. I took the sources from 3.4.18 kernel version because that's the one I'm currently using on most of my machines.

Comments are welcome.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2012-11-17 11:21:45 UTC
Created attachment 329700 [details, diff]
cpupower-3.4.18-makefile.patch

The needed patch to get the ebuild working.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2012-11-17 11:23:38 UTC
Created attachment 329702 [details, diff]
cpupower-3.4.18-makefile.patch

Sorry, first patch contained a bad line. This one is good :)
Comment 7 Manuel Rüger (RETIRED) gentoo-dev 2012-11-17 14:05:34 UTC
bug #410439 and bug #424643 include also ebuilds and some more patches, maybe you want to take a look at them?

imho src_compile and src_install is not nescessary in your ebuild, if you want to process the default operations.
Comment 8 Martin Mokrejš 2012-12-19 15:49:07 UTC
Maybe the package should be rather just cpupower, like in other linux distros. Took me a while to realize this is a same thing. ;-) Works fine for me on 3.7.1 kernel but looks I will downgrade to 3.4 because can't make by CPU to go to the highest turbo frequency (hope the "smp_scheduler or mc_scheduler values in the configuration file" will help me, removed since kernel 3.5. :(). 

https://wiki.archlinux.org/index.php/CPU_Frequency_Scaling
https://bbs.archlinux.org/viewtopic.php?id=148113
Comment 9 Mieszko Ślusarczyk 2013-01-24 08:43:11 UTC
sys-power/cpupower-3.8_rc4 is already in the tree. I guess this can be closed
Comment 10 Samuli Suominen gentoo-dev 2013-01-24 10:36:41 UTC
(In reply to comment #9)
> sys-power/cpupower-3.8_rc4 is already in the tree. I guess this can be closed

nod