Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 407813 - dev-python/fabric-1.8.1 dev-python/fudge-1.0.3-r2 stable request
Summary: dev-python/fabric-1.8.1 dev-python/fudge-1.0.3-r2 stable request
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2012-03-11 16:20 UTC by Laurent Bachelier
Modified: 2014-11-04 08:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bachelier 2012-03-11 16:20:19 UTC
I've been using it for a few months without issues.
Its only dependency (paramiko) is already stable.

Fabric 1.3 and higher use dev-python/ssh which is a fork of paramiko and introduce some other important changes.

So I think 1.2 is a good candidate for stabilization.
Also consider bumping the 1.2 series to 1.2.6, and 1.1 to 1.1.8 (which are maintenance releases).

Reproducible: Always
Comment 1 Laurent Bachelier 2012-11-09 18:32:51 UTC
Now that Fabric 1.5.0 is out, 1.4.x would be a good candidate for stable. I've been using 1.4.3 for a while.
Comment 2 Pacho Ramos gentoo-dev 2014-02-08 21:26:52 UTC
What about 1.8.1?
Comment 3 Laurent Bachelier 2014-02-08 21:42:24 UTC
I haven't followed fabric development for a while, but it looks like a good candidate.

I updated to 1.8.1, I'll report back if I encounter any issues.
Comment 4 Pacho Ramos gentoo-dev 2014-03-08 07:56:58 UTC
Well, this needs all fudge, not sure if it's ok to stabilize then (in general depending in "<" versions is not a good idea for long term :|)
Comment 5 Agostino Sarubbo gentoo-dev 2014-07-06 07:02:48 UTC
This stable request can't be completed because of the following repoman's error(s):

 dependency.bad                11
   dev-python/fabric/fabric-1.8.1.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['<dev-python/fudge-1.0']

In case you are the maintainer of the needed package(s), please authorize the stabilization and edit the summary of this bug.
In case you are not the maintainer of the needed package(s), please open the necessary bug(s) and make a block for this bug.

To find the full list, feel free to follow this article:
Comment 6 Witold Piłat 2014-07-06 17:17:17 UTC
fudge-1.0.3-r2 is still affected by bug 497494