Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 407801 - dev-libs/syck to 0.70 version bump
Summary: dev-libs/syck to 0.70 version bump
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 252909
  Show dependency tree
 
Reported: 2012-03-11 14:27 UTC by Uwe L. Korn
Modified: 2016-02-20 18:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
syck-0.70.ebuild (syck-0.70.ebuild,1.38 KB, text/plain)
2014-10-19 17:41 UTC, Hans de Graaff
Details
syck-0.70-64bit.patch (syck-0.70-64bit.patch,673 bytes, patch)
2014-10-19 17:42 UTC, Hans de Graaff
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe L. Korn 2012-03-11 14:27:55 UTC
Hello,

I'd like to have syck-0.70 in Gentoo. I already made a ebuild at [1]. Basically the only change is to *not* apply the 64bit patch and to change the SRC_URI to [2]

xhochy

[1] https://github.com/xhochy/gentoo-overlay/blob/master/dev-libs/syck/syck-0.70.ebuild
[2] https://github.com/downloads/indeyets/syck/${P}.tar.gz
Comment 1 Samu Voutilainen 2012-03-28 10:17:03 UTC
Confirmed to work here, with my patched pecl-syck.
Comment 2 Andreas K. Hüttel gentoo-dev 2014-10-11 09:12:13 UTC
This also needs python eclass update...
Comment 3 Hans de Graaff gentoo-dev 2014-10-19 17:40:49 UTC
I had a look at this today since syck-0.50 still references rubyforge.org in its SRC_URI and that site is no longer available.

The SRC_URI mentioned in the bug does not work for me. It would be helpful if indeyets could tag the current release as 0.70, and we could use that to download it.

I'll include my syck-0.70 version. Normally I would commit this, but it has a test failure that should be explained first.
Comment 4 Hans de Graaff gentoo-dev 2014-10-19 17:41:36 UTC
Created attachment 386960 [details]
syck-0.70.ebuild
Comment 5 Hans de Graaff gentoo-dev 2014-10-19 17:42:08 UTC
Created attachment 386962 [details, diff]
syck-0.70-64bit.patch
Comment 6 Hans de Graaff gentoo-dev 2014-10-19 17:48:15 UTC
I see the test failure is already reported upstream: https://github.com/indeyets/syck/issues/3
Comment 7 Pacho Ramos gentoo-dev 2014-12-19 09:28:37 UTC
Per Fedora .spec, looks like we should drop the python support from this:
* Tue Apr 02 2013 Oliver Falk <oliver@linux-kernel.at> - 0.70-1.20130402
- Update with latest version from GIT
- No longer build python package, since no longer included
http://pkgs.fedoraproject.org/cgit/syck.git/tree/syck.spec
Comment 8 Pacho Ramos gentoo-dev 2016-02-20 18:22:46 UTC
removed