Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 407623 - symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: _Z14qt_draw_glyphsP8QPainterPKjPK7QPointFi
Summary: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: _Z14qt_draw_gl...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 407625 407633 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-10 03:44 UTC by Anton Kochkov
Modified: 2012-06-25 19:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (slime-build.log,1.61 KB, text/plain)
2012-03-10 03:44 UTC, Anton Kochkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kochkov 2012-03-10 03:44:36 UTC
Created attachment 304787 [details]
full build log

[32;01m * [39;49;00mPackage:    app-emacs/slime-2.0_p20110617
[32;01m * [39;49;00mRepository: lisp
[32;01m * [39;49;00mUSE:        elibc_glibc kernel_linux userland_GNU x86
[32;01m * [39;49;00mFEATURES:   ccache sandbox
/usr/bin/emacs: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: _Z14qt_draw_glyphsP8QPainterPKjPK7QPointFi
 [31;01m*[0m elisp-emacs-version: Failed to run /usr/bin/emacs
 [31;01m*[0m ERROR: app-emacs/slime-2.0_p20110617 failed (setup phase):
 [31;01m*[0m   Emacs version too low
 [31;01m*[0m 
 [31;01m*[0m Call stack:
 [31;01m*[0m      ebuild.sh, line  85:  Called pkg_setup
 [31;01m*[0m      ebuild.sh, line 315:  Called elisp_pkg_setup
 [31;01m*[0m   elisp.eclass, line  87:  Called die
 [31;01m*[0m The specific snippet of code:
 [31;01m*[0m   	elisp-need-emacs "${NEED_EMACS:-21}" || die "Emacs version too low"
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the output of 'emerge --info =app-emacs/slime-2.0_p20110617',
 [31;01m*[0m the complete build log and the output of 'emerge -pqv =app-emacs/slime-2.0_p20110617'.
 [31;01m*[0m This ebuild used the following eclasses from overlays:
 [31;01m*[0m   /var/lib/layman/lisp/eclass/common-lisp-3.eclass
 [31;01m*[0m This ebuild is from an overlay named 'lisp': '/var/lib/layman/lisp/'
 [31;01m*[0m The complete build log is located at '/var/tmp/portage/app-emacs/slime-2.0_p20110617/temp/build.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/app-emacs/slime-2.0_p20110617/temp/die.env'.
 [31;01m*[0m S: '/var/tmp/portage/app-emacs/slime-2.0_p20110617/work/slime-2.0_p20110617'

emerge --info output: https://bugs.gentoo.org/attachment.cgi?id=304777
Comment 1 Anton Kochkov 2012-03-10 03:47:20 UTC
related with bug https://bugs.gentoo.org/show_bug.cgi?id=407625
Comment 2 Samuli Suominen gentoo-dev 2012-03-10 10:18:58 UTC
*** Bug 407625 has been marked as a duplicate of this bug. ***
Comment 3 Samuli Suominen gentoo-dev 2012-03-10 10:19:51 UTC
Have you tried rebuilding x11-libs/cairo yet?
Comment 4 Anton Kochkov 2012-03-12 00:46:37 UTC
(In reply to comment #3)
> Have you tried rebuilding x11-libs/cairo yet?

rebuilding cairo and emacs solved issues
Comment 5 Samuli Suominen gentoo-dev 2012-03-14 09:31:29 UTC
*** Bug 407633 has been marked as a duplicate of this bug. ***
Comment 6 Omar 2012-06-25 19:12:22 UTC
Emerging cairo does not work for me.

Portage 2.1.10.65 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 2.6.32-gentoo-r7 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.32-gentoo-r7-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8400_@_2.66GHz-with-gentoo-2.1
Timestamp of tree: Sat, 23 Jun 2012 15:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.3.4, 4.4.5, 4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo zugaina ardunio g-ctan
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA @EULA PUEL Broadcom dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ggdb -march=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -mtune=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ggdb -march=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -mtune=core2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ar ps"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/arduino /usr/portage/local/g-ctan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl additions alsa amd64 apache2 apng arts asf auto-hinter berkdb bidi bitmap-fonts bzip2 cairo cdda cli consolekit cracklib crypt cups cxx dbus device-mapper djvu dri dvi extras fat fat32 fontconfig fortran gcj gd gdbm gdu gnutls gpm gtk iconv icu ipv6 java5 jpeg jpg kdrive kpathsea ldap midi mikmod mmx mod modules mp3 mpi mudflap multilib mysql ncurses nls nptl nsplugin ntfs opengl openmp pam pcre pdf perl png postgres pppd ps python qt3support qt4 rar readline savedconfig sdk server session smpeg sqlite sse sse2 ssl symlink tcl tcpd threads tiff timidity tk truetype truetype-fonts type1-fonts unicode v4l v4l2 vorbis wav wma wmv wxwidgets xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ar ps" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON