Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 407199 - media-video/smtube - A youtube search and play add-on for smplayer
Summary: media-video/smtube - A youtube search and play add-on for smplayer
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Normal enhancement (vote)
Assignee: zlg (RETIRED)
URL: http://smplayer.sourceforge.net/
Whiteboard: [ago overlay]
Keywords: EBUILD, InOverlay
Depends on:
Blocks:
 
Reported: 2012-03-06 23:27 UTC by Fat-Zer
Modified: 2015-11-27 09:00 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
smtube-1.0.ebuild (smtube-1.0.ebuild,1.82 KB, text/plain)
2012-03-06 23:27 UTC, Fat-Zer
Details
smtube-1.7.ebuild (smtube-1.7.ebuild,1.24 KB, text/plain)
2013-07-16 07:45 UTC, Sergey Popov
Details
smtube-15.11.0.ebuild (smtube-15.11.0.ebuild,1.34 KB, text/plain)
2015-11-21 15:07 UTC, zlg (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fat-Zer 2012-03-06 23:27:52 UTC
Created attachment 304483 [details]
smtube-1.0.ebuild

This small app is used by smplayer-0.7.1 for youtube brose and play wideos from it.

There is no such ebuild in main tree or any gentoo community overlay now.

From it's description:
smtube is a small youtube browser. You can browse, search, download and play youtube videos. The videos are currently played in smplayer but in the future it may be added the possibility to use other players.
Comment 1 Jeroen Roovers gentoo-dev 2013-07-16 00:40:58 UTC
*** Bug 476986 has been marked as a duplicate of this bug. ***
Comment 2 Sergey Popov gentoo-dev 2013-07-16 07:45:00 UTC
Created attachment 353418 [details]
smtube-1.7.ebuild

Updated ebuild for smtube

Unfortunately, due to changes in Youtube API(or something like that, not really sure) smtube can not play videos directly from Youtube. But if you save video through it and click 'play' - works like a charm.

I am not sure that such semi-broken state for app is sufficient to include it in main tree, but if somebody wants it anyway - please tell us about it.
Comment 3 JTRiley 2013-08-26 15:43:29 UTC
Bumping the attached 1.7 ebuild to 1.8 works for me. I'm also able to play videos directly from youtube/smtube without any workarounds.
Comment 4 zlg (RETIRED) gentoo-dev 2015-11-21 15:07:22 UTC
Created attachment 417496 [details]
smtube-15.11.0.ebuild

I updated the old ebuild and tested both without USE flags and with the `qt5` USE flag. Both builds were successful and SMTube runs correctly.

The dependencies aren't as clean as they could be, from what I gathered. However, each individual module that I saw in `ldd` was marked as deprecated, so I left the deps alone. Perhaps a more experienced developer can vet or correct the listed deps.

I'm willing to take over maintainership of this package, but I won't commit it to the tree without at least one other "works for me". Let me know how it works out for you guys.
Comment 5 zlg (RETIRED) gentoo-dev 2015-11-27 09:00:53 UTC
Commit b00190062009b1815683fa8e7242f1b3ee53c11c adds smtube-15.11.0, the latest version. I have tested it repeatedly with SMPlayer and have not had any issues. Since this satisfies the bug, I'll be marking it as resolved and taking over maintainership.

Thanks for reporting the bug, and thanks to all who've worked on the ebuild thus far.