Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 40701 - gentoo-dev-sources 2.6.2 -> alsasound stops when booting
Summary: gentoo-dev-sources 2.6.2 -> alsasound stops when booting
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 All
: High normal (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2004-02-07 03:47 UTC by Max Loparev
Modified: 2004-02-19 10:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Max Loparev 2004-02-07 03:47:15 UTC
When alsasound starts at bootlevel boot
than after Restoring Mixer Levels [ok] the boot process stops forever.
If alsasound init script is removed from boot level than manual start after boot works ok.
Under gentoo-dev-sources-2.6.1-r1 all works normal.
Comment 1 John Mylchreest (RETIRED) gentoo-dev 2004-02-08 05:06:15 UTC
It doesnt appear to be anything to do with alsasound, because by that time alsasound has actually exited.
Does it tell you what it tries to run next?
Comment 2 Max Loparev 2004-02-08 11:56:10 UTC
As i can see in bootsplash.boot the next is hotplug and it normally starts if I remove alsasound.
With alsasound boot process stopped right after last message from alsasound if it has exited why the next sctipt don't print anything to console?
Comment 3 John Mylchreest (RETIRED) gentoo-dev 2004-02-09 01:01:56 UTC
Im unsure as to why this is happening tbh. but it does appear to be that alsasound has finished its work by that time.
Are you using ALSA within the kernel modular? or is it compiled in? is pcm-oss enabled in the kernel or modular?
Could you please post your bootsplash ninit script here as well please.
Also  if you can your kernel .config.
Comment 4 Max Loparev 2004-02-09 11:00:36 UTC
alsa compiled as modules
and I set an experiment
I add snd-via82xx snd-pcm-oss snd-mixer-oss and snd-seq-oss to autoload list, and boot now stops after Loading snd-mixer-oss [ok] i.e. befor alsasound script even starts.
I wan't open the new bug, because I can't descibe it clearly, but something wrong in  module [auto]loading in this kernel version. Near the same situation I have with the nvidia kernel module (pls. look at
Comment 5 Max Loparev 2004-02-09 11:17:14 UTC
btw sometimes boot process can get to Mounting local filesystems ... and halts there, i.e. time depended halt

I can get my system bootable by adding depend () {after hotplug } to alsasound script. Am i right?
Comment 6 John Mylchreest (RETIRED) gentoo-dev 2004-02-09 11:50:22 UTC
This quite possibly could be it.
are you using udev?
Comment 7 Max Loparev 2004-02-09 12:13:45 UTC
no, only devfs
udev merged but not enabled by passing devfs=no and so ignoreg by rc sctipt(i hope :))
Comment 8 John Mylchreest (RETIRED) gentoo-dev 2004-02-09 15:13:40 UTC
Could you please try the recently comitted 2.6.3-rc1 ebuild.
Comment 9 Nick Demchenko 2004-02-11 08:14:47 UTC
Got the same issue (but instead of alsasound it's net.eth0/net.eth1 here) with >=linux-2.6.2 (final) vanilla and mm-sources (haven't tried any other ones). Also tried 2.6.3-rc1. Going to see how 2.6.3-rc2 performs. Believe it'll be the same.
Comment 10 Max Loparev 2004-02-11 12:53:18 UTC
upgrading to gentoo-dev-sources-2.6.3_rc2 has no positive effect
Comment 11 Nick Demchenko 2004-02-11 14:29:32 UTC
Same, tried now 2.6.3-rc2 gentoo-development-sources, love-sources. Seems to be due hotplug, as it comes right during it.
Comment 12 Tim Yamin (RETIRED) gentoo-dev 2004-02-17 17:58:56 UTC
Can you try using a newer or older version of hotplug and see if that solves your problem? Thanks!
Comment 13 Jeremy Huddleston (RETIRED) gentoo-dev 2004-02-19 01:21:50 UTC
And can you try the latest alsasound init script from bug #41600.  This has been committed but might not be on your rsync server yet.  This new init script prevents loading unneeded drivers (a problem that was causing lockups for some users.)
Comment 14 Max Loparev 2004-02-19 10:52:29 UTC
now, under 2.6.3-gentoo problem with alsa is gone.
Comment 15 Tim Yamin (RETIRED) gentoo-dev 2004-02-19 10:53:39 UTC
Closing bug as fixed as reported in comment #14. Thanks!