Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 406479 - Please stabilize app-arch/rpm-4.9.1.2
Summary: Please stabilize app-arch/rpm-4.9.1.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Stanislav Ochotnicky (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 407939
Blocks: CVE-2011-3378
  Show dependency tree
 
Reported: 2012-03-01 20:57 UTC by Stanislav Ochotnicky (RETIRED)
Modified: 2012-03-24 17:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Ochotnicky (RETIRED) gentoo-dev 2012-03-01 20:57:55 UTC
This is a first stablereq after a long time. Among several other features and bugfixes there are several security issues[1,2] solved with this update. For now we've had some testing on x86,amd64,ppc[64] and arm and things seem to work. 

I realize this ebuild hasn't been in the tree for the required period of time, but due to security issues mentioned I believe stabilization is needed and smaller ebuild problems could be solved later (i.e. maintainer mode detected).

[1] https://bugs.gentoo.org/show_bug.cgi?id=384967
[2] https://bugs.gentoo.org/show_bug.cgi?id=335880

Reproducible: Always
Comment 1 Brent Baude (RETIRED) gentoo-dev 2012-03-02 20:41:05 UTC
ppc64 done
Comment 2 Brent Baude (RETIRED) gentoo-dev 2012-03-06 16:08:42 UTC
ppc done
Comment 3 Agostino Sarubbo gentoo-dev 2012-03-11 14:46:08 UTC
amd64 stable
Comment 4 Myckel Habets 2012-03-12 14:52:03 UTC
Build fails with USE="lua" on x86.
Comment 5 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-03-12 16:33:12 UTC
(In reply to comment #4)
> Build fails with USE="lua" on x86.

can not reproduce this.
x86: ok


 * QA Notice: Automake "maintainer mode" detected:
 * 
 *       cd . && /bin/sh /var/tmp/portage/app-arch/rpm-4.9.1.2/work/rpm-4.9.1.2/missing --run automake-1.11 --foreign Makefile
 *
Comment 6 Myckel Habets 2012-03-18 16:02:35 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Build fails with USE="lua" on x86.
> 
> can not reproduce this.
> x86: ok
> 

This bug is now fixed. Seems ok for me as well.
Comment 7 Markus Meier gentoo-dev 2012-03-19 21:33:14 UTC
arm stable
Comment 8 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-03-24 17:24:51 UTC
x86 stable, closing