Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 406255 - dev-libs/apr-1.4.6 failed test: testlfs : \/bin/bash: line 2: 3428 Segmentation fault (core dumped) ./$prog
Summary: dev-libs/apr-1.4.6 failed test: testlfs : \/bin/bash: line 2: 3428 Segmenta...
Status: RESOLVED OBSOLETE
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Sandbox (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL: https://issues.apache.org/bugzilla/sh...
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks: 477296
  Show dependency tree
 
Reported: 2012-02-29 09:03 UTC by Toralf Förster
Modified: 2016-01-31 15:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (dev-libs:apr-1.4.6:20120229-084844.log.gz,82.50 KB, application/x-gzip)
2012-02-29 09:05 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2012-02-29 09:03:10 UTC
at an unstable Gentoo Linux image (chrooted into it).

testcond            : SUCCESS
testlfs             : \/bin/bash: line 2:  3428 Segmentation fault      (core dumped) ./$prog
Programs failed: testall


Reproducible: Always




n22 / # emerge --info dev-libs/apr 
Portage 2.1.10.49 (default/linux/x86/10.0, gcc-4.6.2, glibc-2.14.1-r2, 3.2.9-rc1 i686)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.2.9-rc1-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Wed, 29 Feb 2012 07:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2-r1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build=y --keep-going=y"
FEATURES="assume-digests binpkg-logs compress-build-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bzip2 cli cracklib crypt cups cxx dri fam fastbuild gdbm gmp gpm iconv ipv6 logrotate mmx modules mudflap mysql mysqli ncurses nls nptl nptlonly openmp pam pcre pppd readline session sse sse2 sse3 ssl ssse3 sysfs tcpd threads unicode userlocales webmail x86 xml xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-libs/apr-1.4.5 was built with the following:
USE="urandom uuid -doc -older-kernels-compatibility -static-libs"
Comment 1 Toralf Förster gentoo-dev 2012-02-29 09:05:21 UTC
Created attachment 303695 [details]
build log
Comment 2 Toralf Förster gentoo-dev 2012-12-29 17:08:08 UTC
All tests are passed if diredtly called via :
$> cd /var/tmp/portage/dev-libs/apr-1.4.6-r1/work/apr-1.4.6/tes
$> ./testall

-> sandbox issue ?
Comment 3 Andreas Sturmlechner gentoo-dev 2013-05-26 14:52:51 UTC
Still trouble? Can't reproduce this with gcc-4.7.3, glibc-2.16.0 and sandbox-2.6-r1
Comment 4 Toralf Förster gentoo-dev 2013-05-26 15:07:41 UTC
(In reply to Andreas Sturmlechner from comment #3)
> Still trouble? Can't reproduce this with gcc-4.7.3, glibc-2.16.0 and
> sandbox-2.6-r1
yes:

# zgrep 'Segmentation fault' dev-libs\:apr-1.4.6-r1\:20130526-150156.log.gz
testlfs             : \/bin/bash: line 2:  8600 Segmentation fault      (core dumped) ./$prog


gcc-4.8.0, glibc-2.17 in the mean while
Comment 5 Toralf Förster gentoo-dev 2016-01-31 15:27:59 UTC
obsolete