Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 406047 - kde-base/{konsole,kwrite}: compose key doesn't work in non kde session env
Summary: kde-base/{konsole,kwrite}: compose key doesn't work in non kde session env
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: tracking upstream
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-27 16:51 UTC by Philip Webb
Modified: 2014-03-14 12:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
outpu (einfo.d1,3.15 KB, text/plain)
2012-02-27 16:53 UTC, Philip Webb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Webb 2012-02-27 16:51:58 UTC
KDE System Settings 4.8.0 has a menu for setting a compose key
& it has been set successfully in the file ~/.kde4/share/config/kxkbrc
with the generated line 'Options=compose:lctrl'.
However, this has no effect in Konsole & Kwrite: 'ctrl , c' should produce ç ,
but in fact simply leaves the characters ',c' ; I tried the other permutations
'ctrl c ,'  ', c ctrl'  'c , ctrl' without any success either.
The font was Luxi Mono, which has the character when used in Gvim.
I have set Vi-mode in Kwrite & Kate.

I tried the same setting in Mandriva 10 Spring (KDE 4.4.3) & it works there.
In my Gentoo box, I don't have all of KDE installed, only some apps I use
& the cause of the problem may be a missing package.  I tried Hotkeys,
but it made no difference.  If some other package is needed,
it should be a dependency for Systemsettings, whose absence is a bug.



Reproducible: Always

Steps to Reproduce:
1. Emerge Konsole, Kwrite (Kate) & Systemsettings 4.8.0
2. Set the compose key using Systemsettings
3. Enter an appropriate key pair in Konsole or Kwrite, eg 'ctrl , c'
Actual Results:  
The characters shown on the line are ', c'

Expected Results:  
The character should be 'ç' (c cedilla)
Comment 1 Philip Webb 2012-02-27 16:53:23 UTC
Created attachment 303507 [details]
outpu
Comment 2 Johannes Huber gentoo-dev 2012-02-27 19:01:06 UTC
Report upstream and link here back.
Comment 3 Philip Webb 2012-02-27 19:52:07 UTC
I have submitted KDE bug 294949 .
Comment 4 Andreas K. Hüttel gentoo-dev 2013-03-09 10:26:53 UTC
From the upstream bug: it works fine if a kde session is started via kdm, it does not work if single kde applications are started outside kde.
Comment 5 Michael Palimaka (kensington) gentoo-dev 2014-03-14 12:16:13 UTC
I don't think there's much we can do about this downstream. In any case, most of the KDE configuration options are KDE-specific anyway. What happens if an identical key binding is set in the parent WM?