Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 405089 - app-arch/p7zip-9.13 - ../../../Windows/Control/Controls.cpp:492:53: error: invalid conversion from 'INT (*)(LPARAM, LPARAM, LPARAM)' to 'int (*)(long int, long int, wxIntPtr)'
Summary: app-arch/p7zip-9.13 - ../../../Windows/Control/Controls.cpp:492:53: error: in...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Justin Lecher (RETIRED)
Depends on:
Reported: 2012-02-20 22:04 UTC by Alex Cannon
Modified: 2015-04-07 08:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Full build output for the failed p7zip build (p7zip.log,281.95 KB, text/plain)
2012-02-20 22:05 UTC, Alex Cannon

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Cannon 2012-02-20 22:04:17 UTC
The build fails when compiling Controls.cpp from the Windows directory. Why is it compiling Windows thing on Linux or are those related to compressing windows files?

I changed my CFLAGS to something standard and the build still failed. Could it be related having other programs installed with -ftree-vectorize and stuff?

i586-pc-linux-gnu-g++ -O2 -march=pentium3 -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DNDEBUG -D_REENTRANT -DENV_UNIX -D_7ZIP_LARGE_PAGES -DUNICODE -D_UNICODE -DLANG -DEXTERNAL_LZMA -DEXTERNAL_CODECS -DBENCH_MT -I. `wx-config --unicode=yes --cxxflags` -c -I. -I../../../myWindows -I../../../ -I../../../include_windows ../../../Windows/Control/Controls.cpp
../../../Windows/Control/Controls.cpp: In member function 'bool NWindows::NControl::CListView::SortItems(INT (*)(LPARAM, LPARAM, LPARAM), LPARAM)':
../../../Windows/Control/Controls.cpp:492:53: error: invalid conversion from 'INT (*)(LPARAM, LPARAM, LPARAM)' to 'int (*)(long int, long int, wxIntPtr)'
../../../Windows/Control/Controls.cpp:492:53: error:   initializing argument 1 of 'bool wxGenericListCtrl::SortItems(int (*)(long int, long int, wxIntPtr), wxIntPtr)'
make[1]: *** [Controls.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-arch/p7zip-9.13/work/p7zip_9.13/CPP/7zip/UI/GUI'
make: *** [7zG] Error 2
emake failed
 * ERROR: app-arch/p7zip-9.13 failed (compile phase):
 *   error building GUI

Reproducible: Always

# emerge --info
Portage (default/linux/x86/10.0, gcc-4.5.3, glibc-2.13-r4, 2.6.38-gentoo-r6 i686)
System uname: Linux-2.6.38-gentoo-r6-i686-Pentium_III_-Coppermine-with-gentoo-2.0.3
Timestamp of tree: Tue, 14 Feb 2012 15:30:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13::<unknown repository>, 2.68
sys-devel/automake:       1.5::<unknown repository>, 1.7.9-r1::<unknown repository>, 1.8.5-r4, 1.9.6-r2::<unknown repository>, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.4-r2, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
CFLAGS="-O2 -march=pentium3"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/qmail/alias /var/qmail/control /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium3"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acc acl alsa apache2 berkdb bittorrent bzip2 cddb cdparanoia cli consolekit cracklib crypt cups curl cxx dbus dga divx4linux dri dvd dvdread encode esound exif extensions extras faad fasttrack ffmpeg finger fltk fontconfig foomaticdb fortran ftp gd gdbm geoip gif gimp gimpprint gnutella gnutls gopher gpm gtk iconv idn imagemagick imap imlib innodb ipv6 javascript joystick jpeg kde libkms live lua mad maildir mikmod mmx modules motif mp2 mp3 mpeg mudflap mysql nas ncurses nls nntp nptl nptlonly ogg openft opengl openmp pam pcre png pnm policykit ppds pppd qt qt3 qt3support quicktime readline ruby sasl scanner sdl session slp snmp softmmu speex sse ssl sve svg sysfs tcpd theora tiff truetype unicode usb v4l vchkpw vorbis x264 x86 xft xml xmms xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="cgi actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Alex Cannon 2012-02-20 22:05:25 UTC
Created attachment 302637 [details]
Full build output for the failed p7zip build
Comment 2 Marcin Mirosław 2012-02-21 13:07:35 UTC
It looks like bug:
Btw, your arch (i586) looks quite ancient. For pentium3 i686 is ok.
Comment 3 Justin Lecher (RETIRED) gentoo-dev 2012-02-21 17:52:28 UTC
(In reply to comment #2)
> It looks like bug:
> Btw, your arch (i586) looks quite ancient. For pentium3 i686 is ok.

Does this patches fixes the issue?
Comment 4 Alex Cannon 2012-02-22 15:19:38 UTC
The patch fixed it.(In reply to comment #3)
> (In reply to comment #2)
> > It looks like bug:
> >
> > Btw, your arch (i586) looks quite ancient. For pentium3 i686 is ok.
> Does this patches fixes the issue?

It fixed it!
Comment 5 Justin Lecher (RETIRED) gentoo-dev 2012-05-30 19:43:20 UTC
I can't reproduce this issue and as the patch breaks compilation here and it seems frmo the upstream bug report that it is an wx-2.9 issue, which is still masked, we will wait.