Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404475 - gnome-base/gnome-shell-3.2.2.1 segfaults in on_apps_tree_changed_cb()
Summary: gnome-base/gnome-shell-3.2.2.1 segfaults in on_apps_tree_changed_cb()
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 05:08 UTC by Andrew Hamilton
Modified: 2013-08-25 15:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
:0.log (0.log,115.49 KB, text/plain)
2012-02-19 05:21 UTC, Andrew Hamilton
Details
:0-greeter.log (0-greeter.log,486.01 KB, text/plain)
2012-02-19 05:22 UTC, Andrew Hamilton
Details
:0-slave.log (0-slave.log,91 bytes, text/plain)
2012-02-19 05:22 UTC, Andrew Hamilton
Details
:0.log (0.log,114.40 KB, text/plain)
2012-02-19 08:01 UTC, Andrew Hamilton
Details
:0-greeter.log (0-greeter.log,50.19 KB, text/plain)
2012-02-19 08:01 UTC, Andrew Hamilton
Details
:0-slave.log (0-slave.log,91 bytes, text/plain)
2012-02-19 08:01 UTC, Andrew Hamilton
Details
abrt backtrace (backtrace,38.79 KB, text/plain)
2012-02-19 15:59 UTC, Chris Reffett (RETIRED)
Details
gnome-shell patch to test (0001-app-system-guard-against-NULL-error-on-gmenu_tree_lo.patch,1.20 KB, patch)
2012-02-19 18:30 UTC, Alexandre Rostovtsev (RETIRED)
Details | Diff
:0-greeter.log (0-greeter.log,46.35 KB, text/plain)
2012-02-20 02:53 UTC, Andrew Hamilton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Hamilton 2012-02-19 05:08:17 UTC
gnome-shell segfaults when run as a part of gdm 3.2.1.1 when using the nvidia-drivers 290.10 opengl implementation.  The following appears in dmesg when starting gdm via the init script with nvidia's opengl implementation selected:

gnome-shell[11980]: segfault at 8 ip 00007fe1e930dfe2 sp 00007fff539a0400 error 4 in libgnome-shell.so[7fe1e92dd000+a0000]
gnome-shell[11986]: segfault at 8 ip 00007fa205a10fe2 sp 00007fff0859fa20 error 4 in libgnome-shell.so[7fa2059e0000+a0000]

Reproducible: Always

Steps to Reproduce:
1. eselect opengl set nvidia
2. set DISPLAYMANAGER="gdm" in /etc/conf.d/xdm
3. /etc/init.d/xdm start
Actual Results:  
gdm segfaults with errors in libgnome-shell.so

Expected Results:  
GDM should have started normally.

Portage 2.2.0_alpha86 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 2.6.38-wkstn x86_64)
=================================================================
System uname: Linux-2.6.38-wkstn-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8300_@_2.83GHz-with-gentoo-2.1
Timestamp of tree: Sat, 18 Feb 2012 06:00:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise kde gamerlay-stable science tjcsl
Installed sets: @kde-4.7
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 dlj-1.1 googleearth Q3AEULA LOKI-EULA Intel-SDP Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -mno-tls-direct-seg-refs -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/bin/startfluxbox /usr/share/config /usr/share/fluxbox/menu /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -mno-tls-direct-seg-refs -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.tjhsst.edu/gentoo http://mirror.rit.edu/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en es jp zh zh_CN zh_TW"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/kde /var/lib/layman/gamerlay /var/lib/layman/science /usr/local/portage/overlay"
SYNC="rsync://rsync.csl.tjhsst.edu/gentoo-portage"
USE="X a52 aac acl acpi ads alsa amd64 bash-completion berkdb bluetooth bzip2 cairo cdda cddb cdr cjk cli consolekit cracklib crypt cups curl cxx dbus dmx dri dvd encodex exif fam fbcon fftw flac fortran ftp gd gdbm gif gnome gnustep gnutls gpm gstreamer gtk iconv icu imagemagick ipv6 java jpeg kde kerberos latex ldap libcaca libnotify mad mmx mng modules mono motif mp3 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pch pcre pdf php plotutils png policykit ppds pppd python qt3support qt4 quicktime readline ruby samba sasl sdl semantic-desktop session slang soap spell sqlite sqlite3 sse sse2 ssl svg sysfs tcl tcpd theora threads tiff tk truetype unicode usb v4l v4l2 vim-syntax vorbis webgl wmf x264 xcb xcomposite xine xinerama xml xorg xpm xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en es jp zh zh_CN zh_TW" NETBEANS_MODULES="apisupport cnd dlight enterprise harness ide java mobility nb php profiler websvccommon" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nv vga fbdev intel none" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-19 05:17:35 UTC
Please attach /var/log/gdm/:0.log, /var/log/gdm/:0-greeter.log, and /var/log/gdm/:0-slave.log.
Comment 2 Andrew Hamilton 2012-02-19 05:21:27 UTC
Created attachment 302463 [details]
:0.log
Comment 3 Andrew Hamilton 2012-02-19 05:22:00 UTC
Created attachment 302465 [details]
:0-greeter.log
Comment 4 Andrew Hamilton 2012-02-19 05:22:14 UTC
Created attachment 302467 [details]
:0-slave.log
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-19 05:52:30 UTC
(In reply to comment #2)
> Created attachment 302463 [details]
> :0.log

This is the problem:

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.

I strongly suspect that this glx failure is the cause of the gnome-shell segfault and the gnome-session-check-accelerated failure that can be seen in :0-greeter.log.

See http://www.gentoo.org/doc/en/nvidia-guide.xml for an introduction to configuring nvidia-drivers in Gentoo.

Please reopen this bug if the gnome-shell segfault still occurs after you have an nvidia-drivers setup with correctly working glx on your machine.
Comment 6 Andrew Hamilton 2012-02-19 08:01:00 UTC
Created attachment 302473 [details]
:0.log
Comment 7 Andrew Hamilton 2012-02-19 08:01:25 UTC
Created attachment 302475 [details]
:0-greeter.log
Comment 8 Andrew Hamilton 2012-02-19 08:01:49 UTC
Created attachment 302479 [details]
:0-slave.log
Comment 9 Andrew Hamilton 2012-02-19 08:04:24 UTC
I've fixed the nvidia GLX errors in xorg and have attached updated logs.  gnome-session continues to segfault with the same errors.  Please let me know if you need any more information.
Comment 10 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-19 12:23:19 UTC
(In reply to comment #9)
> I've fixed the nvidia GLX errors in xorg and have attached updated logs. 
> gnome-session continues to segfault with the same errors.  Please let me know
> if you need any more information.

Yes - we need a backtrace of the crash. To get it, please do the following:

1. please re-emerge gnome-shell, clutter, cogl, gjs, spidermonkey, glib, and
gobject-introspection with "-ggdb" in CFLAGS and "splitdebug" in FEATURES (see
http://www.gentoo.org/proj/en/qa/backtraces.xml)

2. emerge app-admin/abrt

3. /etc/init.d/abrt start

4. get the gdm's gnome-shell process to segfault

5. From a terminal or a console, run "abrt-cli list". You will see a list of
reported crashes. Probably the most recent one will be gnome-shell listed as
"@0".

6. Run "abrt-cli report @0" (or @1, etc., depending on how the most recent
gnome-shell crash was listed).

7. When prompted, choose to use the local gnu debugger, and to report using logger.

8. abrt-cli will launch your default console editor (nano, probably), and you
will need to save the report file in the default location.

9. You will end up with a file called "backtrace" in a directory starting with /var/spool/abrt/ccpp-2012* or ~/.abrt/spool/ccpp-2012*. Please attach it.
Comment 11 Chris Reffett (RETIRED) gentoo-dev Security 2012-02-19 15:59:45 UTC
Created attachment 302511 [details]
abrt backtrace

Note: Andrew and I have access to the same hardware, so this is from the same box as he was working on. I built the requested packages with splitdebug and -ggdb, installed abrt, segfaulted gdm, and have attached the backtrace.
Comment 12 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-19 18:30:49 UTC
Created attachment 302533 [details, diff]
gnome-shell patch to test

(In reply to comment #11)

Thanks. From the backtrace, it appears that gnome-shell is crashing because gmenu_tree_load_sync() returns FALSE without setting error, and gnome-shell tries to print error->message while error is NULL. However, after examining the current gnome-menus source, I do not see an execution path where gmenu_tree_load_sync() could fail without setting the error parameter.

First of all, to make sure that the diagnosis is correct, please test gnome-shell with the attached patch.
Comment 13 Andrew Hamilton 2012-02-20 02:53:07 UTC
Created attachment 302557 [details]
:0-greeter.log

The patch appears to have fixed the bug; gnome-shell no longer segfaults when run as a part of GDM.  I have attached an updated :0-greeter.log
Comment 14 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-20 03:31:40 UTC
(In reply to comment #13)

Thanks. The patch that I had attached here is an ugly workaround; the problem needs to be fixed in the gnome-menus library. I have filed a bug with gnome-menus upstream developers at https://bugzilla.gnome.org/show_bug.cgi?id=670418 to figure out why gmenu_tree_load_sync() is failing to set the error parameter on failure: 

Please add yourself to the upstream bug's CC list because gnome-menus developers may want to ask you some questions. (You will need to create a gnome bugzilla account if you don't have one already.)
Comment 15 Pacho Ramos gentoo-dev 2013-08-23 09:31:50 UTC
Is this still a problem with 3.8?
Comment 16 Gilles Dartiguelongue gentoo-dev 2013-08-25 15:35:48 UTC
NEEDINFO per last query.