Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404423 - dev-lisp/ecls-12.2.1 fails to run tests - An error occurred during initialization: Module error: Don't know how to REQUIRE ECL-CURL..
Summary: dev-lisp/ecls-12.2.1 fails to run tests - An error occurred during initializa...
Status: RESOLVED DUPLICATE of bug 422787
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Common Lisp Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 17:45 UTC by Markus Oehme
Modified: 2015-11-08 10:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,612.96 KB, text/plain)
2012-02-18 17:45 UTC, Markus Oehme
Details
emerge --info (info.txt,5.42 KB, text/plain)
2012-02-18 17:45 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2012-02-18 17:45:40 UTC
Created attachment 302399 [details]
build log

On my hardened ~amd64 machine with gcc-4.6.2 I see the following problem when trying to run the test suite for ecls.

make[3]: Entering directory `/var/tmp/portage/dev-lisp/ecls-12.2.1/work/ecl-12.2.1/build/tests'
ecl -norc -load config.lsp -eval '(ecl-tests::ensure-ansi-tests)' -eval '(ext:quit)' < /dev/null
;;; Loading "/var/tmp/portage/dev-lisp/ecls-12.2.1/work/ecl-12.2.1/build/tests/config.lsp"
An error occurred during initialization:
Module error: Don't know how to REQUIRE ECL-CURL..
make[3]: *** [ansi-tests] Error 1
Comment 1 Markus Oehme 2012-02-18 17:45:57 UTC
Created attachment 302401 [details]
emerge --info
Comment 2 Markus Oehme 2013-02-02 10:15:50 UTC
Just rerun with ecls-12.12.1 and everything is fine. One note though: if ecls is a new package (i.e. not already installed) the tests failed.
Comment 3 Pacho Ramos gentoo-dev 2015-11-08 10:08:30 UTC

*** This bug has been marked as a duplicate of bug 422787 ***