Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404345 - app-emulation/virtualbox-modules-4.1.4 - work/vboxpci/linux/VBoxPci-linux.c:989:9: Fehler: Zu wenige Argumente für Funktion »iommu_domain_alloc«
Summary: app-emulation/virtualbox-modules-4.1.4 - work/vboxpci/linux/VBoxPci-linux.c:9...
Status: RESOLVED DUPLICATE of bug 389953
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 08:31 UTC by Thomas Rausch
Modified: 2013-10-03 19:28 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.14 KB, text/plain)
2012-02-18 16:57 UTC, Thomas Reinhold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Rausch 2012-02-18 08:31:16 UTC
make[2]: Entering directory `/usr/src/linux-3.2.1-gentoo-r2'
  CC [M]  /tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/VBoxPci-linux.o
  CC [M]  /tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/VBoxPci.o
  CC [M]  /tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/SUPR0IdcClient.o
  CC [M]  /tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/SUPR0IdcClientComponent.o
  CC [M]  /tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/SUPR0IdcClient-linux.o
/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/VBoxPci-linux.c: In Funktion »VBoxPciLinuxInit«:
/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/VBoxPci-linux.c:149:5: Fehler: Implizite Deklaration der Funktion »iommu_found«
/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/VBoxPci-linux.c: In Funktion »vboxPciOsInitVm«:
/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/VBoxPci-linux.c:989:9: Fehler: Zu wenige Argumente für Funktion »iommu_domain_alloc«
include/linux/iommu.h:68:29: Anmerkung: declared here
make[3]: *** [/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci/linux/VBoxPci-linux.o] Fehler 1
make[2]: *** [_module_/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci] Fehler 2
make[2]: Leaving directory `/usr/src/linux-3.2.1-gentoo-r2'
make[1]: *** [vboxpci] Fehler 2
make[1]: Leaving directory `/tmp/pool/wiesel-1202/portage/app-emulation/virtualbox-modules-4.1.4/work/vboxpci'
cp: Aufruf von stat für „vboxpci/vboxpci.ko“ nicht möglich: Datei oder Verzeichnis nicht gefunden


Reproducible: Always
Comment 1 Thomas Reinhold 2012-02-18 16:55:44 UTC
same here,
it seems that, Update to virtualbox-...-4.1.8 solve this.

http://forums.gentoo.org/viewtopic-p-6945916.html?sid=b7402b88ff40f3d2ba52cab14ae5bf14


emerge --info =app-emulation/virtualbox-modules-4.1.4
Portage 2.1.10.44 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-AMD_Turion-tm-_64_X2_Mobile_Technology_TL-50-with-gentoo-2.1
Timestamp of tree: Fri, 17 Feb 2012 22:30:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo vdr-devel Toms-Repository
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mtune=native -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -mtune=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles metadata-transfer news nodoc noinfo noman parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/local/portage/packages/laptop"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/vdr-devel /usr/local/portage/tom"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 ao apm bluetooth bzip2 chm cli consolekit cracklib crypt cups custom-optimization cxx dbus declarative desktopglobe djvu dri dvd exif ffmpeg flac fortran fuse gdbm gpm gstreamer icedtea-bin iconv id3tag ios iphone ipod ipv6 java jpeg jpeg2k kde lame laptop libnotify libsamplerate lm_sensors lzma mad mjpeg mmx mmxext modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ntp ogg opengl openmp pam pcre pdf phonon png policykit pppd pulsaudio pulseaudio python2 qalculate qemu qt3support qt4 readline rss samba scim sdl semantic-desktop session sndfile sql sqlite sse sse2 ssl svg sysfs taglib tcpd thumbnail tiff truetype unicode upnp usb vorbis wavpack webkit wicd x264 xattr xcomposite xinerama xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Thomas Reinhold 2012-02-18 16:57:37 UTC
Created attachment 302397 [details]
build.log
Comment 3 Ben Kohler gentoo-dev 2013-10-03 19:28:28 UTC

*** This bug has been marked as a duplicate of bug 389953 ***