Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404283 - media-gfx/imagemagick - convert: unable to close module `SVG': /usr/lib64/qt4/libQtGui.so.4: undefined symbol: _ZN11QMetaObject11removeGuardEPP7QObject @ warning/module.c/UnregisterModule/1605.
Summary: media-gfx/imagemagick - convert: unable to close module `SVG': /usr/lib64/qt4...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
: 407479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-17 17:20 UTC by Francesco Lamonica
Modified: 2012-06-12 21:07 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of the convert command with LD_DEBUG="symbols bindings" (ld_debug_output.txt,16.29 KB, text/plain)
2012-04-18 06:32 UTC, diego.amores
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Lamonica 2012-02-17 17:20:17 UTC
if at prompt i do: convert chart.svg chart.png

i get the following error:

convert: unable to close module `SVG': /usr/lib64/qt4/libQtGui.so.4: undefined symbol: _ZN11QMetaObject11removeGuardEPP7QObject @ warning/module.c/UnregisterModule/1605.
convert: symbol lookup error: /usr/lib64/qt4/libQtGui.so.4: undefined symbol: _ZN11QMetaObject11removeGuardEPP7QObject

Reproducible: Always




emerge --info 
Portage 2.1.10.44 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.1.6-gentoo x86_64)
=================================================================
System uname: Linux-3.1.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 17 Feb 2012 11:00:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -mno-avx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mno-avx"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi aften akode alsa amazon amd64 amr amrnb amrwb animgif audiofile branding bzip2 cairo ccache cdda cdr cleartype cli consolekit cracklib crypt cscope cups curl cxx dbus dri dts dvd dvdr ebook encode exif fam ffmpeg firefox flac foomaticdb gcrypt gd gdbm gdu gif gimp gkrellm gpm gsm gtk hardened iconv imagemagick ipod java java6 jpeg lame lcms libgcrypt libssh2 logrotate loop-aes mad matroska mmx mmxext mng modules mp3 mp4 mpeg mpeg2 mplayer mudflap multilib musepack musicbrainz ncurses nls nptl nptlonly nsplugin ogg opencore-amr opengl openmp openssl opensslcrypt pam pango pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 readline samba sdl session smp sndfile speex spell sql sqlite3 sse sse2 sse3 sse4.1 sse4.2 sse4a sse5 ssl startup-notification subversion svg svnserve swat sysfs syslog tcpd theora tiff truetype udev unicode usb v4l v4l2 vorbis webkit x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa radeonhd vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2012-02-17 17:24:32 UTC
Please rebuild x11-libs/qt-gui and try again. Running revdep-rebuild might help too.
Comment 2 Francesco Lamonica 2012-02-17 17:58:45 UTC
i had re-emerged qt-gui, qt-svg and imagemagick before submitting the bug :)
Comment 3 Samu Voutilainen 2012-02-24 15:11:28 UTC
Same error happens here.

I tried rebuilding librsvg, didn’t help either.
Comment 4 Samuli Suominen gentoo-dev 2012-03-09 10:37:30 UTC
*** Bug 407479 has been marked as a duplicate of this bug. ***
Comment 5 Davide Pesavento gentoo-dev 2012-03-09 11:52:48 UTC
Try rebuilding cairo please.
Comment 6 Samuli Suominen gentoo-dev 2012-03-13 20:39:11 UTC
(In reply to comment #5)
> Try rebuilding cairo please.

Replying for the user. He rebuilt cairo. No change.
Comment 7 Francesco Lamonica 2012-03-19 13:47:00 UTC
As Samuli said,
rebuilt cairo: nothing changed
Comment 8 Davide Pesavento gentoo-dev 2012-03-31 00:34:50 UTC
Please retry with Qt 4.8.1
Comment 9 Francesco Lamonica 2012-04-01 15:55:29 UTC
Hi Davide, unfortunately i am on stable amd64 so i cannot emerge 4.8.1
Comment 10 Davide Pesavento gentoo-dev 2012-04-01 16:47:18 UTC
(In reply to comment #9)
> Hi Davide, unfortunately i am on stable amd64 so i cannot emerge 4.8.1

Anyone else who is able to reproduce this bug with qt 4.8.1?
Comment 11 diego.amores 2012-04-15 09:08:22 UTC
I can reproduce this error message on x86 stable, with qt-gui-4.7.4-r1. The PNG output file is correctly generated though.

Also, starting firefox-bin on a console gives the following output, and then continues to work as expected:
/opt/firefox/firefox: symbol lookup error: /usr/lib/qt4/libQtGui.so.4: undefined symbol: _ZN11QMetaObject11removeGuardEPP7QObject
Comment 12 Davide Pesavento gentoo-dev 2012-04-15 17:37:10 UTC
What's the output of
$ nm -D /usr/lib64/qt4/libQtCore.so.4 | grep ZN11QMetaObject11removeGuardEPP7QObject
Comment 13 diego.amores 2012-04-16 19:54:00 UTC
# nm -D /usr/lib/qt4/libQtCore.so.4 \
| grep ZN11QMetaObject11removeGuardEPP7QObject
0016fae0 T _ZN11QMetaObject11removeGuardEPP7QObject
Comment 14 Davide Pesavento gentoo-dev 2012-04-16 20:21:52 UTC
And what's the output of 'ldd /usr/bin/convert'?
Comment 15 diego.amores 2012-04-16 20:31:53 UTC
# ldd /usr/bin/convert
        linux-gate.so.1 =>  (0xb774b000)
        libMagickCore.so.5 => /usr/lib/libMagickCore.so.5 (0xb74b2000)
        libMagickWand.so.5 => /usr/lib/libMagickWand.so.5 (0xb7394000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb737a000)
        libc.so.6 => /lib/libc.so.6 (0xb721c000)
        liblcms2.so.2 => /usr/lib/liblcms2.so.2 (0xb71d5000)
        libtiff.so.5 => /usr/lib/libtiff.so.5 (0xb716b000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb70cd000)
        libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb7079000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb7068000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb705f000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb7045000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb6f25000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xb6ed1000)
        libbz2.so.1 => /lib/libbz2.so.1 (0xb6ec0000)
        libz.so.1 => /lib/libz.so.1 (0xb6eab000)
        libm.so.6 => /lib/libm.so.6 (0xb6e85000)
        libgomp.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/4.5.3/libgomp.so.1 (0xb6e76000)
        librt.so.1 => /lib/librt.so.1 (0xb6e6d000)
        libltdl.so.7 => /usr/lib/libltdl.so.7 (0xb6e63000)
        libdl.so.2 => /lib/libdl.so.2 (0xb6e5f000)
        /lib/ld-linux.so.2 (0xb774c000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb6e5a000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6e3e000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb6e3a000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6e34000)
Comment 16 Davide Pesavento gentoo-dev 2012-04-16 22:04:41 UTC
Ah sorry, of course it's the SVG module that has the symbol issue, so find that module and run ldd on it please.
Comment 17 Davide Pesavento gentoo-dev 2012-04-17 15:45:26 UTC
Also post the output of emerge -pv imagemagick please.
Comment 18 Davide Pesavento gentoo-dev 2012-04-17 16:31:32 UTC
(In reply to comment #16)
> Ah sorry, of course it's the SVG module that has the symbol issue, so find
> that module and run ldd on it please.

The full path is /usr/lib/ImageMagick-6.7.6/modules-Q16/coders/svg.so
Comment 19 diego.amores 2012-04-17 21:06:23 UTC
# ldd /usr/lib/ImageMagick-6.7.6/modules-Q16/coders/svg.so
        linux-gate.so.1 =>  (0xb7726000)
        libMagickWand.so.5 => /usr/lib/libMagickWand.so.5 (0xb75df000)
        libMagickCore.so.5 => /usr/lib/libMagickCore.so.5 (0xb735e000)
        liblcms2.so.2 => /usr/lib/liblcms2.so.2 (0xb7318000)
        libtiff.so.5 => /usr/lib/libtiff.so.5 (0xb72ae000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb720f000)
        libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb71bb000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb71aa000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xb7156000)
        libbz2.so.1 => /lib/libbz2.so.1 (0xb7145000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb712b000)
        libltdl.so.7 => /usr/lib/libltdl.so.7 (0xb7120000)
        libdl.so.2 => /lib/libdl.so.2 (0xb711c000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb7113000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb70fa000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb6fda000)
        libgomp.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/4.5.3/libgomp.so.1 (0xb6fcb000)
        librsvg-2.so.2 => /usr/lib/librsvg-2.so.2 (0xb6f98000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb6e82000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb6e65000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6d71000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb6d6c000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6d24000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb6d1e000)
        librt.so.1 => /lib/librt.so.1 (0xb6d15000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb6c09000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6add000)
        libz.so.1 => /lib/libz.so.1 (0xb6ac8000)
        libm.so.6 => /lib/libm.so.6 (0xb6aa1000)
        libc.so.6 => /lib/libc.so.6 (0xb6943000)
        /lib/ld-linux.so.2 (0xb7727000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb693e000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6923000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6916000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb68d3000)
        libcroco-0.6.so.3 => /usr/lib/libcroco-0.6.so.3 (0xb689c000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb6887000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6828000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb67f7000)
        libEGL.so.1 => /usr/lib/libEGL.so.1 (0xb67df000)
        libpng15.so.15 => /usr/lib/libpng15.so.15 (0xb67b4000)
        libQtGui.so.4 => /usr/lib/qt4/libQtGui.so.4 (0xb5d14000)
        libQtCore.so.4 => /usr/lib/qt4/libQtCore.so.4 (0xb5a7c000)
        libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0xb5a77000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb5a6f000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb5a65000)
        libGL.so.1 => /usr/lib/opengl/xorg-x11/lib/libGL.so.1 (0xb5a17000)
        libgcc_s.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/4.5.3/libgcc_s.so.1 (0xb59fa000)
        libffi.so.5 => /usr/lib/libffi.so.5 (0xb59f2000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb59ed000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb59e7000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb59be000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb5994000)
        libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0xb5991000)
        libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0xb598c000)
        libxcb-xfixes.so.0 => /usr/lib/libxcb-xfixes.so.0 (0xb5985000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb597a000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb5971000)
        libstdc++.so.6 => /usr/lib/gcc/i686-pc-linux-gnu/4.5.3/libstdc++.so.6 (0xb5883000)
        libglapi.so.0 => /usr/lib/libglapi.so.0 (0xb586c000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb5868000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb5862000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb585c000)
        libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0xb5849000)


# emerge -pv imagemagick
...
[ebuild   R    ] media-gfx/imagemagick-6.7.6.4  USE="X bzip2 cxx jpeg lcms openmp pango png svg tiff truetype xml zlib -autotrace -corefonts -djvu -fftw -fontconfig -fpx -graphviz -gs -hdri -jbig -jpeg2k -lqr -lzma -opencl -openexr -perl -q32 -q64 -q8 -raw -static-libs -test -webp -wmf" 0 kB
...
Comment 20 Davide Pesavento gentoo-dev 2012-04-17 23:08:58 UTC
mmm I still don't understand what's going on... Run the following and post or attach the output:

LD_DEBUG="symbols bindings" convert foo.svg foo.png 2>&1 | grep ZN11QMetaObject11removeGuardEPP7QObject
Comment 21 diego.amores 2012-04-18 06:32:48 UTC
Created attachment 309381 [details]
Output of the convert command with LD_DEBUG="symbols bindings"
Comment 22 bazurbat 2012-04-22 13:08:19 UTC
Came here from google search. I'm getting the same undefined symbol message with thunderbird-bin (11.0) on full ~amd64 system (qt-gui-4.8.1 etc.)

Portage 2.3.3-r4 (default/linux/amd64/2008.0/desktop, gcc-4.6.2, glibc-2.13-r4, 3.3.2-gentoo x86_64)
=================================================================
System uname: Linux-3.3.2-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.1.8
Timestamp of tree: Fri, 20 Apr 2012 06:00:01 +0000
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.4_pre20120415, 3.2.4_pre20120415
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1.8-r3
sys-apps/openrc:          0.8.3-r8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.2-r1
sys-devel/gcc-config:     1.5
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo kde vmware local
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="en ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde /usr/local/portage/layman/vmware /usr/local/portage/my"
SYNC="git://github.com/funtoo/portage-mini-2011.git"
SYNC_USER="root"
USE="X a52 aac acl acpi alac alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr dvdread emboss encode exif fam firefox flac fortran gdbm gdu gif gpm gtk iconv jpeg kde lame lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pch pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vdpau vorbis wavpack wxwidgets x264 xattr xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="
actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" 
VIDEO_CARDS="vesa nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK
Comment 23 Davide Pesavento gentoo-dev 2012-05-22 22:19:04 UTC
Can you still reproduce the issue with Qt 4.8.1 (now stable) ?
Comment 24 Davide Pesavento gentoo-dev 2012-06-12 21:07:38 UTC
(In reply to comment #23)
> Can you still reproduce the issue with Qt 4.8.1 (now stable) ?

Closing since no one replied to the above question and no one I talked to is able to reproduce with Qt 4.8.x