Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 403913 - app-emulation/fs-uae - FS-UAE integrates the most accurate Amiga emulation code available from WinUAE.
Summary: app-emulation/fs-uae - FS-UAE integrates the most accurate Amiga emulation co...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 6 votes (vote)
Assignee: Gentoo Games
URL: https://fs-uae.net
Whiteboard: Proxy Maintenance offered
Keywords: EBUILD, Inclusion, PATCH
Depends on:
Blocks:
 
Reported: 2012-02-15 15:40 UTC by frostwork
Modified: 2019-04-20 10:04 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
games-emulation/fs-uae-0.9.7.ebuild (fs-uae-0.9.7.ebuild,1.02 KB, text/plain)
2012-02-15 15:41 UTC, frostwork
Details
games-emulation/fs-uae/files/fs-uae-0.9.7-minizip.patch (fs-uae-0.9.7-minizip.patch,1.17 KB, patch)
2012-02-15 15:42 UTC, frostwork
Details | Diff
app-emulation/fs-uae-0.9.7.ebuild (fs-uae-0.9.7.ebuild,882 bytes, text/plain)
2012-02-15 17:27 UTC, frostwork
Details
FS-UAE ebuild from the roslin overlay. (fs-uae-2.2.2.ebuild,513 bytes, text/plain)
2013-06-09 21:53 UTC, Michał Ziąbkowski
Details
Ebuild for the FS-UAE launcher from roslin overlay. (fs-uae-launcher-2.2.2.ebuild,616 bytes, text/plain)
2013-06-09 21:54 UTC, Michał Ziąbkowski
Details
fs-uae-2.2.2.ebuild (fs-uae-2.2.2.ebuild,502 bytes, text/plain)
2013-06-11 12:21 UTC, Michał Ziąbkowski
Details
fs-uae-launcher-2.2.2.ebuild (fs-uae-launcher-2.2.2.ebuild,605 bytes, text/plain)
2013-06-11 12:21 UTC, Michał Ziąbkowski
Details
app-emulation/fs-uae/fs-uae-2.4.0.ebuild (fs-uae-2.4.0.ebuild,570 bytes, text/plain)
2014-02-25 16:39 UTC, Michał Ziąbkowski
Details
app-emulation/fs-uae-launcher-2.4.0.ebuild (fs-uae-launcher-2.4.0.ebuild,783 bytes, text/plain)
2014-02-25 16:41 UTC, Michał Ziąbkowski
Details
fs-uae-launcher-drop-bundled-lhafile.patch (fs-uae-launcher-drop-bundled-lhafile.patch,316 bytes, patch)
2014-02-25 16:42 UTC, Michał Ziąbkowski
Details | Diff
dev-python/python-lhafile-0.1.0_p3.ebuild (python-lhafile-0.1.0_p3.ebuild,473 bytes, text/plain)
2014-02-25 16:44 UTC, Michał Ziąbkowski
Details
app-emulation/fs-uae-2.8.3.ebuild (fs-uae-2.8.3.ebuild,1.65 KB, text/plain)
2017-08-18 07:11 UTC, Sven Eden
Details
fs-uae-2.8.3_libmpeg2.patch (fs-uae-2.8.3_libmpeg2.patch,1008 bytes, patch)
2017-08-18 07:12 UTC, Sven Eden
Details | Diff
app-emulation/fs-uae-launcher-2.8.3 (fs-uae-launcher-2.8.3.ebuild,1.43 KB, text/plain)
2017-08-18 07:15 UTC, Sven Eden
Details
fs-uae-launcher-2.8.3-German-ROMS.patch (fs-uae-launcher-2.8.3-German-ROMs.patch,747 bytes, patch)
2017-08-18 07:17 UTC, Sven Eden
Details | Diff
fs-uae-launcher-2.8.3-Makefile.patch (fs-uae-launcher-2.8.3-Makefile.patch,626 bytes, patch)
2017-08-18 07:20 UTC, Sven Eden
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description frostwork 2012-02-15 15:40:52 UTC
initial fs-uae-0.9.7.ebuild for the amiga emulator fs-uae.


Reproducible: Always
Comment 1 frostwork 2012-02-15 15:41:59 UTC
Created attachment 302049 [details]
games-emulation/fs-uae-0.9.7.ebuild

imho for this amiga emulator games-emulator is the better category
Comment 2 frostwork 2012-02-15 15:42:31 UTC
Created attachment 302051 [details, diff]
games-emulation/fs-uae/files/fs-uae-0.9.7-minizip.patch

fs-uae-0.9.7-minizip.patch
Comment 3 Mr. Bones. (RETIRED) gentoo-dev 2012-02-15 16:23:12 UTC
maybe should go with the rest of the uae stuff.
Comment 4 frostwork 2012-02-15 16:52:02 UTC
app-emulation/fs-uae in gamerlay ;)
Comment 5 frostwork 2012-02-15 17:27:10 UTC
Created attachment 302055 [details]
app-emulation/fs-uae-0.9.7.ebuild

removed src_install() as it was incomplete and not necessary...
I don't care about the category, but as this emulator behaves more than a rom launcher than a system emulator, I'd suggest games-emulation
Comment 6 Michał Ziąbkowski 2013-06-09 21:53:52 UTC
Created attachment 350580 [details]
FS-UAE ebuild from the roslin overlay.
Comment 7 Michał Ziąbkowski 2013-06-09 21:54:53 UTC
Created attachment 350582 [details]
Ebuild for the FS-UAE launcher from roslin overlay.
Comment 8 droshalla 2013-06-11 11:23:49 UTC
Thank you Marcel and Michał.

This is a great emulator. It's also much more advanced than app-emulation/uae or app-emulation/e-uae. Any chance to move this to the regular/main portage tree?

Also, the project has since moved to a new domain: http://fs-uae.net/
The old URL is still active, though.
Comment 9 Michał Ziąbkowski 2013-06-11 12:20:57 UTC
I agree, it is much nicer to use than its alternatives. Being actively maintained also makes a huge difference.

As for the urls, you're right. I knew about this, but it slipped my mind. Attaching updated ebuilds.
Comment 10 Michał Ziąbkowski 2013-06-11 12:21:29 UTC
Created attachment 350740 [details]
fs-uae-2.2.2.ebuild
Comment 11 Michał Ziąbkowski 2013-06-11 12:21:48 UTC
Created attachment 350742 [details]
fs-uae-launcher-2.2.2.ebuild
Comment 12 droshalla 2013-09-07 07:15:09 UTC
Version bump, please: FS-UAE 2.2.3 (stable) and 2.3.6dev (development). Would be great to finally see the ebuild show up in the main portage tree. Thanks guys!
Comment 13 Marcin Kowalski 2013-10-16 08:56:47 UTC
I don't want to open a bug before i make sure i didn't do something wrong. 

I cannot get the 2.2.3 launcher to work. It fails with module 'wx' not found by python 2.7. 

The launcher pulls in wxgtk:2.9 and wxpython is built for python2.7, also python2.7 is set as main python implementation system-wide. I am not sure what is going wrong here, perhaps it needs :2.8 slot of wxgtk, instead of now :2.9 being the most recent one ?
Comment 14 Andreas Thalhammer 2013-12-07 20:20:52 UTC
Thanks for the ebuilds! I renamed them to -2.2.3 as this is the current version and all compiled fine and runs as expected.

I'd really like to see this ebuild in the main portage tree to replace (or as an alternative to) e-uae because I get a segmentation fault (ARCH=amd64) with e-uae all the time whereas fs-uae on the other hand works just fine.

I just wanted to report that I don't get any python error with fs-uae-launcher.
Comment 15 frostwork 2013-12-08 06:39:27 UTC
yeah, just a few months and my bug is 2 years old...
time's up that this finally gets into portage (does the games herd still exist?).
I just commited the latest devel fs-uae 2.3.11 to the gamerlay overlay
(doing this randomly, so I might miss some updates).
no fs-uae-launcher ebuild yet.
Comment 16 Andreas Thalhammer 2013-12-08 10:33:45 UTC
(In reply to Marcel Unbehaun from comment #15)
> yeah, just a few months and my bug is 2 years old...
> time's up that this finally gets into portage (does the games herd still
> exist?).

Please vote for this bug. Maybe that will help...

> I just commited the latest devel fs-uae 2.3.11 to the gamerlay overlay
> (doing this randomly, so I might miss some updates).
> no fs-uae-launcher ebuild yet.

The fs-uae-launcher ebuild in comment #11 from Michał Ziąbkowski works very well for 2.2.3, have you tested it with the devel version as well?
Comment 17 frostwork 2013-12-08 11:44:03 UTC
I voted for it by opening it :}
Imho a herd should be interested in its category anyway and therefore should see
if some ancient deprecated ebuilds should be replaced by its successors.
So I don't think a vote helps here.
Just commited a slightly modified (needs dev-python/pyside now) fs-uae-launcher-2.3.11 ebuild to gamerlay.
Haven't tested it much yet, no idea if dependencies are missing (f.e. sqlite?)
Thanks for the initial ebuild, Michał!
Comment 18 Michał Ziąbkowski 2013-12-08 12:48:25 UTC
Actually, the development version of the launcher seems to have switched to Qt. I was going to update the ebuild once that got a stable release. Anyway, the old wxpython code is still there but is disabled, judging from the contents of fsui/__init__.py.
Comment 19 Andreas Thalhammer 2013-12-08 13:49:40 UTC
In the meantime wouldn't it be good to add 2.2.3 to portage and (hard)mask e-uae because of the segfaults?
Comment 20 Roc Vallès 2013-12-14 23:50:24 UTC
(In reply to Andreas Thalhammer from comment #19)
> In the meantime wouldn't it be good to add 2.2.3 to portage and (hard)mask
> e-uae because of the segfaults?
It would be good to add it to portage, but fs-uae is no replacement for e-uae. It's too centered on playing games, rather than general emulation of the Amiga.

Replacing the dead e-uae would be covered by PUAE at #351652.
Comment 21 Michał Ziąbkowski 2014-02-25 16:39:07 UTC
Created attachment 371232 [details]
app-emulation/fs-uae/fs-uae-2.4.0.ebuild
Comment 22 Michał Ziąbkowski 2014-02-25 16:41:49 UTC
Created attachment 371234 [details]
app-emulation/fs-uae-launcher-2.4.0.ebuild
Comment 23 Michał Ziąbkowski 2014-02-25 16:42:41 UTC
Created attachment 371236 [details, diff]
fs-uae-launcher-drop-bundled-lhafile.patch
Comment 24 Michał Ziąbkowski 2014-02-25 16:44:40 UTC
Created attachment 371240 [details]
dev-python/python-lhafile-0.1.0_p3.ebuild
Comment 25 Michał Ziąbkowski 2014-02-25 16:49:26 UTC
Uploaded a set of ebuilds for the newest stable fs-uae and launcher. Most notably, the latter now uses PyQt4 or pyside instead of wxpython.

The launcher didn't play nice with distutils, failing to build install some parts of the bundled python-lhafile, so I dropped that copy in favor of an external python-lhafile dep.
Comment 26 Andreas Sturmlechner gentoo-dev 2014-02-26 23:25:07 UTC
Thanks, works great here!
Comment 27 Fab 2014-12-30 17:20:04 UTC
Hi,

Bumping versions of ebuilds from comments #21 and #22 from 2.4.0 to 2.4.1 works fine here.

With x11-drivers/nvidia-drivers 343.36 on amd64, fs-uae always segfaults.
Workaround is :
> export __GL_WRITE_TEXT_SECTION=0

Before running fs-uae or fs-uae-launcher.

https://github.com/FrodeSolheim/fs-uae/issues/31
http://eab.abime.net/showthread.php?p=965560
Comment 28 Roc Vallès 2015-03-29 13:08:17 UTC
Ping?

Please merge, this is maintained unlike uae/e-uae (in portage), which are 8 years off.
Comment 29 Marcin Kowalski 2015-09-21 11:34:23 UTC
2.6.1 is out, i definitely could use an ebuild for that.
Comment 30 Fab 2015-11-04 13:20:34 UTC
Hi,

In my overlay⁽¹⁾ you can find bumped ebuilds for
 - dev-python/python-lhafile-0.2.1
 - app-emulation/fs-uae-2.6.2
 - app-emulation/fs-uae-launcher-2.6.2

Now :
 - fs-uae is using libsdl2
 - fs-uae-launcher is using python3 and PyQt5, and I removed
   bundled dev-python/sip because of bugs like #546730.

I'm not an expert of python ebuilds, but @workforme on a stable amd64 system.


1. https://github.com/netfab/overlay
Comment 31 frostwork 2015-11-04 15:07:24 UTC
"yeah, just a few months and my bug is 4 years old..."
thanks for bumping, Fab.
thanks for nothing, "games herd"
Comment 32 Michael Palimaka (kensington) gentoo-dev 2015-11-04 15:13:44 UTC
(In reply to Marcel Unbehaun from comment #31)
> "yeah, just a few months and my bug is 4 years old..."
> thanks for bumping, Fab.
> thanks for nothing, "games herd"

Do you volunteer to maintain it?
Comment 33 frostwork 2015-11-04 15:16:40 UTC
no my gamerlay maintain times are over.
no interest in maintaining anything after some "gentoo dev"
flamed gamerlay like an idiot...
Comment 34 Fab 2015-11-05 10:51:58 UTC
app-emulation/fs-uae-launcher-2.6.2 --> just fixed the ebuild to not install to wrong directory
Comment 35 Sven Eden 2017-08-18 07:09:20 UTC
I am willing to proxy maintain this. Until the ebuilds are in the tree, they can be obtained from my overlay (seden via layman), or by downloading from here.

The ebuilds have a "works-for-me"-status. A few extra eyes can not hurt, though.

The latest stable version is 2.8.3, I'll post here, and the latest development version is 2.9.6, in my overlay. I think the stable version is enough for a start, I'll add the dev versions once I proxy maintain this. Well, if I am allowed to, anyway.
Comment 36 Sven Eden 2017-08-18 07:11:14 UTC
Created attachment 489482 [details]
app-emulation/fs-uae-2.8.3.ebuild

Current stable version of FS-UAE
Comment 37 Sven Eden 2017-08-18 07:12:51 UTC
Created attachment 489484 [details, diff]
fs-uae-2.8.3_libmpeg2.patch

Make libmpeg2 support optional. It is not crucial for FS-UAE to work.
Comment 38 Sven Eden 2017-08-18 07:15:26 UTC
Created attachment 489486 [details]
app-emulation/fs-uae-launcher-2.8.3

The FS-UAE Launcher in the current stable version. It is an optional add-on, but I do not think it necessary to add another bug for it.

If I am wrong with that assumption, just say so, and I'll file a new one.
Comment 39 Sven Eden 2017-08-18 07:17:57 UTC
Created attachment 489488 [details, diff]
fs-uae-launcher-2.8.3-German-ROMS.patch

Unfortunately the original list of default ROMs does neither list the Kick 1.3 ROM from the upgraded Amiga 500 as it was sold in 1989 in germany, nor the german A4000 Kick 3.1 ROM.

Luckily I had both ripped from my machines, and could add their keys.
Comment 40 Sven Eden 2017-08-18 07:20:01 UTC
Created attachment 489490 [details, diff]
fs-uae-launcher-2.8.3-Makefile.patch

Make DESTDIR configurable and set 'prefix' to $(PREFIX). Portage can't install this properly without the fix.
Comment 41 frostwork 2017-08-18 07:23:29 UTC
yeah, 5 and a half years old bug and still nothing.
thanks for bumping and waking me, Sven Eden! :}
and as usual thanks for nothing, "games herd"!
Comment 42 Sven Eden 2017-08-18 07:31:31 UTC
(In reply to frostwork from comment #41)
> yeah, 5 and a half years old bug and still nothing.
> thanks for bumping and waking me, Sven Eden! :}
> and as usual thanks for nothing, "games herd"!

I had them lying around for a bit, and simply forgot to open a bug for them. Luckily there already is one.

There was no FS-UAE in gamerlay, so it made sense to eventually post my ebuilds, no? ;-)

As for the category, I'll go for app-emulation. My old Amiga 4000 Images work fine with FS-UAE, so it isn't just a simply games launcher. :-D
Comment 43 frostwork 2017-08-18 08:27:38 UTC
(In reply to Sven Eden from comment #42)
> 
> There was no FS-UAE in gamerlay, so it made sense to eventually post my
> ebuilds, no? ;-)

I removed most of my stuff from gamerlay long ago for different boring reasons :}
Just tried both fs-uae and fs-uae-launcher from your overlay and both emerged (and seem to work) fine. thanks a lot!
Comment 44 Andreas Thalhammer 2017-08-18 09:49:03 UTC
(In reply to Sven Eden from comment #39)
> Created attachment 489488 [details, diff] [details, diff]
> fs-uae-launcher-2.8.3-German-ROMS.patch
> 
> Unfortunately the original list of default ROMs does neither list the Kick
> 1.3 ROM from the upgraded Amiga 500 as it was sold in 1989 in germany, nor
> the german A4000 Kick 3.1 ROM.
> 
> Luckily I had both ripped from my machines, and could add their keys.

I think this is something of interest for upsteam as well. Have you reported your patch to the fs-uae developers? You should...

And thanks for your work!
Comment 45 Sven Eden 2017-08-18 12:08:37 UTC
(In reply to Andreas Thalhammer from comment #44)
> I think this is something of interest for upsteam as well. Have you reported
> your patch to the fs-uae developers? You should...

Now I have:
https://github.com/FrodeSolheim/fs-uae-launcher/pull/55

;-)
Comment 46 Sophie Hamilton 2017-10-20 01:21:14 UTC
I've added these ebuilds and installed both fs-uae and fs-uae-launcher, but when I try launching fs-uae-launcher I get these errors:

> sophie@home ~ $ fs-uae-launcher 
> fs-uae-launcher
> 2.8.3
> enabling except hook
> enable tread exception handler
> uname_result(system='Linux', node='home', release='4.12.12-gentoo', version='#2 SMP PREEMPT Thu Oct 12 17:13:15 BST 2017', machine='x86_64', processor='Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz')
> ['/usr/bin/fs-uae-launcher']
> FS-UAE Launcher 2.8.3
> 
> Unhandled exception detected in thread MainThread:
>   ImportError:__init__.py:<module>:49
> 
> Traceback (most recent call last):
>   File "/usr/bin/fs-uae-launcher", line 61, in <module>
>     main()
>   File "/usr/bin/fs-uae-launcher", line 58, in main
>     launcher.apps.main()
>   File "/usr/share/fs-uae-launcher/launcher/apps/__init__.py", line 73, in main
>     app_main()
>   File "/usr/share/fs-uae-launcher/launcher/apps/fs_uae_launcher.py", line 11, in app_main
>     from launcher.fs_uae_launcher import FSUAELauncher
>   File "/usr/share/fs-uae-launcher/launcher/fs_uae_launcher.py", line 8, in <module>
>     import fsui
>   File "/usr/share/fs-uae-launcher/fsui/__init__.py", line 19, in <module>
>     from fsui.qt.Icon import Icon
>   File "/usr/share/fs-uae-launcher/fsui/qt/Icon.py", line 2, in <module>
>     from fsbc.resources import Resources
>   File "/usr/share/fs-uae-launcher/fsbc/resources.py", line 2, in <module>
>     from pkg_resources import resource_filename, resource_stream
>   File "/usr/lib64/python3.4/site-packages/pkg_resources/__init__.py", line 49, in <module>
>     from six.moves import urllib, map, filter
> ImportError: No module named 'six.moves'
> 
> 
> Unhandled exception detected in thread MainThread:
>   ImportError:__init__.py:<module>:49
> 
> Traceback (most recent call last):
>   File "/usr/bin/fs-uae-launcher", line 61, in <module>
>     main()
>   File "/usr/bin/fs-uae-launcher", line 58, in main
>     launcher.apps.main()
>   File "/usr/share/fs-uae-launcher/launcher/apps/__init__.py", line 73, in main
>     app_main()
>   File "/usr/share/fs-uae-launcher/launcher/apps/fs_uae_launcher.py", line 11, in app_main
>     from launcher.fs_uae_launcher import FSUAELauncher
>   File "/usr/share/fs-uae-launcher/launcher/fs_uae_launcher.py", line 8, in <module>
>     import fsui
>   File "/usr/share/fs-uae-launcher/fsui/__init__.py", line 19, in <module>
>     from fsui.qt.Icon import Icon
>   File "/usr/share/fs-uae-launcher/fsui/qt/Icon.py", line 2, in <module>
>     from fsbc.resources import Resources
>   File "/usr/share/fs-uae-launcher/fsbc/resources.py", line 2, in <module>
>     from pkg_resources import resource_filename, resource_stream
>   File "/usr/lib64/python3.4/site-packages/pkg_resources/__init__.py", line 49, in <module>
>     from six.moves import urllib, map, filter
> ImportError: No module named 'six.moves'

I have dev-python/six-1.10.0 installed, and I can run the appropriate commands in Python 3.4 manually without a problem:

> sophie@home ~ $ python3.4
> Python 3.4.5 (default, Oct  6 2017, 05:14:14) 
> [GCC 4.9.4] on linux
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import six
> >>> from six.moves import urllib, map, filter
> >>> [Ctrl-D]
> sophie@home ~ $ 

Is there anything I'm missing?
Comment 47 Sophie Hamilton 2017-10-20 01:23:54 UTC
Forgot to add my emerge --info, sorry:

Portage 2.3.8 (python 2.7.12-final-0, default/linux/amd64/13.0, gcc-4.9.4, glibc-2.23-r4, 4.12.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-5820K_CPU_@_3.30GHz-with-gentoo-2.4.1
KiB Mem:    32924684 total,  26924512 free
KiB Swap:    8191996 total,   8191996 free
Timestamp of repository gentoo: Mon, 16 Oct 2017 18:00:01 +0000
Head commit of repository gentoo: 84e62a195fb087196ed15d847425dd147f85da0b
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.32.1::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            4.9.4::gentoo, 5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

sph-local
    location: /opt/portage-overlay
    masters: gentoo
    priority: 0

abendbrot
    location: /var/lib/layman/abendbrot
    masters: gentoo
    priority: 50

gambas-overlay
    location: /var/lib/layman/gambas-overlay
    masters: gentoo
    priority: 50

palemoon
    location: /var/lib/layman/palemoon
    masters: gentoo
    priority: 50

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/avfs/extfs /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask-enter-invalid --autounmask-keep-masks y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j13"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacplus acl acpi alsa amd64 amr berkdb bluray bzip2 cairo cdda cddb cdio cdparanoia cli cracklib crypt cups cxx dbus dri dts dvd flac fluidsynth fontconfig fortran gdbm gpm gtk iconv ipv6 jpeg libnotify lzma mad mmx modplug modules mp3 mtp multilib ncurses nls nptl ogg opencl opengl openmp pam pcre png qt3support qt5 readline seccomp session sound sse sse2 ssl startup-notification svg tcl tcpd theora tk truetype unicode v4l vdpau vim-syntax vorbis xattr xv xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en-GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="x86_64 arm i386 mips mipsel ppc sparc" QEMU_USER_TARGETS="aarch64 alpha arm i386 m68k mips mipsel ppc sparc x86_64" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-emulation/fs-uae-2.8.3::sph-local was built with the following:
USE="glew qt5 -drivers" ABI_X86="(64)"


app-emulation/fs-uae-launcher-2.8.3::sph-local was built with the following:
USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_4 -python3_5 -python3_6"
Comment 48 Fab 2017-10-20 06:41:12 UTC
> Is there anything I'm missing?

No. Bundled six must be removed in 2.8.3 ebuild else bug #546730 pop-up.
https://github.com/netfab/overlay/tree/master/app-emulation
Comment 49 James Le Cuirot gentoo-dev 2019-02-24 22:52:57 UTC
Guess which platform the (relatively) new acting lead of the games team is a major fan of? ;) Watch this space...
Comment 50 Larry the Git Cow gentoo-dev 2019-04-20 10:04:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=03b85469c5d73043a371077217bba2b8b228e699

commit 03b85469c5d73043a371077217bba2b8b228e699
Author:     James Le Cuirot <chewi@gentoo.org>
AuthorDate: 2019-04-20 10:04:28 +0000
Commit:     James Le Cuirot <chewi@gentoo.org>
CommitDate: 2019-04-20 10:04:28 +0000

    app-emulation/fs-uae-launcher: New package for launching fs-uae
    
    Closes: https://bugs.gentoo.org/403913
    Package-Manager: Portage-2.3.64, Repoman-2.3.12
    Signed-off-by: James Le Cuirot <chewi@gentoo.org>

 app-emulation/fs-uae-launcher/Manifest             |  1 +
 .../files/fs-uae-launcher-2.8.3-German-ROMs.patch  | 21 ++++++
 .../fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild   | 76 ++++++++++++++++++++++
 app-emulation/fs-uae-launcher/metadata.xml         | 14 ++++
 4 files changed, 112 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=061131ac2bfd6a8ee8795e2c4b6c503ba11f4015

commit 061131ac2bfd6a8ee8795e2c4b6c503ba11f4015
Author:     James Le Cuirot <chewi@gentoo.org>
AuthorDate: 2019-04-20 10:03:47 +0000
Commit:     James Le Cuirot <chewi@gentoo.org>
CommitDate: 2019-04-20 10:03:47 +0000

    app-emulation/fs-uae: New Amiga emulator package
    
    Closes: https://bugs.gentoo.org/403913
    Package-Manager: Portage-2.3.64, Repoman-2.3.12
    Signed-off-by: James Le Cuirot <chewi@gentoo.org>

 app-emulation/fs-uae/Manifest                      |   1 +
 .../fs-uae/files/fs-uae-2.8.3-libmpeg2.patch       |  36 +++++++
 app-emulation/fs-uae/fs-uae-2.8.3.ebuild           | 116 +++++++++++++++++++++
 app-emulation/fs-uae/metadata.xml                  |  15 +++
 4 files changed, 168 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=be555249167cd6d8bd702a96bb6b5b1926c5f9fb

commit be555249167cd6d8bd702a96bb6b5b1926c5f9fb
Author:     James Le Cuirot <chewi@gentoo.org>
AuthorDate: 2019-04-20 10:01:00 +0000
Commit:     James Le Cuirot <chewi@gentoo.org>
CommitDate: 2019-04-20 10:01:00 +0000

    dev-python/python-lhafile: New package, used by fs-uae-launcher
    
    Bug: https://bugs.gentoo.org/403913
    Package-Manager: Portage-2.3.64, Repoman-2.3.12
    Signed-off-by: James Le Cuirot <chewi@gentoo.org>

 dev-python/python-lhafile/Manifest                    |  1 +
 dev-python/python-lhafile/metadata.xml                | 11 +++++++++++
 dev-python/python-lhafile/python-lhafile-0.2.1.ebuild | 17 +++++++++++++++++
 3 files changed, 29 insertions(+)