Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 403473 - media-plugins/vdr-xineliboutput-1.0.5-r1 - xine_post_audiochannel.c:97:7: error: ‘post_audio_port_t’ has no member named ‘format’
Summary: media-plugins/vdr-xineliboutput-1.0.5-r1 - xine_post_audiochannel.c:97:7: err...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 22:05 UTC by Piotr Szymaniak
Modified: 2014-02-14 17:16 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build.log (Build.log,14.07 KB, text/plain)
2012-02-13 22:06 UTC, Piotr Szymaniak
Details
patch as in Comment_4, for version 10201 (vdr-xineliboutput-1.0.5-XINE_VERSION_CODE.patch,1.21 KB, patch)
2012-07-19 22:56 UTC, womble
Details | Diff
ebuild patch (1 line for the path above) (vdr-xineliboutput-1.0.5-r2.ebuild.patch,491 bytes, patch)
2012-07-19 22:57 UTC, womble
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Szymaniak 2012-02-13 22:05:34 UTC
[ebuild  N    ] dev-libs/libxdg-basedir-1.1.1  USE="-doc -static-libs" 
[ebuild  N    ] media-sound/alsa-headers-1.0.25 
[ebuild  N    ] sys-process/wait_on_pid-0.0.1 
[ebuild  N    ] dev-util/unifdef-2.6 
[ebuild  N    ] app-arch/cabextract-1.4  USE="-extra-tools" 
[ebuild  N    ] x11-proto/xproto-7.0.22  USE="-doc" 
[ebuild  N    ] x11-libs/xtrans-1.2.6  USE="-doc" 
[ebuild  N    ] media-tv/linuxtv-dvb-headers-5.3 
[ebuild  N    ] media-libs/libdvdcss-1.2.11  USE="-doc -static-libs" 
[ebuild  N    ] x11-proto/videoproto-2.3.1 
[ebuild  N    ] x11-proto/kbproto-1.0.5 
[ebuild  N    ] x11-proto/xextproto-7.2.0  USE="-doc" 
[ebuild  N    ] media-libs/freetype-2.4.8  USE="bzip2 -X -auto-hinter -bindist -debug -doc -fontforge -static-libs -utils" 
[ebuild  N    ] app-admin/eselect-vdr-0.0.3 
[ebuild  N    ] x11-proto/xf86vidmodeproto-2.3.1 
[ebuild  N    ] media-libs/alsa-lib-1.0.25-r1  USE="-alisp -debug -doc -python" 
[ebuild  N    ] x11-proto/xcb-proto-1.7 
[ebuild  N    ] dev-libs/libpthread-stubs-0.3  USE="-static-libs" 
[ebuild  N    ] dev-libs/libgpg-error-1.10-r1  USE="nls -common-lisp -static-libs" 
[ebuild  N    ] x11-proto/xf86bigfontproto-1.2.0 
[ebuild  N    ] x11-proto/inputproto-2.1 
[ebuild  N    ] media-fonts/font-util-1.2.0 
[ebuild  N    ] x11-misc/util-macros-1.16.1 
[ebuild  N    ] dev-lang/nasm-2.09.10  USE="-doc" 
[ebuild  N    ] media-video/ffmpeg-0.10  USE="bzip2 encode hardcoded-tables qt-faststart zlib -3dnow -3dnowext -X -aac -aacplus -alsa (-altivec) -amr -ass -avx -bindist -cdio (-celt) -cpudetection -debug -dirac -doc -faac -frei0r -gnutls -gsm -ieee1394 (-iwmmxt) -jack -jpeg2k -libv4l -mmx -mmxext -modplug -mp3 (-neon) -network -openal -openssl -oss -pic -pulseaudio -rtmp -schroedinger -sdl -speex -ssse3 -static-libs -test -theora -threads -truetype -v4l -vaapi -vdpau (-vis) -vorbis -vpx -x264 -xvid" 
[ebuild  N    ] x11-libs/libICE-1.0.7  USE="ipv6 -doc -static-libs" 
[ebuild  N    ] media-libs/libdvdread-4.2.0  USE="css" 
[ebuild  N    ] x11-libs/libXdmcp-1.1.0  USE="-doc -static-libs" 
[ebuild  N    ] x11-libs/libXau-1.0.6  USE="-static-libs" 
[ebuild  N    ] dev-libs/libgcrypt-1.5.0-r1  USE="-static-libs" 
[ebuild  N    ] app-admin/sudo-1.8.3_p2  USE="pam -ldap -offensive (-selinux) -skey" 
[ebuild  N    ] sys-libs/libcap-2.22  USE="pam" 
[ebuild  N    ] media-libs/libjpeg-turbo-1.1.90_p20120210  USE="-java -static-libs" 
[ebuild  N    ] virtual/ffmpeg-0.9  USE="encode -X -jpeg2k -mp3 -sdl -theora -threads -vaapi -vdpau -x264" 
[ebuild  N    ] media-tv/gentoo-vdr-scripts-0.4.9  USE="-nvram" 
[ebuild  N    ] virtual/jpeg-0  USE="-static-libs" 
[ebuild  N    ] media-libs/libdvdnav-4.2.0 
[ebuild  N    ] x11-libs/libSM-1.2.0  USE="ipv6 uuid -doc -static-libs" 
[ebuild  N    ] dev-libs/libxslt-1.1.26-r3  USE="crypt -debug -python -static-libs" 
[ebuild  N    ] x11-libs/libxcb-1.8  USE="-doc (-selinux) -static-libs" 
[ebuild  N    ] x11-libs/libX11-1.4.4  USE="ipv6 -doc -static-libs -test" 
[ebuild  N    ] x11-libs/libXext-1.3.0  USE="-doc -static-libs" 
[ebuild  N    ] x11-libs/libXt-1.1.1  USE="-static-libs" 
[ebuild  N    ] x11-libs/libXv-1.0.6  USE="-static-libs" 
[ebuild  N    ] media-libs/xine-lib-1.2.1  USE="X alsa css ipv6 mmap nls xcb xv -a52 -aac -aalib (-altivec) -bluray -directfb -dts -dvb (-dxr3) -fbcon -flac -fusion -gtk -imagemagick -jack -libcaca -mad -mng -modplug -musepack -opengl -oss -pulseaudio (-real) -samba -sdl -speex -theora -truetype -v4l -vcd -vdpau -vdr -vidix (-vis) -vorbis -wavpack -win32codecs -xinerama -xvmc" 
[ebuild  N    ] media-libs/fontconfig-2.8.0-r2  USE="-doc -static-libs" 
[ebuild  N    ] app-admin/eselect-fontconfig-1.1 
[ebuild  N    ] media-fonts/corefonts-1-r6  USE="-X" 
[ebuild  N    ] virtual/ttf-fonts-1 
[ebuild  N    ] media-video/vdr-1.6.0_p2-r7  USE="-analogtv -atsc -cmdreccmdi18n -cmdsubmenu -cutterlimit -cutterqueue -cuttime -ddepgentry -debug -deltimeshiftrec -dolbyinrec -dvbplayer -dvbsetup -dvdarchive -dvdchapjump -dvlfriendlyfnames -dvlrecscriptaddon -dvlvidprefer (-dxr3) -em84xx -graphtft -hardlinkcutter -iptv -jumpplay -liemikuutio -lircsettings -livebuffer -lnbshare -mainmenuhooks -menuorg -noepg -osdmaxitems -parentalrating -pinplugin -rotor -settime -setup -softosd -sortrecords -sourcecaps -syncearly -timercmd -timerinfo -ttxtsubs -validinput -vanilla -volctrl -wareagleicon -yaepg" 
[ebuild  N    ] media-plugins/vdr-xineliboutput-1.0.5-r1  USE="vdr xine -X -fbcon -libextractor -xinerama" 



Portage 2.1.10.45 (default/linux/x86/10.0, gcc-4.6.2, glibc-2.14.1-r2, 3.2.5 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.5-i686-Intel-R-_Pentium-R-_4_CPU_2.60GHz-with-gentoo-2.1
Timestamp of tree: Fri, 10 Feb 2012 22:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Os -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--load-average 5 --jobs 3"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.ift.uni.wroc.pl/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync1.pl.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 modules mudflap ncurses nls nptl nptlonly openmp pam pcre pppd readline session ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Piotr Szymaniak 2012-02-13 22:06:05 UTC
Created attachment 301839 [details]
Build.log

Build.log
Comment 2 kilroy 2012-02-26 15:00:25 UTC
Same here.

Seems like the API has changed from
  media-libs/xine-lib-1.1.20
to 
  media-libs/xine-lib-1.2.1

Downgrading xine-lib fixed it for me... Seems like we have to wait for a new xineliboutput
Comment 3 mpcww 2012-03-07 11:31:17 UTC
I can confirm: masking  media-libs/xine-lib-1.2.1 helped me as well.
Comment 4 Dennis Eberstein 2012-03-24 20:14:50 UTC
Do you now that this is just the trick:

--- xine_post_audiochannel.c.original   2012-01-03 13:58:04.440916261 +0200
+++ xine_post_audiochannel.c   2012-01-03 14:01:26.479877000 +0200
@@ -70,7 +70,7 @@
/*
  *    Port functions
  */
-#if XINE_VERSION_CODE < 10200
+#if XINE_VERSION_CODE <= 10200
static int audioch_port_open(xine_audio_port_t *port_gen, xine_stream_t *stream,
                              uint32_t bits, uint32_t rate, int mode)
#else
@@ -85,7 +85,7 @@
   _x_post_inc_usage(port);
   
   port->stream = stream;
-#if XINE_VERSION_CODE < 10200
+#if XINE_VERSION_CODE <= 10200
   port->bits = bits;
   port->rate = rate;
   port->mode = mode;
@@ -112,7 +112,7 @@
   int i;

   if(this->channels == 2) {
-#if XINE_VERSION_CODE < 10200
+#if XINE_VERSION_CODE <= 10200
     int step = buf->format.bits / 8;
#else
     int step = sample_bytes_table[buf->format.sample_format];
@@ -122,7 +122,7 @@
     newbuf->vpts = buf->vpts;
     newbuf->frame_header_count = buf->frame_header_count;
     newbuf->first_access_unit = buf->first_access_unit;
-#if XINE_VERSION_CODE < 10200
+#if XINE_VERSION_CODE <= 10200
     newbuf->format.bits = buf->format.bits;
     newbuf->format.rate = buf->format.rate;
     newbuf->format.mode = buf->format.mode;
Comment 5 tazinblack 2012-05-13 18:47:58 UTC
Same problem here.
Unfortunately there's no media-libs/xine-lib-1.1.20 any more in portage :-(
Please somebody fix this.
Comment 6 womble 2012-07-19 22:54:46 UTC
(In reply to comment #4)

Same problem here.

However, I simply change the version as given in Comment_4 to 10201, and it
worked for me. Unfortunately, I have absolutely no idea which is the correct
maximal version number to use, maybe 10202 (for xine-lib-1.2.2 etc.) is
also correct.

Attached both new patch for ebuild and patched ebuild itself.
Comment 7 womble 2012-07-19 22:56:33 UTC
Created attachment 318674 [details, diff]
patch as in Comment_4, for version 10201
Comment 8 womble 2012-07-19 22:57:37 UTC
Created attachment 318676 [details, diff]
ebuild patch (1 line for the path above)
Comment 9 tazinblack 2012-09-27 15:47:31 UTC
Is there something I can help so this will be fixed inside portage?
Comment 10 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2014-02-14 17:16:36 UTC
Please test media-plugins/vdr-xineliboutput-1.1.0.