Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402977 - emerge --update doesn't update all packages which can be updated
Summary: emerge --update doesn't update all packages which can be updated
Status: RESOLVED DUPLICATE of bug 274454
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Documentation (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 09:56 UTC by dieter ferdinand
Modified: 2013-08-12 16:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dieter ferdinand 2012-02-10 09:56:14 UTC
hello,
i am updating one of my gentoo-systems in the last days.

but with emerge --update, over 50 packages are not updated.

here a list of some packages:
sudo
dev-db/mysql 5.1.56 5.1.61
dev-db/mysql-init-scripts 1.2 2.0_pre1-r2
dev-db/virtuoso-odbc 6.1.2 6.1.3
dev-db/virtuoso-server 6.1.2 6.1.3-r2
dev-lang/swig 2.0.2 2.0.4-r1
dev-lang/yasm 1.1.0-r1 1.2.0
update dev-libs/gmp 5.0.2 5.0.2_p1
dev-libs/gobject-introspection 0.10.8 1.30.0-r2
dev-libs/libusb 1.0.8 1.0.9_rc3
dev-libs/shared-desktop-ontologies 0.7.0 0.8.1
dev-php/PEAR-Console_Getopt 1.2.3-r1 1.3.1
dev-python/pygobject 2.28.6 3.0.2
dev-python/pygtk 2.24.0-r1 2.24.0-r2
dev-tex/bibtexu 3.71_p20110627 3.71_p20110705
dev-util/desktop-file-utils 0.18 0.19
dev-util/dialog 1.1.20100428 1.1.20110707-r1
dev-util/intltool 0.41.1 0.50.0

the first version number is the installed version and the second the actual version.
i think, this is no problem of blocking packages, because i can update them by call emerge -u with the package name.

to update qt, i must remove all qt packages and reinstall the packages because emerge won't update this libs vom 4.7.2 to 4.7.4 because they are blocked.
i must update this libs because gdk-pixbuf don't work with the installed libs (segmentation fault).

goodby


Reproducible: Always

Steps to Reproduce:
emerge --update
check which packages are not updated with a script



script to check which packages are not update or update this packages:
#!/usr/bin/ksh
VER=""
NEU=""
PAKET1=""
emerge --search %|tee /tmp/update.log|grep -B2 "installed: .*[0-9]\\."|while read ZEILE
do
#  echo "$ZEILE"
  case "$ZEILE" in
    *Not*Installed*) PAKET="";;
    Latest\ version\ available:*) NEU="${ZEILE##* }";;
    Latest\ version\ installed:*) VER="${ZEILE##* }";;
    */*) PAKET="${ZEILE##* }";VER="";NEU="";;
  esac
  if [ -n "$PAKET" -a -n "$VER" -a -n "$NEU" -a "$VER" != "$NEU" ]
  then
#    echo "$PAKET  $VER  $NEU"
    case "$PAKET" in
#      *kde*|\]) ;;
      *) if [ "$PAKET" != "$PAKET1" ]
         then
           echo "update $PAKET $VER $NEU"
           test -n "$1" && emerge -u "$PAKET"
           PAKET1="$PAKET"
         fi
         ;;
    esac
  fi
done
Comment 1 Jeroen Roovers gentoo-dev 2012-02-10 16:32:58 UTC
I normally go for `emerge -vuaDN world'.
Comment 2 Zac Medico gentoo-dev 2012-02-10 18:07:11 UTC
This is likely a --with-bdeps issue, like bug 274454. Try it with --with-bdeps=y. Also, check if `emerge --pretend --depclean` would remove any of the relevant packages.
Comment 3 dieter ferdinand 2012-02-10 19:11:22 UTC
emerge --update gives this info:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] net-libs/webkit-gtk-1.6.1-r301 [1.4.3-r300] USE="-webgl%" 

WARNING: One or more updates have been skipped due to a dependency conflict:

sys-kernel/linux-headers:0

  (sys-kernel/linux-headers-3.1::gentoo, ebuild scheduled for merge) conflicts with
    <sys-kernel/linux-headers-3.0 required by (media-tv/linuxtv-dvb-headers-5::gentoo, installed)

depclean will remove this packages:
All selected packages: sys-devel/bin86-0.16.17 media-sound/musepack-tools-465 dev-perl/File-BaseDir-0.30.0 dev-perl/Crypt-SSLeay-0.57 sys-power/iasl-20090123 kde-base/knetworkconf-4.4.5 sys-kernel/gentoo-sources-3.0.6 x11-proto/xf86miscproto-0.9.3 dev-perl/File-MimeInfo-0.150.0 x11-libs/libXxf86misc-1.0.3 dev-libs/liboil-0.3.17 x11-proto/fontcacheproto-0.1.3 x11-libs/libXfontcache-1.0.5 dev-db/phpmyadmin-3.4.6 net-zope/zope-testrunner-4.0.3 sys-devel/gcc-4.4.5 net-libs/libvncserver-0.9.7 media-libs/libcuefile-465 dev-cpp/clucene-0.9.21b-r1 dev-perl/File-DesktopEntry-0.40.0 sys-devel/dev86-0.16.17-r6 net-libs/openslp-1.2.1-r1 kde-base/kweather-4.4.5 sys-fs/sysfsutils-2.1.0 media-libs/libreplaygain-465 app-misc/hal-info-20090716 net-libs/xulrunner-1.9.2.20 media-libs/libvpx-0.9.6 dev-libs/eggdbus-0.6 net-nds/phpldapadmin-1.2.1.1-r1 media-libs/xine-lib-1.1.19 sys-libs/slang-2.2.2 sys-apps/dmidecode-2.10 sys-apps/less-444

but som of these packages are needed!

these packages are not updated at this moment:
update media-libs/phonon 4.5.0 4.5.1-r1
update media-libs/xine-lib 1.1.19 1.1.20
update media-libs/xvid 1.2.2-r2 1.3.2
update media-plugins/vdr-svdrpservice 0.0.3 0.0.4
update media-sound/cdparanoia 3.10.2-r3 3.10.2-r4
update media-sound/lame 3.98.4 3.99.3
update net-dns/libidn 1.22 1.23
update net-libs/glib-networking 2.28.7 2.30.1-r1
update net-libs/libproxy 0.4.6-r3 0.4.7
update net-libs/libsoup 2.34.3 2.36.1
update net-libs/libsoup-gnome 2.34.3 2.36.1
update net-libs/webkit-gtk 1.4.3-r300 1.6.1-r301
update net-misc/curl 7.21.4 7.24.0
update perl-core/Module-Build 0.36.07 0.380.0
update sys-apps/attr 2.4.46 2.4.46-r1
update sys-apps/man 1.6f-r4 1.6g
update sys-apps/openrc 0.9.4 0.9.8.4
update sys-apps/sdparm 1.03 1.06
update sys-devel/dev86 0.16.17-r6 0.16.18
update sys-devel/gdb 7.2 7.3.1
update sys-kernel/linux-headers 2.6.39 3.1
update sys-libs/slang 2.2.2 2.2.4
update sys-power/pm-utils 1.4.1 1.4.1-r2
update virtual/perl-Module-Build 0.36.07 0.380.0-r2
update virtual/perl-version 0.82 0.940.0
update x11-apps/mkfontscale 1.0.9 1.0.9-r1
update x11-apps/xdpyinfo 1.2.0 1.3.0
update x11-libs/libXi 1.4.3 1.4.3-r1
update x11-libs/libdrm 2.4.26 2.4.27
update x11-libs/libxklavier 5.0 5.1
update x11-libs/pixman 0.22.2 0.24.0
update x11-misc/shared-mime-info 0.90 1.0
update x11-proto/xcb-proto 1.6-r1 1.6-r2
update x11-themes/gnome-icon-theme 3.0.0 3.2.1.2

but the update is in work.

emerge -vuaDN world will update more packages, but it seems, that i get problems with the use flags, because some packages need use flags, which don't work with other packages like the static use flag.
this would update the most packages. i have checked some packages in the list and find only the package sys-devel/dev86 which is not updated with this params. but i can't check all packages because i have updated many packages with my script.
after the scrip is finish, i will run emerge with this params, to update the rest of the listes packages for this paramaters. i think this packages need update because some of the packages which they use are updated.

goodby
Comment 4 Zac Medico gentoo-dev 2012-02-10 19:23:41 UTC
There's a "Why is it that emerge does not update all packages?" section in the FAQ that's supposed to cover this:

  http://www.gentoo.org/proj/en/portage/doc/faq.xml

As noted there, the purest command to update all packages that won't be removed by --depclean is:

    emerge --deep --with-bdeps=y --update world
Comment 5 dieter ferdinand 2012-03-05 08:34:36 UTC
hello,
new updates with emerge --deep --with-bdeps=y --update world and emerge -vuaDN world on my system and much updates on an other system and not all packages are updated!
on my system this packages are not updated:
update media-libs/libvpx 0.9.6 0.9.7-r1
update media-libs/tiff 3.9.5 4.0.0-r1

on the second system: (after depclean)
update app-text/docbook-xml-dtd 4.4-r2 4.5-r1
update dev-java/antlr 2.7.7-r2 3.1.3-r2
update dev-java/qdox 1.6.3 1.12
update media-libs/lcms 1.19 2.3

but on this system i have an other problem after depclean:
xinetd and nano (editor) are removed!
on the last update on this system and a third system, the programs from coreutils disapear, but if i check with emerge --search coreutils, this package is installed. after re-merge of the package, it works again.

goodby
Comment 6 Zac Medico gentoo-dev 2012-03-05 08:47:11 UTC
(In reply to comment #5)
> on my system this packages are not updated:
> update media-libs/libvpx 0.9.6 0.9.7-r1
> update media-libs/tiff 3.9.5 4.0.0-r1
> 
> on the second system: (after depclean)
> update app-text/docbook-xml-dtd 4.4-r2 4.5-r1
> update dev-java/antlr 2.7.7-r2 3.1.3-r2
> update dev-java/qdox 1.6.3 1.12
> update media-libs/lcms 1.19 2.3

Typically, it means that the package is either eligible for depclean, or has a reverse dependency which requires the lower version. Check reverse dependencies like this:

   emerge -pv --depclean <atom>

> but on this system i have an other problem after depclean:
> xinetd and nano (editor) are removed!

Sounds like bug 380515.

> on the last update on this system and a third system, the programs from
> coreutils disapear, but if i check with emerge --search coreutils, this
> package is installed. after re-merge of the package, it works again.

There was an update where a bunch of coreutils binaries moved from /bin to /usr/bin (or vice versa, can't remember). Maybe that was it.
Comment 7 dieter ferdinand 2012-03-05 09:14:58 UTC
hello,
there is also a problem with gcc after depclean, it don't work after that.
depclean remove an older version of gcc.

i can change the profile with gcc-config and remerge it after that.

goodby
Comment 8 dieter ferdinand 2012-03-05 09:32:47 UTC
hello,
if i make that, i get the info, which package has put in this package, but i can't see, which version is needed:
  app-text/docbook-xml-dtd-4.1.2-r6 pulled in by:
    gnome-base/gnome-desktop-2.32.1

  app-text/docbook-xml-dtd-4.4-r2 pulled in by:
    app-text/gnome-doc-utils-0.20.6

goodby
Comment 9 Zac Medico gentoo-dev 2012-03-05 10:02:22 UTC
(In reply to comment #8)
> hello,
> if i make that, i get the info, which package has put in this package, but i
> can't see, which version is needed:
>   app-text/docbook-xml-dtd-4.1.2-r6 pulled in by:
>     gnome-base/gnome-desktop-2.32.1

The atom in DEPEND is ~app-text/docbook-xml-dtd-4.1.2, as shown here:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild?revision=1.10&view=markup

>   app-text/docbook-xml-dtd-4.4-r2 pulled in by:
>     app-text/gnome-doc-utils-0.20.6

The atom in DEPEND is ~app-text/docbook-xml-dtd-4.4, as shown here:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-text/gnome-doc-utils/gnome-doc-utils-0.20.6.ebuild?revision=1.9&view=markup
Comment 10 Zac Medico gentoo-dev 2013-08-12 16:21:19 UTC

*** This bug has been marked as a duplicate of bug 274454 ***