Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402967 - sys-fs/fuse - ld.gold: error: symbol fuse_new has undefined version, error: symbol __fuse_process_cmd has undefined version
Summary: sys-fs/fuse - ld.gold: error: symbol fuse_new has undefined version, error: s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Tim Harder
URL: http://patches.openembedded.org/patch...
Whiteboard:
Keywords:
: 445826 533046 555196 (view as bug list)
Depends on:
Blocks: gold-tracker
  Show dependency tree
 
Reported: 2012-02-10 08:21 UTC by Michael Palimaka (kensington)
Modified: 2016-07-18 22:47 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,18.83 KB, text/plain)
2012-02-10 08:21 UTC, Michael Palimaka (kensington)
Details
Patch from http://patches.openembedded.org/patch/13645/ (Extracted the Patch) (gold-unversioned-symbol.patch,2.62 KB, patch)
2014-12-18 02:55 UTC, Oliver Hildebrandt
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2012-02-10 08:21:02 UTC
Created attachment 301457 [details]
build log

fuse-2.8.7 fails to build with the gold linker:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: error: symbol fuse_new has undefined version 
collect2: ld returned 1 exit status
make[1]: *** [libfuse.la] Error 1


Portage 2.1.10.45 (hardened/linux/amd64, gcc-4.5.3-asneeded, glibc-2.14.1-r2, 3.1.5-hardened-libre x86_64)
=================================================================
System uname: Linux-3.1.5-hardened-libre-x86_64-06-17-with-gentoo-2.1
Timestamp of tree: Fri, 10 Feb 2012 07:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo sunrise kensington qt kde x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch protect-owned sandbox sfperms split-elog split-log splitdebug strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.internode.on.net/pub/gentoo/ http://distfiles.gentoo.org/"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/kensington /var/lib/layman/qt /var/lib/layman/kde /usr/local/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="aac acl acpi alsa amd64 apache2 apng asf background bash-completion bazaar berkdb bzip2 cairo cleartype cli consolekit corefonts cracklib crashreporter crypt cups cxx dbus deblob dri dvd ebook exceptions fam ffmpeg flac fontconfig gdbm git glib gmp gold gpm handbook hardened iconv ipv6 ithreads jit jpeg justify kde kontact lastfm less libnotify mikmod mmx mng modules mp3 mp4 mpeg mta mudflap multilib ncurses networkmanager nls nptl nptlonly ogg opengl openmp optimized-qmake pam pax_kernel pcap pcre phonon player png policykit pppd private-headers qt3support qt4 readline rss semantic-desktop session sftp sha512 smbclient spell sse sse2 ssl ssse3 startup-notification suhosin svg symlink sysfs tcpd theora threads threadsafe tiff truetype udev unicode upnp uuid vhosts vorbis webm xft xorg xscreensaver xvfb zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="*" APACHE2_MODULES="dav alias auth_basic authn_default auth_digest authn_file authz_host authz_user autoindex cgi deflate dir filter headers include info log_config mime mime_magic negotiation proxy proxy_http rewrite speling status vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby19" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Palimaka (kensington) gentoo-dev 2012-02-10 08:25:31 UTC
I found a potential patch (http://patches.openembedded.org/patch/13645/) but I am familiar with neither this type of link error, nor fuse, so I don't know how useful it is.
Comment 2 Alexander Tsoy 2012-06-22 09:55:37 UTC
Similar problem with currently stable fuse-2.8.6:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: error: symbol __fuse_exited has undefined version
collect2: ld returned 1 exit status
Comment 3 Marcin Mirosław 2012-07-09 09:11:15 UTC
"me too":
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.1/../../../../x86_64-pc-linux-gnu/bin/ld: error: symbol fuse_new has undefined version
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-07-30 10:03:20 UTC
*** Bug 445826 has been marked as a duplicate of this bug. ***
Comment 5 Alex Xu (Hello71) 2013-12-04 19:07:01 UTC
sys-fs/fuse-2.9.3:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: error: symbol __fuse_process_cmd has undefined version
Comment 6 Oliver Hildebrandt 2014-12-18 02:55:11 UTC
Created attachment 391900 [details, diff]
Patch from http://patches.openembedded.org/patch/13645/ (Extracted the Patch)

I have solved the Problem with the above Patch, added it to the fuse-2.9.3 ebuild and it compiles fine (glibc-2.19, gcc-4.9.2, binutils-2.24-r3 [gold])
Comment 7 Nuno Silva 2015-01-18 10:47:52 UTC
If this is indeed a duplicate of bug 445826, can someone please update the subject accordingly? Note that 445826 mentions a different error message...
Comment 8 Pacho Ramos gentoo-dev 2015-07-18 09:15:17 UTC
*** Bug 555196 has been marked as a duplicate of this bug. ***
Comment 9 Pacho Ramos gentoo-dev 2015-07-18 09:15:27 UTC
*** Bug 533046 has been marked as a duplicate of this bug. ***
Comment 10 Jaak Ristioja 2015-08-24 19:52:03 UTC
Any progress? The attached patch still seems to fix emerge of fuse 2.9.4.
Comment 11 xpue 2015-08-24 21:22:50 UTC
Adding -Wl,-fuse-ld=bfd to LDFLAGS also fixes buld.
Comment 12 Matt Whitlock 2015-08-25 00:22:51 UTC
Would invoking tc-ld-disable-gold[1] in src_configure() also work?

[1] https://devmanual.gentoo.org/eclass-reference/toolchain-funcs.eclass/
Comment 13 Marcin Mirosław 2015-08-26 07:20:48 UTC
(In reply to Jaak Ristioja from comment #10)
> Any progress? The attached patch still seems to fix emerge of fuse 2.9.4.

(In reply to xpue from comment #11)
> Adding -Wl,-fuse-ld=bfd to LDFLAGS also fixes buld.

Me seems this isn't fix but only workarround for real problem.
Comment 14 Petros 2015-08-26 11:35:12 UTC
(In reply to xpue from comment #11)
> Adding -Wl,-fuse-ld=bfd to LDFLAGS also fixes buld.

In package.env I suppose, not globally. :)
Comment 15 Roman Gruber 2015-10-28 12:20:02 UTC
May I kindly ask the developers, who are in charge, why we can not fix this?

WE know it does not build with gold. There seems to be a fix.

Bug open, fix proposed from someone. I run into this for weeks on this new hardware. I did not bother to read the previous box emerge.log. I am quite sure, that this issue is well known since june or april 2015.

Ebuilds usually patch out invalid cflags, why not patch out in this case the gold-linker?

Frienldy reminder, please fix htis ebuild. Thank you

The status should be confirmed, if you need a build.log. I gladly provide emerge-info and build.log, if you really need that to get the bug as confirmed.
Comment 16 Fabio Scaccabarozzi 2016-04-07 20:37:53 UTC
I have opened a bug for this some time ago in fuse's upstream, see here:
https://github.com/libfuse/libfuse/issues/11

I have asked the maintainer for inclusion of the patch. He has concerns that the patch might break fuse 2.x for some people, as he doesn't see the patch widely adopted by distros. He would rather either update the patch for fuse 3.x or version all the symbols with fuse 3.x, from what I understood. Currently, I don't know if there's any ETA for fuse 3.x.
Comment 17 Peter Asplund 2016-06-21 20:08:57 UTC
I agree that it would be great to get this fixed upstream, but since the bug has been around since 2012, perhaps we can get the suggested work-around at least _until_ the patch is accepted or until Gentoo decide to try applying the patch on the 2.x series. Workarounds are OK temporarily, aren't they?
Comment 18 jorgicio 2016-07-12 21:41:31 UTC
fuse-2.9.7 was bumped, and I have set gold as a default linker. However, fuse failed. so I found this patch:
https://raw.githubusercontent.com/fsvm88/gentoo-portage_etc/master/patches/sys-fs/fuse/fuse-gold.patch
Put it into /etc/portage/patches/sys-fs/fuse (if not exist, create that directory)
And then built it with that and went fine.
Comment 19 Fabio Scaccabarozzi 2016-07-12 22:03:52 UTC
@maintainers: please note that this:
https://raw.githubusercontent.com/fsvm88/gentoo-portage_etc
is the URL of my /etc/portage git repository of my main desktop PC. :-)

That patch was refreshed against 2.9.5 in January and has been working perfectly to date. The original patch has been floating around for at least 1 year or more before I had it tracked.

Please note that a pull request was issued for this about 2 months ago, but devs decided against merging:
https://github.com/gentoo/gentoo/pull/1468
Comment 20 Tim Harder gentoo-dev 2016-07-18 22:47:57 UTC
I don't think this is necessary anymore with recent binutils (2.26) since they finally fixed base symbol versioning issues with the gold linker (https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commit;h=b45e00b3ed40589af75b8a36a67905ae265a20f8) which is what I was waiting for.