Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402465 - media-video/avidemux-2.5.6 - work/avidemux_2.5.6/plugins/ADM_audioDevices/Sdl/ADM_deviceSDL.cpp:15:17: fatal error: SDL.h: No such file or directory
Summary: media-video/avidemux-2.5.6 - work/avidemux_2.5.6/plugins/ADM_audioDevices/Sdl...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Tom Wijsman (TomWij) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 22:16 UTC by Woody
Modified: 2013-03-17 00:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Emerge log file (media-video%3Aavidemux-2.5.6%3A20120206-214322.log,645.81 KB, text/plain)
2012-02-06 22:18 UTC, Woody
Details
emerge --info (avidemux.info,3.98 KB, text/plain)
2012-02-07 15:05 UTC, Woody
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Woody 2012-02-06 22:16:29 UTC
I have Gentoo Prefix installed on a Gentoo host system. Avidemux fails to emerge. I've tried ebuild versions 2.5.4-r2, 2.5.5 and 2.5.6. Every time, the install fails at the same point, with the error "SDL.h: No such file or directory"

Reproducible: Always

Steps to Reproduce:
1. Wget avidemux ebuild + patch files to local portage overlay directory
2. # emerge avidemux

Actual Results:  
 emerge fails with compile error: "SDL.h: No such file or directory"

Expected Results:  
emerge should have successfully installed avidemux

This is a Prefixed Portage configuration.  The host OS is Gentoo.
Comment 1 Woody 2012-02-06 22:18:23 UTC
Created attachment 301093 [details]
Emerge log file
Comment 2 Paweł Rumian 2012-02-07 12:25:26 UTC
1) This is not a critical bug
2) You have not provided emerge --info media-video/avidemux
3) Why are you fetching ebuild via wget?
Comment 3 Woody 2012-02-07 15:05:48 UTC
Created attachment 301133 [details]
emerge --info
Comment 4 Woody 2012-02-07 15:09:02 UTC
(In reply to comment #2)
> 1) This is not a critical bug
> 2) You have not provided emerge --info media-video/avidemux
> 3) Why are you fetching ebuild via wget?

This is my first bug report, so any assistance is appreciated.

1)  What status do you recommend
2)  emerge --info is now added
3)  Avidemux does not appear to be in the tree, so I emerged it from an ebuild file.  What difference does it make how I acquired the ebuild file?
Comment 5 Rafał Mużyło 2012-02-07 19:20:55 UTC
Many ebuilds that "just work" in the main tree might be very much broken for Prefix. Assuming that they will leads to "bugs" like this.

I.e. '/usr/include/SDL' *is*, contrary to the idea you seem to get in your thread, the correct location of libsdl headers for standard tree.

I'd check what method avidemux build system uses to detect libsdl and then checked both verbose cmake (IIRC) output and result of manually running the check.
Comment 6 Woody 2012-02-07 19:41:28 UTC
(In reply to comment #5)
> Many ebuilds that "just work" in the main tree might be very much broken for
> Prefix. Assuming that they will leads to "bugs" like this.

Sounds like you're saying that Prefix is what is broken.  Should I report a bug there?

> 
> I.e. '/usr/include/SDL' *is*, contrary to the idea you seem to get in your
> thread, the correct location of libsdl headers for standard tree.

I'm not suggesting that '/usr/include/SDL' is not the correct location.  I'm only pointing to what made the install work.

> I'd check what method avidemux build system uses to detect libsdl and then
> checked both verbose cmake (IIRC) output and result of manually running the
> check.

You're getting beyond me here. What you're suggesting sounds like the right direction to me, but I'm not able to explore that.  If this report doesn't belong here, please suggest where I should report it.
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2012-02-07 19:49:13 UTC
avidemux doesn't have any KEYWORDS for prefix... so it's not really supposed to work (yet)

anyway, nothing for media-video@ here (readd us back when you have a working patch)
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-02-07 20:18:12 UTC
Thanks Woody. I have no idea how CMake works but if you poke around at the build system, you will see -I/usr/include references everywhere. So, it is either something trivial to make it work with Gentoo Prefix or something complex.
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2012-02-07 20:53:32 UTC
Nothing for Qt here either
Comment 10 Woody 2012-02-07 20:57:04 UTC
(In reply to comment #7)
> avidemux doesn't have any KEYWORDS for prefix... so it's not really supposed to
> work (yet)
> 
> anyway, nothing for media-video@ here (readd us back when you have a working
> patch)

Doesn't sound like it takes much to make avidemux install under Prefix if changing a single directory makes it work.  Everything else installed without a problem.

So, to sum up, should I close this report and go and discuss on the avidemux development site?
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-02-07 21:07:09 UTC
(In reply to comment #10)
> (In reply to comment #7)
> > avidemux doesn't have any KEYWORDS for prefix... so it's not really supposed to
> > work (yet)
> > 
> > anyway, nothing for media-video@ here (readd us back when you have a working
> > patch)
> 
> Doesn't sound like it takes much to make avidemux install under Prefix if
> changing a single directory makes it work.  Everything else installed without a
> problem.

Oh, you got it to build? Please attach your patch.

> So, to sum up, should I close this report and go and discuss on the avidemux
> development site?

Probably not, here should be the right place to start then we can evaluate the options.
Comment 12 Rafał Mużyło 2012-02-07 21:10:42 UTC
:roll:
Well, looking at 2.5.5 tarball, the macro in question seems to be cmake/FindSDL.cmake, which doesn't look very Prefix-friendly.
Comment 13 Woody 2012-02-07 23:19:22 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #7)
> > > avidemux doesn't have any KEYWORDS for prefix... so it's not really supposed to
> > > work (yet)
> > > 
> > > anyway, nothing for media-video@ here (readd us back when you have a working
> > > patch)
> > 
> > Doesn't sound like it takes much to make avidemux install under Prefix if
> > changing a single directory makes it work.  Everything else installed without a
> > problem.
> 
> Oh, you got it to build? Please attach your patch.
> 
> > So, to sum up, should I close this report and go and discuss on the avidemux
> > development site?
> 
> Probably not, here should be the right place to start then we can evaluate the
> options.

I didn't apply a patch, I just copied the contents of '$GENTOO_PREFIX/usr/include/SDL' to '$GENTOO_PREFIX/usr/include/'.  It seems that the only thing preventing it from installing was that it looks for SDL files in the wrong directory.
Comment 14 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-02-07 23:23:49 UTC
Oh, that is definately wrong. Need a build system patch, instead.
Comment 15 Peter Norman 2013-03-16 23:29:21 UTC
make -j1 DESTDIR=/var/tmp/portage/media-video/avidemux-2.6.2/image/ preinstall 
/usr/bin/cmake -H/var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2.6.2/avidemux_plugins e/media-video/avidemux-2.6.2/work/avidemux_2.6.2/buildPluginsGtk --check-build-system CMakeFiles/M
/usr/bin/cmake -E cmake_progress_start /var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2Gtk/CMakeFiles /var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2.6.2/buildPluginsGtk/CMamarks
make -f CMakeFiles/Makefile2 all
make[1]: Entering directory `/var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2.6.2/build
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2.6.2/buildP
/usr/bin/cmake -E cmake_progress_start /var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2Gtk/CMakeFiles 0
make -f CMakeFiles/Makefile2 preinstall
make[1]: Entering directory `/var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2.6.2/build
make[1]: Nothing to be done for `preinstall'.
make[1]: Leaving directory `/var/tmp/portage/media-video/avidemux-2.6.2/work/avidemux_2.6.2/buildP
chmod: cannot access '/var/tmp/portage/media-video/avidemux-2.6.2/image//usr/bin/avidemux3_jobs': irectory
Comment 16 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-03-17 00:09:52 UTC
The version in question (2.5.*) is masked and won't be unmasked; so, closing this bug.

> chmod: cannot access '/var/tmp/portage/media-video/avidemux-2.6.2/image//usr/bin/avidemux3_jobs': irectory

Please file a new bug for this, it is irrelevant regarding this bug.

Also provide the output of `emerge --info =media-videa/avidemux-2.6.2`.