Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402303 - media-sound/alsa-utils doesn't respect LINGUAS for files in /usr/share/locale, /usr/share/man
Summary: media-sound/alsa-utils doesn't respect LINGUAS for files in /usr/share/locale...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
: 469426 (view as bug list)
Depends on:
Blocks: respect_LINGUAS
  Show dependency tree
 
Reported: 2012-02-05 22:14 UTC by Piotr Szymaniak
Modified: 2014-06-23 22:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Szymaniak 2012-02-05 22:14:02 UTC
When media-sound/alsa-utils-1.0.25 is emerged, it dumps LC_MESSAGES for languages other then selected by 'LINGUAS="en pl"' in my make.conf.

~ (: qlist media-sound/alsa-utils | grep locale
/usr/share/locale/ru/LC_MESSAGES/alsaconf.mo
/usr/share/locale/ja/LC_MESSAGES/alsaconf.mo

Actual Results:  
LC_MESSAGES contains unwanted files

Expected Results:  
LC_MESSAGES should contain only files for selected LINGUAS





$ emerge --info =media-sound/alsa-utils-1.0.25
Portage 2.2.0_alpha85 (default/linux/x86/10.0/desktop, gcc-4.6.2, glibc-2.13-r4, 3.2.2 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.2-i686-Pentium-R-_Dual-Core_CPU_E5400_@_2.70GHz-with-gentoo-2.1
Timestamp of tree: Sun, 05 Feb 2012 19:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.11.2-r1
sys-devel/binutils:       2.22.52.0.1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo multimedia x11 sunrise mgorny roslin gamerlay-stable
Installed sets: @system
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.ift.uni.wroc.pl/"
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl en"
MAKEOPTS="-j3"
PKGDIR="/home/p/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/mgorny /home/lazy_bum/uberlay/roslin /home/lazy_bum/uberlay/gamerlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion bzip2 cairo cdda cdr cli consolekit cracklib crypt cups custom-cflags custom-cxxflags cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gles gpm gtk iconv ipv6 jabber jpeg lcms libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell sse sse2 ssl ssse3 svg sysfs tcpd tiff truetype udev unicode usb vim-syntax vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog cpu cpufreq disk hddtemp network uptime users" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-sound/alsa-utils-1.0.25 was built with the following:
USE="nls -doc -minimal"
Comment 1 Tony Vroon gentoo-dev 2012-02-07 08:29:23 UTC
Is this a regression from 1.0.24.2-r1 to 1.0.25 or has it never worked? Or is it a regression from 1.0.23-r1 to 1.0.24.2-r1 that has carried on into 1.0.25?
Comment 2 Jeroen Roovers gentoo-dev 2012-02-14 16:18:14 UTC
Um, this is taking it a bit too far. If you made it your project to go through the entire tree to look for packages that do not honour LINGUAS, you're going about it the wrong way.

Stop filing these bugs now or only file them for packages you show a clear personal interest for.
Comment 3 Piotr Szymaniak 2012-02-16 21:05:09 UTC
(In reply to comment #1)
> Is this a regression from 1.0.24.2-r1 to 1.0.25 or has it never worked? Or is
> it a regression from 1.0.23-r1 to 1.0.24.2-r1 that has carried on into 1.0.25?

Sincerely — I have no idea. I was a heavy user of localepurge until it came out [1] [2] that it's a bug when a package doesn't respect LINGUAS.

[1] http://archives.gentoo.org/gentoo-dev/msg_69c10fa4b1af60615e49f09e79c63dd1.xml
[2] http://archives.gentoo.org/gentoo-dev/msg_67742e6e10cc2b3dda6fb9f98164bce6.xml
Comment 4 Samuli Suominen gentoo-dev 2014-06-23 22:00:28 UTC
*** Bug 469426 has been marked as a duplicate of this bug. ***
Comment 5 Samuli Suominen gentoo-dev 2014-06-23 22:02:57 UTC
> Samuli Suominen 2014-06-24 01:00:28 EEST Comment 4
> Duplicate of this bug: 469426

It was mentioned in above bug that also alsa-utils installs these items with LINGUAS="en_GB en cs sk ja":

/usr/share/man/fr
/usr/share/man/fr/man8
/usr/share/man/fr/man8/alsaconf.8

So it's both, /usr/share/locale and /usr/share/man. Watch out for more.