Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402245 - sys-fs/dosfstools-3.0.12 dosfslabel does not work if long file names are used in partition
Summary: sys-fs/dosfstools-3.0.12 dosfslabel does not work if long file names are used...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-02-05 10:16 UTC by Sergey Gusarov
Modified: 2018-09-28 12:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
My fix for described problem (dosfslabel_lfn.patch,837 bytes, patch)
2012-02-05 10:16 UTC, Sergey Gusarov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Gusarov 2012-02-05 10:16:35 UTC
Created attachment 300939 [details, diff]
My fix for described problem

I ran into a problem using dosfslabel. The applying of the new label
is broken for not fresh formatted partitions.
In this case dosfslabel creates a second file in root directory with VOLUME attribute.
In addition, the file has other attributes.
Because of this, neither Windows nor Linux does not recognize this new
file and continue to use the old one.
I researched the problem and discovered that the dosfslabel code does
not took into consideration long file name case.
Bug reproduced always with any linux distro.
Patch here.
Comment 1 Samuli Suominen gentoo-dev 2013-01-23 19:12:35 UTC
Has this been reported upstream? I don't see this in the new .14 release. :-/
Comment 2 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-09-28 12:16:53 UTC
seems obsolete