Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402057 - sys-power/apcupsd-3.14.10-r1 - daemon fails to stop during shutdown
Summary: sys-power/apcupsd-3.14.10-r1 - daemon fails to stop during shutdown
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 12:03 UTC by Billy DeVincentis
Modified: 2013-10-18 18:07 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config (apcupsd.conf,12.17 KB, text/plain)
2012-02-04 20:30 UTC, Billy DeVincentis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2012-02-03 12:03:27 UTC
sys-power/apcupsd-3.14.10-r1 always fails to stop during shutdown. I believe the init script needs some tweaking

Reproducible: Always




emerge --info
Portage 2.2.0_alpha84 (default/linux/amd64/10.0/desktop, gcc-4.6.2, glibc-2.14.1-r2, 3.2.2-gentoo x86_64)
=================================================================
System uname: Linux-3.2.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Fri, 03 Feb 2012 06:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.7-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.6.3-r1, 1.9.6-r3, 1.10.3, 1.11.2-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo miscellaneous
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=n"
FEATURES="assume-digests binpkg-logs buildpkg distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                                                                
LANG="en_US.UTF-8"                                                                                                                                                          
LC_ALL="en_US.UTF-8"                                                                                                                                                        
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                           
MAKEOPTS="-j17 -l24"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib accessibility acl acpi aften alsa amd64 animate archive ares artworkextra audio audiofile avahi bash-completion beep berkdb bidi bittorrent bluetooth bookmarks branding bzip2 cairo cdda cddb cdio cdr chm cli clucene consolekit corefonts cpudetection cracklib crypt css cups curl cxx dbus declarative deprecated designer-plugin device-mapper dga directfb discouraged doc dri dts dv dvb dvd dvdnav dvdr ebook eds elisp emacs emboss emerald encode eselect examples exif expat extra-tools extras fam fat fax fbcon fbcondecor ffmpeg firefox flac flash fltk fontconfig foomaticdb fortran ftp fts3 fuse gcj gd gdbm gdu ggi gif gimp glep glib gnome gnutls gphoto2 gpm gstreamer gtk handbook hddtemp hfs hpijs html httpd hwdb hyperestraier iconv idn imagemagick imlib inkjar inotify ipv6 jack jadetex java jfs joystick jpeg jpeg2k kde kdrive kerberos konqueror lame lcms ldap libcaca libnotify libsamplerate live lm_sensors mad mail matroska md5sum mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modules mono mozilla mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql nas nautilus ncurses networking new-login nls npp nptl nptlonly nsplugin ntfs objc odbc offensive ogg openal openexr opengl openmp osdmenu pam pango pcre pdf perl plasma png policykit postgres ppds pppd ps pulseaudio python qt3support qt4 quicktime raptor rar rdesktop readline realmedia reflection regex reiser4 reiserfs reports samba sametime scanner script sdl secure-delete semantic-desktop servletapi session sip skins slang slp smbclient smp sndfile snmp sound speech speex spell sqlite sse sse2 ssl startup-notification static-ppds stream subversion svg swat sysfs syslog tcpd templates themes theora threads thumbnail tidy tiff timidity tk tools truetype udev unicode unsupported usb utils v4l2 vala vcd vdpau vdr video vlm vmware_guest_linux vorbis wav wavpack weather webkit wmf x264 xattr xcb xcomposite xfs xine xml xorg xpm xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-02-04 17:51:40 UTC
Did you mean that the shutdown process hangs? Do you see any useful output? What are the last few lines you see?
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-02-04 17:54:39 UTC
Looks like bug #346561.

You will have to post more information about your apcupsd configuration.
Comment 3 Billy DeVincentis 2012-02-04 20:30:06 UTC
Created attachment 300925 [details]
config
Comment 4 Billy DeVincentis 2012-02-04 20:32:01 UTC
can't say for sure if it's related to the other bug mentioned but I can tell you that it always turns my framebuffer splash to silent because of the error  of it not stopping and it always says the same thing ,apcupsd refused to stop
Comment 5 Billy DeVincentis 2012-02-04 20:34:38 UTC
Feb  1 08:10:56 Linux1 apcupsd[5745]: apcupsd exiting, signal 15
Feb  1 08:11:01 Linux1 /etc/init.d/apcupsd[19421]: start-stop-daemon: 1 process refused to stop
Feb  1 08:11:01 Linux1 /etc/init.d/apcupsd[19411]: ERROR: apcupsd failed to stop

from messages log
Comment 6 Aidan Marks 2012-05-19 22:26:29 UTC
At the risk of this being a different bug and hijacking this report, apcupsd is now failing to start for me.  It was working fine for the last couple of years:

wumpyr ~ # lsusb | grep American
Bus 001 Device 003: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
wumpyr ~ # equery l apcupsd
 * Searching for apcupsd ...
[IP-] [  ] sys-power/apcupsd-3.14.10-r1:0
wumpyr ~ # /etc/init.d/apcupsd start
 * Starting APC UPS Daemon ...
 * start-stop-daemon: did not create a valid pid in `/var/run/apcupsd.pid'
 * Failed to start apcupsd                                                                                                                                                                                                                                                                                             [ !! ]
 * ERROR: apcupsd failed to start
wumpyr ~ #
wumpyr ~ # grep -v '^#' /etc/apcupsd/apcupsd.conf |grep -v '^$'
UPSCABLE usb
UPSTYPE usb
DEVICE 
LOCKFILE /var/lock
SCRIPTDIR /etc/apcupsd
PWRFAILDIR /etc/apcupsd
NOLOGINDIR /etc
ONBATTERYDELAY 6
BATTERYLEVEL 5
MINUTES 3
TIMEOUT 0
ANNOY 300
ANNOYDELAY 60
NOLOGON disable
KILLDELAY 0
NETSERVER on
NISIP 0.0.0.0
NISPORT 3551
EVENTSFILE /var/log/apcupsd.events
EVENTSFILEMAX 10
UPSCLASS standalone
UPSMODE disable
STATTIME 0
STATFILE /var/log/apcupsd.status
LOGSTATS off
DATATIME 0
wumpyr ~ #
wumpyr ~ # tail /var/log/messages
May 20 08:15:22 wumpyr apcupsd[8648]: apcupsd error shutdown completed
May 20 08:15:22 wumpyr /etc/init.d/apcupsd[8646]: start-stop-daemon: did not create a valid pid in `/var/run/apcupsd.pid'
May 20 08:15:22 wumpyr /etc/init.d/apcupsd[8636]: ERROR: apcupsd failed to start
May 20 08:16:50 wumpyr apcupsd[8671]: Lock file data error: 
May 20 08:16:50 wumpyr apcupsd[8671]: apcupsd FATAL ERROR in apcupsd.c at line 285
May 20 08:16:50 wumpyr Failed to acquire device lock file
May 20 08:16:50 wumpyr apcupsd[8671]: Lock file data error: 
May 20 08:16:50 wumpyr apcupsd[8671]: apcupsd error shutdown completed
May 20 08:16:50 wumpyr /etc/init.d/apcupsd[8669]: start-stop-daemon: did not create a valid pid in `/var/run/apcupsd.pid'
May 20 08:16:50 wumpyr /etc/init.d/apcupsd[8659]: ERROR: apcupsd failed to start
wumpyr ~ # 
wumpyr ~ # ls -la /var/run/apcupsd.pid
ls: impossibile accedere a /var/run/apcupsd.pid: File o directory non esistente
wumpyr ~ #
wumpyr ~ # emerge --info
Portage 2.2.0_alpha107 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.15-r2, 3.3.5-gentoo x86_64)
=================================================================
System uname: Linux-3.3.5-gentoo-x86_64-Intel-R-_Core-TM-_i3-2100T_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sat, 19 May 2012 14:00:02 +0000
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo sunrise local_overlay
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.3 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build=n"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.iinet.net.au/linux/Gentoo/ ftp://ftp.swin.edu.au/gentoo"
LANG="it_IT@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/nas/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi amd64 asf bash-completion berkdb bzip2 cli cracklib crypt cups cxx dbus dri dts dvb dvd ffmpeg flac fortran gdbm gpm iconv ipv6 jpeg kde kdehiddenvisibility live logrotate matroska mmx mmxext modules mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf plasma png pppd readline session sse sse2 ssl svg tcpd theora tiff truetype truetype-fonts type1-fonts unicode wmf x264 xinetd xorg xulrunner xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB it" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 7 Billy DeVincentis 2012-07-04 19:21:33 UTC
Okay, I have solved the problem by building in usb support in my kernel and not building usb support as modules but the bug will still affect all who have usb support as modules
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-04 19:29:04 UTC
Ah, hm, now that explains why I was unable to reproduce. Now that I know why it happens I'll see if I can reproduce and solve it.
Comment 9 Billy DeVincentis 2012-07-05 01:16:59 UTC
I'm not sure but there seems to be more problems with not having usb support built into the kernel. I use a framebuffer splash and I was no longer able to switch between silent and verbose with f2 now with the new grub2. After building support in, all works correctly. Maybe it's time to reccommend building usb support into kernel.
Comment 10 Tony Vroon gentoo-dev 2013-10-18 18:07:08 UTC
A good rule of thumb for where to use kernel modules is that it allows you to load & unload drivers for hot-pluggable components. The USB controller is an integral part of the mainboard that cannot be removed. It would be convention to build this into the kernel proper.
This is certainly the first I have heard of anyone trying to unload drivers that fundamental to system operation during the shutdown sequence, and as you have found it is very unlikely to work correctly.

I support the change you have made, but do not believe we have any misleading documentation on this subject that could have lead you down this path.