Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 402027 - dev-python/django-1.3.1 with dev-python/psycopg-2.4.2 fails app/project tests
Summary: dev-python/django-1.3.1 with dev-python/psycopg-2.4.2 fails app/project tests
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL: https://code.djangoproject.com/ticket...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 05:42 UTC by Alex
Modified: 2015-02-28 13:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2012-02-03 05:42:55 UTC
according to https://code.djangoproject.com/ticket/16250 django has bug with running django tests when dev-python/psycopg-1.4.2 is used as database backend.

Reproducible: Always
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2012-02-25 11:36:16 UTC
Before I go making patches; can you get the nature of the content straightened out first?

Summary cites dev-python/psycopg-1.4.2.
You cite dev-python/psycopg-1.4.2 in the Description.
Hit the link, and

Ticket #16250 (closed Bug: fixed) 

Last modified 5 weeks
Error with new pyscopg2 2.4.2 release and tests

culminating in 

The easiest solution is to use psycopg2 2.4.1.
In summary, psycopg-1.4.2 ~= psycopg2 2.4.1.
Comment 2 Doug Goldstein gentoo-dev 2012-04-28 20:34:37 UTC
So it appears you can not run project or app tests with psycopg-2.4.2 and Django 1.3.x. They do not intend on fixing this in the 1.3.x series since its an API change in psycopg. They recommend people just stick with psycopg-2.4.1 or go to Django 1.4.x. Or just skip their app/project tests on setups configured like this and run tests elsewhere. 

Not sure how we want to handle this in Gentoo. Maybe an ewarn in the Django package when installing with psycopg-2.4.2.
Comment 3 Doug Goldstein gentoo-dev 2012-04-28 20:35:29 UTC
I should note this does not affect the Django test suite which is run with FEATURES=test during emerge.
Comment 4 Justin Lecher gentoo-dev 2015-02-28 13:51:47 UTC
All affected version of django and psycopg removed from tree. Please reopen if still exists.