Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 401339 - sys-fs/zfs-fuse-0.6.9 with glibc-2.14 (patch)
Summary: sys-fs/zfs-fuse-0.6.9 with glibc-2.14 (patch)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Parpart (RETIRED)
URL:
Whiteboard:
Keywords: PATCH
: 380749 (view as bug list)
Depends on:
Blocks: 358697 glibc-rpc
  Show dependency tree
 
Reported: 2012-01-29 15:59 UTC by Tommy Pettersson
Modified: 2012-06-23 22:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
new ebuild (zfs-fuse-0.6.9-r2.ebuild,1.38 KB, text/plain)
2012-01-29 16:01 UTC, Tommy Pettersson
Details
patch to make zfs-fuse build with both glibc 2.13 and 2.14 (zfs-fuse-0.6.9-libumem-remove-hooks.patch,2.42 KB, text/plain)
2012-01-29 16:02 UTC, Tommy Pettersson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy Pettersson 2012-01-29 15:59:40 UTC
This is a first step to keep zfs-fuse in gentoo. It is a minimal change just to make the package build with the newer glibc. The patch is from libumem upstream, and it has worked stable during daily use for a couple of days now. I plan to address the other open issues later.

Reproducible: Always
Comment 1 Tommy Pettersson 2012-01-29 16:01:15 UTC
Created attachment 300279 [details]
new ebuild
Comment 2 Tommy Pettersson 2012-01-29 16:02:01 UTC
Created attachment 300281 [details]
patch to make zfs-fuse build with both glibc 2.13 and 2.14
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2012-02-03 22:30:45 UTC
*** Bug 380749 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2012-02-26 17:58:23 UTC
Closing since zfs-fuse was removed from tree. But adding bug 358697 to Blocks: -line since if the package is reintroduced to tree, this one should get fixed too.