Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 401331 - app-office/dia with >=dev-libs/glib-2.31 - /usr/include/glib-2.0/glib/gstrfuncs.h:28:2: error: #error "Only <glib.h> can be included directly."
Summary: app-office/dia with >=dev-libs/glib-2.31 - /usr/include/glib-2.0/glib/gstrfun...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GNOME Office (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 407285 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-01-29 15:08 UTC by Maciej Piechotka
Modified: 2012-04-08 01:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed patch (dia-0.97-glib_h-fix.patch,1.45 KB, patch)
2012-03-09 01:10 UTC, Göktürk Yüksek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2012-01-29 15:08:31 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../intl -I../../lib -pthread -DORBIT2=1 -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/libdrm -I/usr/include/libxml2 -I/usr/include/libart-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/orbit-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libgnomeui-2.0 -I/usr/include/gnome-keyring-1 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gail-1.0 -pthread -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -DDIA_SHAPEDIR=\"/usr/share/dia/shapes\" -I/usr/include/libxml2 -I/usr/include/freetype2 -O2 -pipe -ggdb -march=native -msahf -mcx16 -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -w -floop-interchange -floop-strip-mine -floop-block -floop-flatten -ftree-loop-linear -ftree-loop-im -ftree-loop-distribution -ftree-loop-distribute-patterns -fsched-pressure -fsched-spec-load -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -c shape_typeinfo.c  -fPIC -DPIC -o .libs/shape_typeinfo.o
In file included from shape_typeinfo.c:30:0:
/usr/include/glib-2.0/glib/gstrfuncs.h:28:2: error: #error "Only <glib.h> can be included directly."
make[3]: *** [shape_typeinfo.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/paludis/app-office-dia-0.97.2/work/dia-0.97.2/objects/custom'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/app-office-dia-0.97.2/work/dia-0.97.2/objects'
make[1]: Leaving directory `/var/tmp/paludis/app-office-dia-0.97.2/work/dia-0.97.2'
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
Comment 1 tman 2012-03-02 21:38:28 UTC
i can confirm this problem too

libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../intl -I../../lib -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -I/usr/include/libxml2 -I/usr/include/libart-2.0 -pthread -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -DDIA_SHAPEDIR=\"/usr/share/dia/shapes\" -I/usr/include/libxml2 -I/usr/include/freetype2 -march=core2 -O2 -pipe -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -c custom_object.c  -fPIC -DPIC -o .libs/custom_object.o
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../intl -I../../lib -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -I/usr/include/libxml2 -I/usr/include/libart-2.0 -pthread -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -DDIA_SHAPEDIR=\"/usr/share/dia/shapes\" -I/usr/include/libxml2 -I/usr/include/freetype2 -march=core2 -O2 -pipe -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -c shape_typeinfo.c  -fPIC -DPIC -o .libs/shape_typeinfo.o
custom_object.c: In function ‘custom_setup_properties’:
custom_object.c:382:7: warning: passing argument 1 of ‘(info->props + (long unsigned int)((long unsigned int)i * 88ul))->ops->get_data_size’ from incompatible pointer type
custom_object.c:382:7: note: expected ‘struct Property *’ but argument is of type ‘struct PropDescription *’
custom_object.c: In function ‘custom_draw_element’:
custom_object.c:911:26: warning: comparison between ‘LineCaps’ and ‘enum DiaSvgLineDefaults’
custom_object.c:913:39: warning: comparison between ‘LineCaps’ and ‘enum DiaSvgLineDefaults’
custom_object.c:917:26: warning: comparison between ‘LineJoin’ and ‘enum DiaSvgLineDefaults’
custom_object.c:919:38: warning: comparison between ‘LineJoin’ and ‘enum DiaSvgLineDefaults’
custom_object.c:923:28: warning: comparison between ‘LineStyle’ and ‘enum DiaSvgLineDefaults’
custom_object.c:925:40: warning: comparison between ‘LineStyle’ and ‘enum DiaSvgLineDefaults’
In file included from shape_typeinfo.c:30:0:
/usr/include/glib-2.0/glib/gstrfuncs.h:28:2: error: #error "Only <glib.h> can be included directly."
make[3]: *** [shape_typeinfo.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/app-office/dia-0.97.2/work/dia-0.97.2/objects/custom'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-office/dia-0.97.2/work/dia-0.97.2/objects'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-office/dia-0.97.2/work/dia-0.97.2'
make: *** [all] Error 2
 * ERROR: app-office/dia-0.97.2 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =app-office/dia-0.97.2',
 * the complete build log and the output of 'emerge -pqv =app-office/dia-0.97.2'.
 * The complete build log is located at '/var/log/portage/app-office:dia-0.97.2:20120302-195213.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/dia-0.97.2/temp/environment'.


Portage 2.2.0_alpha89_p5 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r2, 3.2.6-gentoo x86_64)
=================================================================
System uname: Linux-3.2.6-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P9700_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Fri, 02 Mar 2012 19:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          9999
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2-r1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo mpd science wirelay scarabeus Techwolf luman nikai emacs java-overlay gnome mgorny qt poly-c lokal
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en vi"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
Comment 2 Samuli Suominen gentoo-dev 2012-03-07 14:51:07 UTC
*** Bug 407285 has been marked as a duplicate of this bug. ***
Comment 3 Göktürk Yüksek gentoo-dev 2012-03-09 01:10:36 UTC
According to glib 2.31.0 changelog[0]:
  * It is no longer possible to include individual headers (like
  "ghash.h") -- you must #include <glib.h>.

Can you test the attached patch?

[0] http://mail.gnome.org/archives/gnome-announce-list/2011-October/msg00041.html
Comment 4 Göktürk Yüksek gentoo-dev 2012-03-09 01:10:56 UTC
Created attachment 304687 [details, diff]
Proposed patch
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-04-08 01:15:06 UTC
(In reply to comment #4)
> Created attachment 304687 [details, diff] [details, diff]

That patch is wrong, glib/gstdio.h should still be #included separately.
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-04-08 01:20:20 UTC
Thank you all for reporting. The issue has been fixed in cvs without a revision bump; patch submitted upstream at https://bugzilla.gnome.org/show_bug.cgi?id=673712

>  08 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> dia-0.97.2.ebuild,
>  +files/dia-0.97.2-glib-2.31.patch:
>  Fix building against >=glib-2.31 (bug #401331, thanks to Maciej Piechotka for
>  reporting).