Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 399777 - sys-kernel/gentoo-sources-3.1.6: Ethernet device r8169 locks up after some use (NETDEV WATCHDOG transmit queue timed out)
Summary: sys-kernel/gentoo-sources-3.1.6: Ethernet device r8169 locks up after some us...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2012-01-22 21:26 UTC by Guido Winkelmann
Modified: 2012-03-16 00:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

dmesg output from after the problem occured (netcrash-20120122,46.97 KB, text/plain)
2012-01-22 21:28 UTC, Guido Winkelmann
dmesg output from 3.2.1-r2 (netcrash-20120126,44.70 KB, text/plain)
2012-01-26 19:51 UTC, Guido Winkelmann

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Winkelmann 2012-01-22 21:26:44 UTC
With sys-kernel/gentoo-sources-3.1.6, my r8169 ethernet device will completely stop sending and/or receiving packets after some minutes or hours of use.

Reproducible: Always

Steps to Reproduce:
1. Boot system with Kernel 3.1.6-gentoo
2. Use normally for a few minutes to hours
Actual Results:  
After some seemingly random time, all network activity will come to a sudden an abrupt stop.

Expected Results:  
The network device should keep working.

This issue appears to be new in 3.1.6. I've had it happen twice to me now, before switching back to 3.0.6.

The ethernet device is the on-board ethernet of a Gigabyte GA-990FXA-UD§ mainboard. lspci will list it as

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

I have tried unplugging and replugging the network as well as doing "ifconfig eth0 down; ifconfig eth0 up", neither of which solved the problem. The only way I could find to regain network connectivity was to reboot.
Comment 1 Guido Winkelmann 2012-01-22 21:28:27 UTC
Created attachment 299571 [details]
dmesg output from after the problem occured

This is the output dmesg gave after the problem occured.
Comment 2 Guido Winkelmann 2012-01-26 19:51:53 UTC
Created attachment 299999 [details]
dmesg output from 3.2.1-r2

The problem is still there in 3.2.1-r2, as can be seen in this dmesg output.
Comment 3 Mike Pagano gentoo-dev 2012-03-04 21:34:12 UTC
Please test with vanilla-sources 3.2.9 and then bring to and post the url back here.
Comment 4 Guido Winkelmann 2012-03-13 13:29:12 UTC
Posted to bugzilla as
Comment 5 Mike Pagano gentoo-dev 2012-03-16 00:21:25 UTC
Thanks, we'll watch the upstream bug and attempt to back port any fix identified.