Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 399739 - dev-db/libdbi-drivers-0.8.3 fails to return column information for empty sqlite3 table
Summary: dev-db/libdbi-drivers-0.8.3 fails to return column information for empty sqli...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Robin Johnson
URL: https://bugzilla.balabit.com/show_bug...
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-01-22 15:37 UTC by Patrick
Modified: 2014-01-11 21:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
libdbi-drivers-0.8.3-sqlite3-fix (libdbi-drivers-0.8.3-sqlite3-fix.patch,734 bytes, patch)
2012-01-22 15:39 UTC, Patrick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick 2012-01-22 15:37:58 UTC
I ran across this bug trying to use a sqlite3 database with syslog-ng (see url for syslog-ng bug report). The fix for the issue has been in upstream's CVS repo for almost 4 years now, but no build has been released. I created a new ebuild based off libdbi-drivers-0.8.3-r2 with the attached patch and the issue has been resolved.

Can this patch be integrated into the ebuild?
Would it also be possible to mark the build as stable some time soon? Not a requirement, but syslog-ng cant use sqlite3 databases without this fix.

Reproducible: Always
Comment 1 Patrick 2012-01-22 15:39:40 UTC
Created attachment 299535 [details, diff]
libdbi-drivers-0.8.3-sqlite3-fix
Comment 2 Patrick 2012-09-22 18:58:10 UTC
It's been 8 months since this was reported, and a patch has even been provided. Can this get some attention please?
Comment 3 Patrick 2012-10-26 12:33:07 UTC
10 months, no activity. Re-adding bug-wranglers. Can this please get some attention.
Comment 4 Jeroen Roovers gentoo-dev 2012-10-26 16:54:27 UTC
Bug wranglers cannot help you with stale bugs.
Comment 5 Pacho Ramos gentoo-dev 2014-01-11 21:31:05 UTC
Please try with 0.9 version