Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 398599 - app-office/libreoffice-3.4.5.2 fails to open a document saved with password under earlier version
Summary: app-office/libreoffice-3.4.5.2 fails to open a document saved with password u...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
: 407463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-12 05:03 UTC by Yanestra
Modified: 2012-03-13 07:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
LibreOffice spreadsheet protected with password (testsheet1.ods,6.51 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-13 03:18 UTC, Yanestra
Details
testsheet2.ods (testsheet2.ods,6.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-20 11:52 UTC, Chí-Thanh Christopher Nguyễn
Details
emerge --info libreoffice (emerge--infolibreoffice.txt,5.32 KB, text/plain)
2012-01-20 11:54 UTC, Chí-Thanh Christopher Nguyễn
Details
emerge --info libreoffice (x,5.30 KB, text/plain)
2012-01-20 17:33 UTC, Yanestra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yanestra 2012-01-12 05:03:45 UTC
When I try to open a document (in this case a Calc spreadsheet) saved with an earlier version (3.4.3.2), the password given by me is prompted as being wrong. I stepped back to 3.4.3.2 and succeeded in opening the document, but 3.4.5.2 won't.

Reproducible: Didn't try
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2012-01-12 13:43:35 UTC
Hello, by any chance are you able to put the document here as an attachment? (if I won't manage to reproduce it by any of mine this might help a bit).
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2012-01-12 13:57:20 UTC
Okey i am unable to reproduce with any test document i create;

could you try to update and tell me what version exactly you have? In about dialog there should be something like OOO340m1 (Build:502).
Comment 3 Yanestra 2012-01-13 03:18:25 UTC
Created attachment 298811 [details]
LibreOffice spreadsheet protected with password

The password is 'yanestra' (without quotes). Written with 3.4.3.2, newer version 3.4.5.2 won't open.
Comment 4 Yanestra 2012-01-13 03:22:21 UTC
Gentoo 3.4.3.2 translates into:
OOO340m1 (Build:302)

Gentoo 3.4.5.2 translates into:
OOO340m1 (Build:502)

I have created an attachment with a test case. Please consider the problem as reproducible now.

It appears, the attached file cannot be opened with the newer version of LibreOffice. Try so, password is 'yanestra' (without quotes).

It was written with version 3.4.3.2 which can also read it without problems.
Comment 5 Yanestra 2012-01-13 10:20:46 UTC
Cross-check with LibreOffice 3.4.3 (Build 302) and 3.4.5rc2 (Build 502) under Windows/x86: With both, you can open the ODS file.
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-01-20 11:52:34 UTC
Created attachment 299381 [details]
testsheet2.ods

libreoffice-3.4.5.2 (amd64) can open this file fine.
Attached is the result of saving it again without modification and with the same password.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-01-20 11:54:06 UTC
Created attachment 299383 [details]
emerge --info libreoffice
Comment 8 Yanestra 2012-01-20 17:33:21 UTC
Created attachment 299405 [details]
emerge --info libreoffice

emerge --info libreoffice
Comment 9 Yanestra 2012-01-20 17:52:38 UTC
I have used current /usr/portage and problem remains the same.
Comment 10 Yanestra 2012-01-23 17:21:19 UTC
Got a try with 3.5.0rc1 (350m1 Build:11) i.e. Gentoo app-office/libreoffice-3.5.0.1:

Works flawlessly.

So, the only version causing trouble appears to be 3.4.5.2. I think, one could consider masking 3.4.5.2 as soon as 3.5 is available.
Comment 11 Marco Leogrande 2012-03-01 05:39:17 UTC
I would like to add that the binary version (app-office/libreoffice-bin-3.4.5.2-r1) is, as of today, affected by the same bug.
Comment 12 Yanestra 2012-03-01 15:09:45 UTC
Sigh, this communication is that speedy, that I can expect a solution for late 2013. Closed - nobody cares anyway.
Comment 13 Tomáš Chvátal (RETIRED) gentoo-dev 2012-03-01 18:30:32 UTC
So what do you expect me to do.

I spent debugging this issue for 12 hours of clear time already.

the problem is that the required .so libraries where the error occurs are the one that are not respecting the ldflags/cflags so even with debug enabled I can't see the symbols that are the problematic ones.

If I update to 3.5 which is the version where I made the symbols visible I can't reproduce the problem so it is useless.

As you already said the bug IS fixed in 3.5 which I can confirm, so just update to that version or try to debug it yourself to see if you manage to obtain the debugsymbols.

The bug is also reported upstream and is present on debian so since my C++ foo is too low for it hope debianers or upstream will work it out.

Sadly it is not reproducable on windows which is the most important platform for upstream (before you ask just think who is probably only one paying for the development [yep windows corporate users]).
Comment 14 Tomáš Chvátal (RETIRED) gentoo-dev 2012-03-13 07:59:48 UTC
*** Bug 407463 has been marked as a duplicate of this bug. ***