Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 398521 - =app-office/libreoffice-3.4.5.2 and related ebuilds stabilisation
Summary: =app-office/libreoffice-3.4.5.2 and related ebuilds stabilisation
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 398557
Blocks:
  Show dependency tree
 
Reported: 2012-01-11 12:28 UTC by Tomáš Chvátal (RETIRED)
Modified: 2013-10-06 15:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal (RETIRED) gentoo-dev 2012-01-11 12:28:47 UTC
app-text/sampleicc-1.6.4                 amd64      ppc       x86
media-libs/libvisio-0.0.12               amd64      ppc       x86
dev-libs/hyphen-2.8.3                    amd64 hppa ppc ppc64 x86
dev-cpp/libcmis-0.1.0                    amd64      ppc       x86
app-text/mythes-1.2.2                    amd64      ppc       x86
app-text/libexttextcat-3.2.0             amd64      ppc       x86
app-office/libreoffice-l10n-3.4.5-r1     amd64      ppc       x86
app-office/libreoffice-3.4.5.2           amd64      ppc       x86
app-office/imposter-0.3                  amd64

The list ^

Now more work for arches:

I can't generate the binaries this time so you can generate them on your stable boxes. The script is in files/generate_libreoffice_package.sh,
you just run it and it generates few files that need to be put somewhere (devspace), where i will link them in the lo-bin.
(this is purely optional, if you don't want users to have binaries available on your arch then don't do this).
Comment 1 Agostino Sarubbo gentoo-dev 2012-01-11 14:47:26 UTC
@scarabeus, please fix on the fly:

 * QA Notice: USE Flag 'templates' not in IUSE for app-office/libreoffice-3.4.5.2
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2012-01-11 14:51:18 UTC
The templates copy/pasto fixed.
Comment 3 Agostino Sarubbo gentoo-dev 2012-01-11 15:58:54 UTC
updated list(sorted):

=app-office/imposter-0.3                  amd64                                                                                                                                     
=app-office/libreoffice-3.4.5.2           amd64      ppc       x86                                                                                                                  
=app-office/libreoffice-l10n-3.4.5-r1     amd64      ppc       x86                                                                                                                  
=app-text/libexttextcat-3.2.0             amd64      ppc       x86                                                                                                                  
=app-text/mythes-1.2.2                    amd64      ppc       x86                                                                                                                  
=dev-cpp/libcmis-0.1.0                    amd64      ppc       x86                                                                                                                  
=dev-libs/hyphen-2.8.3                    amd64 hppa ppc ppc64 x86                                                                                                                  
=dev-libs/jemalloc-2.2.5                  amd64      ppc ppc64 x86                                                                                                                  
=media-libs/libvisio-0.0.12               amd64      ppc       x86                                                                                                                  
=media-libs/sampleicc-1.6.4               amd64      ppc       x86
Comment 4 Maurizio Camisaschi (amd64 AT) 2012-01-12 15:14:56 UTC
please check for rdepend, scanelf shows some that are missing in the ebuilds

=app-office/libreoffice-3.4.5.2 
dev-libs/atk-1.32.0-r1
media-libs/mesa-7.11.2
x11-libs/gdk-pixbuf-2.24.0-r1
x11-libs/libICE-1.0.7
x11-libs/libSM-1.2.0
x11-libs/libX11-1.4.4
x11-libs/libXext-1.3.0
x11-libs/pango-1.28.4

=app-office/imposter-0.3
sys-libs/zlib-1.2.5-r2
x11-libs/gdk-pixbuf-2.24.0-r1
x11-libs/pango-1.28.4
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2012-01-16 08:11:14 UTC
(In reply to comment #4)
> please check for rdepend, scanelf shows some that are missing in the ebuilds
> 
> =app-office/libreoffice-3.4.5.2 
> dev-libs/atk-1.32.0-r1
Dunno, but i don't have atk here so i have to question configure.ac

> media-libs/mesa-7.11.2
virtual/opengl?

> x11-libs/libICE-1.0.7
> x11-libs/libSM-1.2.0
> x11-libs/libX11-1.4.4
> x11-libs/libXext-1.3.0
These probably need to depend on proto headers too. Consult configure.in as it is most probably lacking them so maybe even upstream patch is applicable.

> x11-libs/pango-1.28.4
> x11-libs/gdk-pixbuf-2.24.0-r1
Gtk only related, needs checking?

Feel free to open separate bug with proper patch.

> 
> =app-office/imposter-0.3
> sys-libs/zlib-1.2.5-r2
> x11-libs/gdk-pixbuf-2.24.0-r1
> x11-libs/pango-1.28.4

Feel free to write patch against this package in separate bug again.
Comment 6 Agostino Sarubbo gentoo-dev 2012-01-16 11:57:15 UTC
amd64 stable
Comment 7 Agostino Sarubbo gentoo-dev 2012-01-16 11:59:22 UTC
Sorry Tom, but imho, the script does not work as well, because first should make the binary with general CFLAGS and second, it does not respect local var like PKGDIR.
I try to make a binary when I have time to check the script and make the binary ;)
Comment 8 David Abbott gentoo-dev 2012-01-20 09:03:54 UTC
Tested on x86, all good here.
Here are the -bin if needed/wanted
http://gentoo-pr.org/libreo/libreo/
Comment 9 Tomáš Chvátal (RETIRED) gentoo-dev 2012-01-20 11:37:23 UTC
(In reply to comment #8)
> Tested on x86, all good here.
> Here are the -bin if needed/wanted
> http://gentoo-pr.org/libreo/libreo/

I get 403 on some of those files. Check permissions :)
Comment 10 David Abbott gentoo-dev 2012-02-04 22:31:08 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Tested on x86, all good here.
> > Here are the -bin if needed/wanted
> > http://gentoo-pr.org/libreo/libreo/
> 
> I get 403 on some of those files. Check permissions :)

Hi Tomas,
Should be fixed.
Comment 11 Andreas K. Hüttel archtester gentoo-dev 2012-02-25 15:35:27 UTC
Here's an updated list. In particular it now also includes fresh binary packages. The -bin-debug package contains only the splitdebugfiles from the /usr/lib/debug tree for each build.

Please give especially the binary packages a good testing, they are really fresh from the compiler and as you remember from last try mistakes may happen...

=app-office/libreoffice-3.4.5.2                          ppc       x86
=app-office/libreoffice-bin-3.4.5.2-r1        amd64                x86
=app-office/libreoffice-bin-debug-3.4.5.2-r1  amd64                x86
=app-office/libreoffice-l10n-3.4.5-r1                    ppc       x86
=app-text/libexttextcat-3.2.0                            ppc       x86
=app-text/mythes-1.2.2                                   ppc       x86
=dev-cpp/libcmis-0.1.0                                   ppc          
=dev-libs/hyphen-2.8.3                                   ppc ppc64    
=dev-libs/jemalloc-2.2.5                                 ppc ppc64 x86       
=media-libs/libvisio-0.0.14-r1                           ppc          
=media-libs/sampleicc-1.6.4                              ppc
Comment 12 Maurizio Camisaschi (amd64 AT) 2012-03-01 15:25:11 UTC
(In reply to comment #11)
> =app-office/libreoffice-bin-3.4.5.2-r1        amd64               
> =app-office/libreoffice-bin-debug-3.4.5.2-r1  amd64               

amd64 ok
Comment 13 Agostino Sarubbo gentoo-dev 2012-03-02 15:17:23 UTC
amd64 stable
Comment 14 Dan Dexter 2012-03-25 22:04:24 UTC
While archtesting for x86, I noticed two segfaults in dmesg for libreoffice-bin. I managed to reproduce it once but I'm having a hard time narrowing down what is causing it.

I opened a new ticket (bug 409699) and have it blocking this one. The application works as intended despite the segfault while exiting and it's difficult to reproduce, so if this is not an issue for stabilizing app-office/libreoffice-bin-3.4.5.2-r1 then please unblock.

I was not able to reproduce the issue on stable libreoffice-bin but this may be due to the fact it's difficult to reproduce in general.
Comment 15 Tomáš Chvátal (RETIRED) gentoo-dev 2012-04-10 08:48:01 UTC
Move t bug https://bugs.gentoo.org/show_bug.cgi?id=411449